5,606,779 Members 38,186 Now Online
XDA Developers Android and Mobile Development Forum

Parts of screen not responding to touch and other issues with screen and battery

Tip us?
 
Unreal_628
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 8
Join Date: Apr 2011
Location: Brisbane
Default Parts of screen not responding to touch and other issues with screen and battery

Hi, about 2 weeks ago my phone began to run into some rather odd problems which I suspect are all related and may or may not be to do with water damage as these problems started soon after i was at the beach and my phone got a little wet being in my pocket.

The first problem I am having and also the most critical is that part of the touch screen (just under the notification for about 5m) will not respond to any touches. This itself is not such a big problem. However after a random amount of time from when I boot the phone up the touch input kinda "moves up". For example, I click on the dock bar and it's as if I am click halfway up the screen. This of course makes the phone unusable to a large degree and the only way I can seem to fix it is by restarting the phone, which leads to problem two.

Now problem two is that the phone will continually boot loop until I connect the phone to a power source. I can still get into the hboot etc but not much more than that.

I suspect both, or at least problem two to be due to a battery problem and so I have ordered a replacement battery but that wont be coming for a while yet.

I've also tried several different roms, wiping the cache and delvik, re flashing the boot along with several hours of googling the problem but that came up with nothing related to my issue.

So any help or input someone could give me would be great, thanks in advance.
The Following User Says Thank You to Unreal_628 For This Useful Post: [ Click to Expand ]
 
Stevemotto
Old
#2  
Stevemotto's Avatar
Senior Member
Thanks Meter 53
Posts: 379
Join Date: Dec 2011
Location: Sydney
Seems like a hardware problem to me. If you still have warranty, send it in for repair.

Sent from my Legend using xda premium
HTC Legend : CM 7.1 Overclocked 806 MHZ
 
tataenozec
Old
#3  
tataenozec's Avatar
Member
Thanks Meter 5
Posts: 48
Join Date: Apr 2012
agree
 
gmo_omg
Old
#4  
Junior Member
Thanks Meter 3
Posts: 18
Join Date: Oct 2010
Yes I had the same problem too... I brought it to HTC Hong Kong (i live here) and had to pay them about 150 USD to get it replaced.. a while later it happened again and they fixed it free under the 3 month warranty. I just got it back and I really hope it doesn't happen again.
 
haririan
Old
#5  
haririan's Avatar
Member
Thanks Meter 0
Posts: 35
Join Date: Aug 2011
I have the same problem,What did you do at last? did the battery replacement solved your problem?!!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes