FORUMS

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

Sunday Debate: How Can We Get a No-Compromise Phone?

Join us in a fun Sunday Debate on Compromises. Come with your opinions and … more

[REF] Known identified battery drainers

13,888 posts
Thanks Meter: 25,326
 
By Entropy512, Senior Recognized Developer on 18th October 2011, 02:22 AM
Post Reply Subscribe to Thread Email Thread
17th April 2012, 05:38 PM |#631  
Senior Member
Flag Reykjavik
Thanks Meter: 183
 
More
Guys, please help me. I have been having trouble with drains for a very long time. I'm really exhausted, really thinking about uninstalling all apps, start from scratch and install only one app by one. But that would take a REALLY long time.

I'm running a custom ROM (HyDrOG3N-ICS) and Siyah kernel (latest). This has nothing/little to do with that, because I've tried several other ROMs/kernels. Always the same/similiar problem. Also other users are experiencing great battery life with these two.

No CPU/GPU undervolt going on. I use the ondemand governor.
I have a "Screen off" profile that sets the CPU max_freq to 200 MHz.
I have a "Screen on" profile that sets the CPU max_freq to 1000 MHz and min_freq to 200 MHz.

I have tried to turn off WiFi, it didn't change much.

I have only sync on Gmail, calendar and contacts.

I have seen gprs.data-stall wakelock a lot lately. Even though I have mobile data disabled at all times.

I have GTALK_ASYNC_CONN wakelocks even though I froze Talk app with TiBU.

I did a cat /proc/wakelocks > wakelocks.txt and put it into a PDF in the attachments.

In attachments are also my WireShark and dmesg and BBS dumps

BBS dump in attachment not working, here it is: http://pastebin.com/W3iAw5Ui

192.168.1.20 is my phone.
I filtered the WireShark dump with this:
ip.src == 192.168.1.20 || ip.dst == 192.168.1.20
Because I was getting a lot of other network data.

Here are some screenshots:
http://imgur.com/a/cyhSO

As you can probably see in wakelocks.pdf battery-sec-monitor is getting very high wake_count. Don't know what that is.

PLEASE help me get to the bottom of this.
Last edited by gaui; 17th April 2012 at 06:18 PM.
 
 
17th April 2012, 05:53 PM |#632  
mzaur's Avatar
Senior Member
NJ
Thanks Meter: 58
 
More
The BBS log you posted isn't working. Says 404 page not found... Repost a working BBS log. The best ones are where you unplug at night and then leave your phone overnight untouched, and then save log in the morning before doing anything else.
Last edited by mzaur; 17th April 2012 at 05:56 PM.
17th April 2012, 06:18 PM |#633  
Senior Member
Flag Reykjavik
Thanks Meter: 183
 
More
Quote:
Originally Posted by mzaur

The BBS log you posted isn't working. Says 404 page not found... Repost a working BBS log. The best ones are where you unplug at night and then leave your phone overnight untouched, and then save log in the morning before doing anything else.

Sorry mate, here...

http://pastebin.com/W3iAw5Ui
18th April 2012, 04:45 AM |#634  
Member
Flag Calgary
Thanks Meter: 3
 
More
Question WiFi battery drain
Hi Folks,
I've been facing a huge battery drain, caused by my wifi. I don't have a cheap-ass router (dlink dir-655) and my CPU-SPY looks like this:
500MHz - 28%
200MHz - 32%
DS - 25%

Checking the BBS, I don't see any problems with Kernel/Partial Wakelocks. But when I check "Other", it gives me 100% wifi on.
Based on that, I installed the shark file suggested, and after running it for quite some time, the only thing I got (besides NULL) was "RAW". I'm running the CM9 nightly 14/04, with XXLPS modem.

With wifi off, I have an excellent battery life.

Any suggestions?
Last edited by Thor_BR; 18th April 2012 at 04:54 AM.
18th April 2012, 04:55 AM |#635  
alacrify's Avatar
Senior Member
Thanks Meter: 1,945
 
More
Quote:
Originally Posted by Thor_BR

Hi Folks,
I've been facing a huge battery drain, caused by my wifi. I don't have a cheap-ass router (dlink dir-655) and my CPU-SPY looks like this:
500MHz - 28%
200MHz - 32%
DS - 25%

Checking the BBS, I don't see any problems with Kernel/Partial Wakelocks. But when I check "Other", it gives me 100% wifi on.
Based on that, I installed the shark file suggested, and after running it for quite some time, the only thing I got (besides NULL) was "RAW". I'm running the CM9 nightly 14/04, with XXLPS modem.

With wifi off, I have an excellent battery life.

Any suggestions?

Let shark run for 15-20 minutes, and post the Pcap log here (check the thread for options to set) - let someone who can read it better than I can chime in. You may be getting a lot of polling from your network that's keeping it awake.
18th April 2012, 06:58 AM |#636  
selw0nk's Avatar
Senior Member
Flag San Jose, CA.
Thanks Meter: 174
 
More
You can turn off data and turn off sync to save battery life. Only turn it back only when you need it.
18th April 2012, 02:01 PM |#637  
alacrify's Avatar
Senior Member
Thanks Meter: 1,945
 
More
Quote:
Originally Posted by selw0nk

You can turn off data and turn off sync to save battery life. Only turn it back only when you need it.

You really shouldn't have to - when my phone is tweaked properly on a stable ROM, I lost ~1% an hour idle. With normal use, I get a day and a half off the charger. It does take some effort to track down the issues, but it's worth it.
18th April 2012, 05:34 PM |#638  
OP Senior Recognized Developer
Flag Owego, NY
Thanks Meter: 25,326
 
Donate to Me
More
Quote:
Originally Posted by alacrify

You really shouldn't have to - when my phone is tweaked properly on a stable ROM, I lost ~1% an hour idle. With normal use, I get a day and a half off the charger. It does take some effort to track down the issues, but it's worth it.

For me, 1%/hour idle is high except when on weak signal - and since ICS I've cracked the 1% threshold even at my desk.
18th April 2012, 06:12 PM |#639  
alacrify's Avatar
Senior Member
Thanks Meter: 1,945
 
More
Quote:
Originally Posted by Entropy512

For me, 1%/hour idle is high except when on weak signal - and since ICS I've cracked the 1% threshold even at my desk.

You're an exceptional example though - I'm not running my own ROM, no tweaks at all, no SetCPU even right now. Just a solid ROM with your kernel input and debloating by not loading bad apps
18th April 2012, 06:19 PM |#640  
Member
Flag Calgary
Thanks Meter: 3
 
More
Pcap attached
Hey Folks,
Here's the pcap. The app crashes if I leave it for 30 min.

Any help is appreciated!
Attached Files
File Type: zip shark_dump_1334726336.zip - [Click for QR Code] (2.2 KB, 3 views)
18th April 2012, 07:21 PM |#641  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by Entropy512

For me, 1%/hour idle is high except when on weak signal - and since ICS I've cracked the 1% threshold even at my desk.

Are you serious? We're talking about phone being at sleep but 3g (UMTS & HSPA) enabled all the time?

With wifi & goog signal thats possible I think, but I think I've never got below 5%/h or so...

(Running cm9 by the way)

Greetings

Nevermind, I've a GT9100, wrong forum :/
Should be similiar though
Last edited by CruX.; 18th April 2012 at 08:12 PM.

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes