FORUMS

Analysis & Opinion

Top Forum Discussions

[UTILITY] Android Utility - [apktool|dex2jar|smali|more][Mac & Linux][Feb13, 2012]

6,259 posts
Thanks Meter: 6,837
 
By tommytomatoe, Recognized Developer on 13th July 2011, 09:19 PM
Post Reply Subscribe to Thread Email Thread
18th April 2012, 04:37 PM |#531  
tommytomatoe's Avatar
OP Recognized Developer
Flag Knoxville USA
Thanks Meter: 6,837
 
Donate to Me
More
I will update tonight. I commented out a line last night and it was late, and in doing.so I added a random ' lol. Fix later.

Sent from my PG86100 using Tapatalk 2
 
 
18th April 2012, 04:45 PM |#532  
grayn0de's Avatar
Senior Member
Flag Austin, Tx
Thanks Meter: 306
 
More
Quote:
Originally Posted by tommytomatoe

I will update tonight. I commented out a line last night and it was late, and in doing.so I added a random ' lol. Fix later.

Sent from my PG86100 using Tapatalk 2

Does this mean that the OS X version will be in-line with the Linux version? Because that would be awesome.

Keep up the good work, Tommy!
18th April 2012, 09:57 PM |#533  
scott.hart.bti's Avatar
Recognized Developer
Flag Reading
Thanks Meter: 17,043
 
Donate to Me
More
Thumbs up
Quote:
Originally Posted by MasterZen88

Found the problem. Creater forgot to close out the syntax...

Code:
	1) echo "woot" ;; #a_if;;
	2) apk_dec -m;;
	3) apk_build -m;;
	a) ttadb;;
Just add the following in red to your script and it should work.

This worked. Thank you very much!
18th April 2012, 10:45 PM |#534  
tommytomatoe's Avatar
OP Recognized Developer
Flag Knoxville USA
Thanks Meter: 6,837
 
Donate to Me
More
Typo has been fixed. It was late last night lol. :)

Sent from my PG86100 using Tapatalk 2
The Following User Says Thank You to tommytomatoe For This Useful Post: [ View ]
19th April 2012, 10:55 AM |#535  
MasterZen88's Avatar
Senior Member
Thanks Meter: 1,162
 
Donate to Me
More
Quote:
Originally Posted by tommytomatoe

Typo has been fixed. It was late last night lol. :)

Sent from my PG86100 using Tapatalk 2

Great!...By the way great job on the tool, this is a must have tool for devs!!!
13th May 2012, 08:02 AM |#536  
cowsquad's Avatar
Senior Member
Flag Portland, Oregon
Thanks Meter: 304
 
Donate to Me
More
I hope I can decompile and compile ICS APKS
14th May 2012, 08:29 PM |#537  
Fraction's Avatar
Senior Member
Flag Bergen
Thanks Meter: 5
 
More
I am alittle new to modding. I am getting some errors on my mac when trying to execute commands.

Quote:

/Users/fraction/android-utility/andutil: /Users/fraction/android-utility/utility/romutil: /bin/bash: bad interpreter: Operation not permitted

Quote:

/Users/fraction/android-utility/utility/apk_tool: /usr/local/bin/apktool: /bin/bash: bad interpreter: Operation not permitted

Quote:

/Users/fraction/android-utility/utility/apk_tool: line 223: /usr/bin/sed: Operation not permitted


My PATH look like this:
Quote:

/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/texbin:/Users/fraction/bin:/Users/fraction/android-utility:/Users/fraction/android-utility/utility:/Users/fraction/android-sdk/platform-tools/:/Users/fraction/android-sdk/tools


I'm a missing something?


Thanks.
Fraction
14th May 2012, 08:51 PM |#538  
tommytomatoe's Avatar
OP Recognized Developer
Flag Knoxville USA
Thanks Meter: 6,837
 
Donate to Me
More
Did you install the mac version? Your errors lead me to.think you used Linux version..

Sent from my PG86100 using Tapatalk 2
14th May 2012, 09:04 PM |#539  
Fraction's Avatar
Senior Member
Flag Bergen
Thanks Meter: 5
 
More
I followed the "mac install" link, got a zip called: "tommytomatoe-Android-Utility-0e87a90"..


EDIT:
I installed the old Mac 1.0.1 on another mac. And that worked... Strange...

How do I completely uninstall 1.0.2?
Last edited by Fraction; 14th May 2012 at 09:15 PM.
14th May 2012, 09:28 PM |#540  
tommytomatoe's Avatar
OP Recognized Developer
Flag Knoxville USA
Thanks Meter: 6,837
 
Donate to Me
More
Quote:
Originally Posted by Fraction

I followed the "mac install" link, got a zip called: "tommytomatoe-Android-Utility-0e87a90"..


EDIT:
I installed the old Mac 1.0.1 on another mac. And that worked... Strange...

How do I completely uninstall 1.0.2?

When you installed 1.0.1 you effectively overwrote 1.0.2. No uninstallation necessary.

Let me.know.if.you need anything

Sent from my PG86100 using Tapatalk 2
14th May 2012, 09:59 PM |#541  
Fraction's Avatar
Senior Member
Flag Bergen
Thanks Meter: 5
 
More
Quote:
Originally Posted by tommytomatoe

When you installed 1.0.1 you effectively overwrote 1.0.2. No uninstallation necessary.

Let me.know.if.you need anything

Sent from my PG86100 using Tapatalk 2

On the MacPro, where I had the problems installing 1.0.1 didn't work. How do I remove all traces of this tool? So that I can be sure to start over from a clean environment?

And where is the "Please check the build_log for apk with errors"? Can't seem to find it?

And last: What is the Framework-res.apk used for? I had to install it, But the one I got from a rom failed horrible I think. So i used a 800KB framework-htc-res.apk, and all seemed ok..

(Are you on any Irc channels? I really wanna learn )

Read More
Post Reply Subscribe to Thread

Tags
apktool, draw9patch compiler, mac

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes