FORUMS

Analysis & Opinion

Top Forum Discussions

[Tutorial] Compile ICS on Ubuntu

3,818 posts
Thanks Meter: 10,620
 
Post Reply Subscribe to Thread Email Thread
19th April 2012, 07:24 AM |#261  
cdesai's Avatar
Recognized Developer
Flag IN YOUR HEAD
Thanks Meter: 4,038
 
Donate to Me
More
Quote:
Originally Posted by justlovejoy

Code:
joyride@joyride:~/aosp$ repo sync -j1

... A new repo command ( 1.15) is available.
... You should upgrade soon:
whats up wit dat?

Thanks Unlimited!

As it says in plain English, a new version of the repo tool is available
The Following User Says Thank You to cdesai For This Useful Post: [ View ]
 
 
19th April 2012, 01:37 PM |#262  
justlovejoy's Avatar
Senior Member
Flag Cybertron/Earth
Thanks Meter: 1,039
 
Donate to Me
More
Quote:

target thumb C++: libsecosal <= hardware/samsung/exynos4/multimedia/openmax/sec_omx/osal/SEC_OSAL_Android.cpp
hardware/samsung/exynos4/multimedia/openmax/sec_omx/osal/SEC_OSAL_Android.cpp: In function 'OMX_ERRORTYPE SEC_OSAL_LockANBHandle(OMX_U32, OMX_U32, OMX_U32, OMX_COLOR_FORMATTYPE, void**)':
hardware/samsung/exynos4/multimedia/openmax/sec_omx/osal/SEC_OSAL_Android.cpp:163: error: 'GRALLOC_USAGE_YUV_ADDR' was not declared in this scope
hardware/samsung/exynos4/multimedia/openmax/sec_omx/osal/SEC_OSAL_Android.cpp: In function 'OMX_ERRORTYPE SEC_OSAL_GetPhysANBHandle(OMX_U32, void**)':
hardware/samsung/exynos4/multimedia/openmax/sec_omx/osal/SEC_OSAL_Android.cpp:220: error: 'class android::GraphicBufferMapper' has no member named 'getphys'
make: *** [out/target/product/epic4gtouch/obj/STATIC_LIBRARIES/libsecosal_intermediates/SEC_OSAL_Android.o] Error 1
make: *** Waiting for unfinished jobs....
true
Note: external/jsilver/src/org/clearsilver/FactoryLoader.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

was trying to stay away from asking but ?????
20th April 2012, 03:21 AM |#263  
Senior Member
Thanks Meter: 83
 
More
Quote:
Originally Posted by cdesai

As it says in plain English, a new version of the repo tool is available

I haven't seen it (yet) and I've been running repo ugh for about 2 weeks. (15 gigs and still going.... will it ever end lol) . I must say that this waiting has done me some good. Reading reading reading. Understanding git a little better now.
I am more confidential now about this process than when I started downloading the sources. Bloody slow connection works to my advantage for once.

Sent from my GT-S5360
Last edited by Dreamboxuser; 20th April 2012 at 06:22 AM.
20th April 2012, 05:15 PM |#264  
Senior Member
Thanks Meter: 83
 
More
I'm getting this error now with github:
fatal: Unable to look up github.com (port 9418) (name or service not known)
Anyone had this?
Edit:well its working again even though the whole time github never reported a problem.

this auto corrected post sent from my Galaxy Y running something.
Last edited by Dreamboxuser; 21st April 2012 at 12:01 AM.
21st April 2012, 02:39 AM |#265  
lithid-cm's Avatar
Recognized Developer
Flag Cleveland
Thanks Meter: 2,973
 
More
Quote:
Originally Posted by Dreamboxuser

I'm getting this error now with github:
fatal: Unable to look up github.com (port 9418) (name or service not known)
Anyone had this?
Edit:well its working again even though the whole time github never reported a problem.

this auto corrected post sent from my Galaxy Y running something.

Usually happens during an unknown networking issue. Sometimes switching from using git -> https works.
The Following User Says Thank You to lithid-cm For This Useful Post: [ View ]
21st April 2012, 05:49 AM |#266  
justlovejoy's Avatar
Senior Member
Flag Cybertron/Earth
Thanks Meter: 1,039
 
Donate to Me
More
Quote:
Originally Posted by lithid-cm

Usually happens during an unknown networking issue. Sometimes switching from using git -> https works.

Didn't know you could do that, well yes but not in this circumstance, lol, now that I think about it, I realize I just didn't think about it but did I fart in the elevator? I'm getting build errors trying to make aosp left and right, when I post its like no comment. I'd like to know though! Lol nvm. Feed me more information please nurse, you guys be cool. Icu

Sent from my SPH-D710 using Tapatalk 2
22nd April 2012, 03:48 AM |#267  
Senior Member
Flag Dallas
Thanks Meter: 1,034
 
Donate to Me
More
Does anyone have experience with the Supersonic? I'm getting some weird errors involving hwcomposer and libqcomui.
22nd April 2012, 04:47 AM |#268  
lithid-cm's Avatar
Recognized Developer
Flag Cleveland
Thanks Meter: 2,973
 
More
Quote:
Originally Posted by pspunderground

Does anyone have experience with the Supersonic? I'm getting some weird errors involving hwcomposer and libqcomui.

Post your logs. I had the evo before the nexus s 4g.
22nd April 2012, 03:37 PM |#269  
Senior Member
Thanks Meter: 83
 
More
Well after trying to sync to the cm9 repos I've had to abandon it due to files failing to complete (at 95 percent it would always say unexpected EOF) and then restart. Little bit of a drag since it has taken ages to get to this point (started it on the 12th and it has been running basically 24/7 since then and was up to 23 gigs). Gonna just stick with the aosp until I get back to a high speed connection.


this auto corrected post sent from my Galaxy Y running something.
Last edited by Dreamboxuser; 22nd April 2012 at 03:58 PM.
22nd April 2012, 04:43 PM |#270  
Senior Member
Flag Dallas
Thanks Meter: 1,034
 
Donate to Me
More
Quote:
Originally Posted by lithid-cm

Post your logs. I had the evo before the nexus s 4g.

http://logcat.miui.us/709018

Here you go.

Sent from my PC36100 using XDA
22nd April 2012, 05:25 PM |#271  
Senior Member
Flag Coimbatore
Thanks Meter: 5
 
More
First time building.
Ok now i just got my PC up and running with the source and started compiling. But i get the following error message (Look at the attachment below.)

Here are the things i did (I like to log my stuff so i can revert if i screw up)
Code:
2. After the syncing process was done downloaded the vender files from [link] https://github.com/koush/android_vendor_htc_buzz[/link]
	place them in home/WORKING_DIRECTORY/vendor/htc/buzz
3. Download the device specific files from ErwinP's github [link] https://github.com/ErwinP/android_device_htc_buzz [/link] and place them in home/WORKING_DIRECTORY/	 device/htc/buzz
4. Set up adb using guide from [link]  http://forum.xda-developers.com/showthread.php?t=1550414 [/link]
	ADB setup cheanged a bit and the ~/.bashrc file was changed with the new stuff which is commented out to make the adb work and thus the project to move ahead
	
5. Changing common_mini_phone.mk to common_tiny_phone.mk under vendor/cm/config
6. moving device/htc/buzz/common to BACKUP_ICS_SOURCE
http://img407.imageshack.us/img407/2964/error2gk.png
Attached Thumbnails
Click image for larger version

Name:	error_2.jpg
Views:	371
Size:	38.2 KB
ID:	1019005  
Last edited by Deltatiger; 22nd April 2012 at 05:31 PM.

Read More
Post Reply Subscribe to Thread

Tags
compile, ics, source

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes