5,814,863 Members 49,239 Now Online
XDA Developers Android and Mobile Development Forum

[KERNEL] Semaphore ICS 1.3.0

Tip us?
 
dastinger
Old
(Last edited by dastinger; 21st April 2012 at 01:09 AM.)
#3301  
dastinger's Avatar
Senior Member
Thanks Meter 223
Posts: 557
Join Date: Dec 2010
@badworker

Search some pages back for a tutorial for Heimdall.

-----

I'm having trouble as well for some days now. Didn't say anything earlier because I wanted to make sure it was Semaphore. I did a clean flash of AOKP B32. Flashed JW4 w/ PIT using ODIN -> Hard Reset -> Flashed B32 -> Let it boot -> Restored /data from a Nandroid -> Flashed Semaphore. I always used Semaphore with AOKP with this settings:

OC: 1140
Ondemand
Simple I/O
Lock Min Scaling Frequency
Deep Idle

Voltages:



(Apart from the 1140 frequency which I had running on 1300mV. Changed it to purely test if that was the issue)

All ran well on M4, Build 30 and 31. Since I flashed 32 that I get random reboots using these settings. I tried to disable OC, still random reboots. Disabled UV. Still random reboots. Yesterday I flashed B32 again without wiping and stayed on Glitch for a day. Used exactly the same settings regarding OC, scheduler, UV etc. It ran perfectly. About 2 hours ago I decided to have another go with Semaphore 1.0.1s and, 45 minutes later, reboot. Thing is, I'm not always doing something on the phone. I can be watching a video and it reboots, I can be browsing forums in Tapatalk, stop and, seconds later, reboot etc etc. I really love AOKP as I really love Semaphore so I want to keep this combo. I know lots of users have this combo on their phones running perfectly so it's not an incompatibility issue.

What should I do? Is there any way I can get a logcat at the time of the reboots? If so, how? I don't know anything more I can do. Help.

PS: Could anyone tell me, please, what are the default kernel voltages?
PSS: I had the same issues both on 1.0.0s and 1.0.1s.
PSSS: Ran Kernel Cleaner Script and cleared both init.d and NS Tools settings everytime I changed kernels.
Google Nexus 5
Rom: KK 4.4.4 Slim
Kernel: Franco
Launcher: Nova
 
yahyoh
Old
#3302  
yahyoh's Avatar
Senior Member
Thanks Meter 1,878
Posts: 4,655
Join Date: Nov 2011
Location: Riyadh
Quote:
Originally Posted by badworker View Post
I was listening to music with my sgs and suddently the phone starts 'clicking' (like BSOD in windows when the music is playing, if you know, the sound were like that).
Then I removed battery and put back on, the phone doesn't boot.
I can't go into recovery nor boot normally, it goes in bootloop.

There's some way to flash this kernel via odin or something similar, without loosing any data?

I don't really know if the problem is kernel-side or rom-side, I believe that's something wrong with kernel but I can't confirm.

The operation that I made today:
flashed a new modem.
installed Voltage Control (locking max freq to 800MHz when display's off).

I used this configuration since semaphore 1.0.1s and CM9 04-19 were released:
SGS with CM9 04192012 + Semaphore 1.0.1s + lock min freq to 100MHz and a little UV, I've never had any kind of problem with this configuration until this evening.

ty
just reflash an odin kernel or flash recovery fix from here the reflash the kernel u like the go to advanced in recovery thn reboot recovery then try to clear ns tool then clean init.d scripts then wipe cache an dalvik and see if it work
dont forget to restore init.d scripts when it work
Gnote2 Rom: XXUFNE1 kernel: Stock
.........................
Galaxy S2 ROM: XWMS3 4.1.2 Kernel: Stock
............................
MOTO G ROM : 4.4.4 Kernel :stock

............
 
contactfornitish
Old
#3303  
contactfornitish's Avatar
Senior Member
Thanks Meter 18
Posts: 134
Join Date: Jul 2011
Location: New Delhi
Now this is something that is beyond horrible.

This is not the case always but as many reported, battery life is not that good as been earlier. I also understand that it might be an issue with ICSSGS ROM but can not understand that why others not facing such issue.

Sent from my GT-I9000 using XDA
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1334967457728.jpg
Views:	709
Size:	45.0 KB
ID:	1016387  
 
scuba156
Old
#3304  
scuba156's Avatar
Senior Member
Thanks Meter 732
Posts: 575
Join Date: Apr 2011
Location: Melbourne

 
DONATE TO ME
Quote:
Originally Posted by HM.Carbide View Post
I can't see the SemaphoreScripts folder.

The tests folder has to be lowercase, and I am not sure about the .txt extension and the file rights.

Sent from my GT-I9000 using XDA
That's within the SemaphoreScripts folder (the current directory is shown at the top of the screen).

'tests' was renamed to 'Tests' to disable the script to allow the default bt_off script. The .txt extension worked fine for me, i haven't seen any source (not sure if you use open source anyway), but it seems to ignore any file extensions for anything in there. I've never had an issue with the script. My issue was with incorrect OC/UC values, i don't have the issue now, just pointing out what happened for me.

Sent from my GT-I9000 using Tapatalk 2
 
nieohl
Old
#3305  
nieohl's Avatar
Senior Member
Thanks Meter 42
Posts: 746
Join Date: Sep 2011
Having random boot. Just got woke up and turned on my phone, as i was watching tv, after like 10mins, i heard my phone, it was the notification sound, then i checked it. It was rebooted by itself. I know it was rebooted because it has super backup, email notification on my status bar. They said it was kernel issue.. :/
I was on semaphore 1.0.0bm btw.

Sent from my GT-I9000 using xda premium
Device: i9505
Rom: GOLDENEYE XXUEML6 v18.1
Kernel: Stock
Theme: BluO'z V2.1
Mod: Lightning unlock
 
LoqOs195
Old
#3306  
Senior Member
Thanks Meter 12
Posts: 139
Join Date: Apr 2011
I cant sync with any devices using bluethoot, the devices can not found my sgs

Enviado desde mi GT-I9000 usando Tapatalk
 
dchawk81
Old
#3307  
dchawk81's Avatar
Senior Member
Thanks Meter 49
Posts: 654
Join Date: Nov 2010
Is there a way to fix the screen rotation and the backwards home and back capacitive buttons on my Captivate?
FYI: When a someone says "nandroid" what they're referring to is CWM or ClockWork. I wish someone had told me that months ago.
 
ngenhit
Old
#3308  
Member
Thanks Meter 41
Posts: 74
Join Date: Sep 2010
Quote:
Originally Posted by dchawk81 View Post
Is there a way to fix the screen rotation and the backwards home and back capacitive buttons on my Captivate?
You are not supposed to use the i9000 & Vibrant Kernel builds for captivate. It has incompatible GPIO mappings .
 
dchawk81
Old
(Last edited by dchawk81; 21st April 2012 at 05:52 AM.)
#3309  
dchawk81's Avatar
Senior Member
Thanks Meter 49
Posts: 654
Join Date: Nov 2010
Quote:
Originally Posted by ngenhit View Post
You are not supposed to use the i9000 & Vibrant Kernel builds for captivate. It has incompatible GPIO mappings .
What do I use? I was directed here from Darknight.

Edit: never mind. Found the Cappy version.
FYI: When a someone says "nandroid" what they're referring to is CWM or ClockWork. I wish someone had told me that months ago.
 
the_stift
Old
(Last edited by the_stift; 21st April 2012 at 08:59 AM.)
#3310  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Sep 2007
Location: Hamburg
I am using Rom: Slim ICS v3.3 with the semaphore kernel 1.0.0s
and I have the problem that adb v1.0.29 cant reach my phone anymore.
I got adb working over WIFI but not with usb :-/
Any ideas what I can do?

Tags
ics, semaphore
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes