Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

HTC One X-At&t Apn settings for data, 3g and etc.

OP Jesushasadroid

21st April 2012, 12:14 AM   |  #1  
Jesushasadroid's Avatar
OP Senior Member
Flag Hollywood, FL
Thanks Meter: 43
 
633 posts
Join Date:Joined: Oct 2010
I just got my HTC One X today. When i pop in the micro sim card, i could receive calls and text , but no data. Here's what work for me. I added a new apn....

Name: can be anything
APN: wap.cingular
Proxy: leave blank
Port: leave blank
Username:WAP@CINGULARGPRS.COM
Password:CINGULAR1
Server: leave blank
MMSC: http://mmsc.cingular.com
MMS Proxy: wireless.cingular.com
MMS Port: 80
MCC:310
MNC:410
APN Type: leave blank
The Following 4 Users Say Thank You to Jesushasadroid For This Useful Post: [ View ]
21st April 2012, 12:44 AM   |  #2  
Junior Member
Kansas City, MO
Thanks Meter: 1
 
10 posts
Join Date:Joined: Feb 2008
More
a little instruction pleas
could you explain how you changed your apn settings..please
21st April 2012, 12:45 AM   |  #3  
Member
Thanks Meter: 6
 
90 posts
Join Date:Joined: Apr 2012
All I had to do was click on AT&T in the apn menu and it did everything for me.
The Following User Says Thank You to johnl199 For This Useful Post: [ View ]
21st April 2012, 12:58 AM   |  #4  
Jesushasadroid's Avatar
OP Senior Member
Flag Hollywood, FL
Thanks Meter: 43
 
633 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by jrocm

could you explain how you changed your apn settings..please

no problem...
Settings/ Mobile Networks/ Access point names/ Menu/ New Apn/ Then set it up and save. Then select it and your good to go..

Quote:
Originally Posted by johnl199

All I had to do was click on AT&T in the apn menu and it did everything for me.

I live in hollywood florida. when i pick att...it only gave me voice and text no data...even though it had the 3g and H bars...weird...
21st April 2012, 01:05 AM   |  #5  
Junior Member
Kansas City, MO
Thanks Meter: 1
 
10 posts
Join Date:Joined: Feb 2008
More
worked like a charm?
Thanks just got the phone a couple hours ago...was starting to get irked...Thanks yal
21st April 2012, 01:06 AM   |  #6  
kgill7's Avatar
Senior Member
Flag California
Thanks Meter: 2,032
 
1,685 posts
Join Date:Joined: Nov 2010
Donate to Me
im on t-mobile with this phone, and i dont get any data not even 2g, how would i go about getting apn settings, i know ur on att, but i need help.lol.
21st April 2012, 01:17 AM   |  #7  
Jesushasadroid's Avatar
OP Senior Member
Flag Hollywood, FL
Thanks Meter: 43
 
633 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by jrocm

Thanks just got the phone a couple hours ago...was starting to get irked...Thanks yal

no worries...thats why I posted it...enjoy the ONE....!
21st April 2012, 02:00 AM   |  #8  
phobos512's Avatar
Senior Member
Flag Lexington Park, MD
Thanks Meter: 104
 
777 posts
Join Date:Joined: Mar 2009
More
You can access the APN menu by going to settings - mobile network - access point names.

Sent from my HTC One X using Tapatalk 2
E.Cadro
21st April 2012, 02:28 AM   |  #9  
Guest
Thanks Meter: 0
 
n/a posts
Quote:
Originally Posted by kgill7

im on t-mobile with this phone, and i dont get any data not even 2g, how would i go about getting apn settings, i know ur on att, but i need help.lol.

Did you try these?

http://support.t-mobile.com/docs/DOC...oredirect=true

This could be the problem

http://androidforums.com/htc-one-x/533805-new-t-mobile-sim-issues-unlocked-htc-one-x.html#post4260319

Sent from wherever I am!
Last edited by E.Cadro; 21st April 2012 at 04:43 AM.
21st April 2012, 03:42 AM   |  #10  
BarryH_GEG's Avatar
Senior Member
Flag Spokane, Washington
Thanks Meter: 4,400
 
8,972 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by Jesushasadroid

I just got my HTC One X today. When i pop in the micro sim card, i could receive calls and text , but no data. Here's what work for me. I added a new apn....

Mine picked up the APN from the SIM and they're slightly different than yours. Mine are in red.

Name: can be anything [MediaNet]
APN: wap.cingular
Proxy: leave blank [wireless.cingular.com]
Port: leave blank [80]
Username:WAP@CINGULARGPRS.COM
Password:CINGULAR1
Server: leave blank
MMSC: http://mmsc.cingular.com
MMS Proxy: wireless.cingular.com [66.209.11.32]
MMS Port: 80 [8080]
MMS protocol: WAP 2.0
MCC:310
MNC:410
APN Type: leave blank [.]

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes