FORUMS

Sunday Debate: How Can We Get a No-Compromise Phone?

Join us in a fun Sunday Debate on Compromises. Come with your opinions and … more

PSA: You Can Optimize Your Note 4’s Recents Menu & RAM

The Note 4 never had the fastest Recents Menu, and despite its 3GB of RAM, … more

XDA Picks: Best Apps of the Week (July 25 – Aug 1)

Apps are at the front and center of any smartphone experience, and with over a … more

Voices Of XDA: Orbiting The Earth With Android

Editor’s note: This week’s feature has been written by forum … more

[NIGHTLY/KERNEL][USER] UNOFFICIAL CM9 + 3.0.x Kernel for K-Fire [3.0.31+ 06-28]

3,317 posts
Thanks Meter: 23,530
 
By Hashcode, Senior Recognized Developer on 10th April 2012, 10:04 AM
Post Reply Subscribe to Thread Email Thread
21st April 2012, 05:17 PM |#461  
loki154's Avatar
Senior Member
Thanks Meter: 16
 
More
After flashing the #6 kernel, my kindle won't charge at all on usb or the ac charger :/ its completely dead with no charging light.
 
 
21st April 2012, 05:36 PM |#462  
Junior Member
Thanks Meter: 5
 
More
Hey Loki,

USB does charge but it's very slow. AC should work though.
Plug it with the AC adapter for a few minutes and it should be fine.
21st April 2012, 05:39 PM |#463  
loki154's Avatar
Senior Member
Thanks Meter: 16
 
More
Idk, its been plugged into both and the charging light never comes on.
21st April 2012, 05:47 PM |#464  
Junior Member
Thanks Meter: 0
 
More
First of all, great work. The #3 ROM with #6 kernel is already the smoothest experience I've had with the Fire.

For reference, my observations so far:

HWA mostly works in browser flash, twitchtv app, YouTube app, MX video player. Sometimes videos in YouTube or MX will not start and cause FC.
Charging using wall charger works fine, but the LED indicator will only show that its charging while its not sleeping. While sleeping, the charging LED will come on for a second or two at somewhat regular intervals. This might be related to what's been observed, namely
High battery drawn during sleep. It's nearly as high as during use.
I have no screen striping/flickering/banding issues whatsoever
Google Earth doesn't work

Installed by:
Boot to TWRP 2.1, wipe cache/dalvik/system/factory reset, install #3 ROM and #6 kernel immediately after. Boot to system, then back to recovery, flash gapps, boot to system. All lovely

---------- Post added at 06:47 PM ---------- Previous post was at 06:40 PM ----------

Quote:
Originally Posted by loki154

Idk, its been plugged into both and the charging light never comes on.

Maybe it's not really powered down. Try unplugging from charger, then press the power button for 20 seconds, then let go of the power button and plug in the charger. It should come on immediately.
Last edited by nekonosuna; 21st April 2012 at 05:52 PM.
21st April 2012, 06:22 PM |#465  
Krunk_Kracker's Avatar
Senior Member
Flag Lakeland
Thanks Meter: 720
 
More
Quote:
Originally Posted by Trojan38

OMFG I have exactly the same issue . That's funny but quite unsecure.

Nah its not insecure. It won't allow you to login unless you know the password. Seems that Tapatalks servers use the MAC address of the device to keep track. As soon as the Mac address issue gets resolved, it will stop doing it.

Sent from my DROIDX using Tapatalk 2
21st April 2012, 07:52 PM |#466  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by TheKid2

Anyone wishing to restore there MAC Address back to factory.
I had documented my original MAC addresses.

In terminal emulator/or adb shell (wifi turned off)

su
mount -o remount rw /system
calibrator set nvs_mac /system/etc/firmware/ti-connectivity/wl1271-nvs.bin XX:XX:XX:XX:XX:XX

You should backup original wl1271-nvs.bin before using this method.
if you have problem can restore file and reboot.

If someone could verify this for me I will edit/delete post if neccessary.

Thanks

I tried doing the steps you've described and now my mac address is no longer 00:d2:8b:43:9f:fd. It works!
21st April 2012, 07:55 PM |#467  
Senior Member
Flag Peachtree City
Thanks Meter: 64
 
Donate to Me
More
How exactly does one use USB OTG? I would like to use my kindle to take notes in class but would rather use an actual keyboard than the touch one. Anyone?

Sent from my myTouch_4G_Slide using XDA
21st April 2012, 08:47 PM |#468  
neilrl79's Avatar
Senior Member
Flag Maryland
Thanks Meter: 175
 
Donate to Me
More
Quote:
Originally Posted by loki154

Idk, its been plugged into both and the charging light never comes on.

With my fire powered all the way down (power button 20 sec press) the charging light was not on while plugged into AC power but it fully charged.
21st April 2012, 10:31 PM |#469  
KaLiBLeeK's Avatar
Senior Member
Flag San Diego, CA
Thanks Meter: 32
 
Donate to Me
More
Thumbs up
Quote:
Originally Posted by neilrl79

With my fire powered all the way down (power button 20 sec press) the charging light was not on while plugged into AC power but it fully charged.

Ditto (kinda?); Left my KF plugged into a wall charger overnight, but left it on. Woke up in the morning and it was fully charged. The charging light was behaving weirdly, so I just checked in the battery section of the setting to make sure it was charging, and indeed it was.

And I'm going to assume if people are having "banding" issues with their KF is not the same as what I've seen the entire time I've owned my KF; if I leave a page/app open for a bit that has a white background and dark text, images, once I leave that page/app, the image hangs around for a bit (ghosts? whatever), but then goes around after a bit of use. This has happened on every ROM/kernel I've owned, regardless of display brightness.

TBH, for what I use my KF for, the kernel as it stands right now is pretty much perfect. Really amazed by all the progress that's been made over the past week or so. Kudos to Hash/Intersect/etc etc.
21st April 2012, 10:45 PM |#470  
Hashcode's Avatar
OP Senior Recognized Developer
Thanks Meter: 23,530
 
Donate to Me
More
The MAC address issue is because of the nvs.bin that was included in the #3 rom (it has a preset MAC in it). Looks like the other CM7 rom fixed this by NOT including the nvs.bin file and wrapping the module loader binary with a script that builds a new file if it doesn't exist and then runs the module loader.

I'll try and get this into the next full ROM update.

Sent from my XT894 using XDA
The Following 3 Users Say Thank You to Hashcode For This Useful Post: [ View ]
21st April 2012, 11:17 PM |#471  
Senior Member
Thanks Meter: 268
 
More
There seems to be some success with this, so if you are having battery drain issues turn off your touch sounds and unlock sounds. Audiodriver_1 seems to be constantly starting while the phone is sleeping which is consuming power. Turning these sounds off seems to fix the problem for now

Sent from my LG-VM670 using Tapatalk
The Following User Says Thank You to pbailey212 For This Useful Post: [ View ]

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes