Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,048 Members 45,702 Now Online
XDA Developers Android and Mobile Development Forum

[NIGHTLY] [ROM] CyanogenMod 9

Tip us?
 
mistabelmont
Old
#311  
Junior Member
Thanks Meter 32
Posts: 15
Join Date: Apr 2012
Quote:
Originally Posted by sheedatali View Post
Hey guys, there is a lot of material on what probably works. Is there a list of things that are yet to be resolved? i-e not working?
http://review.cyanogenmod.com/#/q/statuspen+branch:ics+(project:CyanogenMod/android_device_hp_tenderloin+OR+project:CyanogenMo d/hp-kernel-tenderloin+OR+(-project:%255ECyanogenMod/android_device_.*+AND+-project:%255ECyanogenMod/.*kernel.*)),n,z
 
mkosem
Old
(Last edited by mkosem; 21st April 2012 at 06:51 AM.)
#312  
Senior Member
Thanks Meter 30
Posts: 237
Join Date: Sep 2007
I still see this weird netd issue in these builds. I didn't see it on the unofficial nightlies, but it definitely hurts performance and battery life.



Swapping the binary out with a cm7 equivalent fixes it. Oddly, the binary from the non-problematic: unofficial nightlies doesn't.

--Matt
 
LikeaG2root
Old
#313  
LikeaG2root's Avatar
Senior Member
Thanks Meter 236
Posts: 1,024
Join Date: Apr 2011
Location: Orlando,FL
Latest nightly is working very well. Best one yet!

Info about possible fix for Wi-Fi...I was previously having issues staying connected using cm9 and aokp builds. It was bad and so I went to my router settings. I have a Linksys router with both wireless G and N. I disabled the N signal and set my G signal to channel 1. Wi-Fi is working better than ever and have not had any disconnects since the change. So apparently the N signal interferes with the hptouchpad's reception. Hope this helps someone

Sent from my cm_tenderloin using Xparent Cyan Tapatalk 2
HTC One (M7)
HTC One S (ville)
HPtouchpad 32gb (tenderloin)
 
ashtrai
Old
#314  
Junior Member
Thanks Meter 3
Posts: 24
Join Date: Jan 2011
Quote:
Originally Posted by ashtrai View Post
I've been having a recurring problem with my TP since a while back. My sound stops working when i wake my device up after deepsleep. the only way to get sound working again is to reboot. Installing the bricked-ics kernel fixed this but that kernel was unstable. Ive tried removing android completely from my device, done a webosdoctor and then reinstalling it. Still the same problem. Ive had this since after the 3.5 alpha. im on the latest nightly now.

I've taken some catlogs of when the sound is working after a fresh reboot and one where its not. These catlogs are me pressing on the menu button to try to make a touchsound.

Without sound
Code:
04-20 03:21:39.499 D/dalvikvm(9013): GC_FOR_ALLOC freed 1K, 17% free 11218K/13447K, paused 26ms
04-20 03:21:40.419 D/dalvikvm(9013): GC_FOR_ALLOC freed 276K, 18% free 11073K/13447K, paused 27ms
04-20 03:21:41.219 I/ALSAModule(196): ALSA Module: closing down output device
04-20 03:21:42.429 I/ALSAModule(196): ALSA Module: closing down output device
04-20 03:21:42.449 D/memalloc(193): /dev/pmem: Allocated buffer base:0x2ca68000 size:1638400 offset:3014656 fd:37
04-20 03:21:42.459 D/memalloc(2045): /dev/pmem: Mapped buffer base:0x48a63000 size:4653056 offset:3014656 fd:85
04-20 03:21:42.459 D/ALSAModule(196): open called for devices 00000000 in mode 0...
04-20 03:21:42.489 I/ALSAModule(196): Set global parms
04-20 03:21:42.489 I/ALSAModule(196): Setting interleved PCM
04-20 03:21:42.519 D/memalloc(193): /dev/pmem: Allocated buffer base:0x2ca68000 size:1638400 offset:4653056 fd:41
04-20 03:21:42.549 I/ALSAModule(196): Buffer size: 2400, chunk 4800, latency 54421
04-20 03:21:42.549 I/ALSAModule(196): Initialized ALSA PLAYBACK device default
04-20 03:21:42.549 E/AudioHardwareALSA(196): RE-OPEN AFTER STANDBY:: took 121 msecs
04-20 03:21:42.549 D/memalloc(2045): /dev/pmem: Mapped buffer base:0x48ed3000 size:6291456 offset:4653056 fd:88
04-20 03:21:42.569 D/memalloc(193): /dev/pmem: Allocated buffer base:0x2ca68000 size:1638400 offset:6291456 fd:52
04-20 03:21:42.579 D/memalloc(2045): /dev/pmem: Mapped buffer base:0x4ab66000 size:7929856 offset:6291456 fd:91
With sound
Code:
04-20 03:44:29.099 D/NetlinkEvent(149): Unexpected netlink message. type=0x0
04-20 03:44:29.709 D/NetlinkEvent(149): Unexpected netlink message. type=0x140e
04-20 03:44:33.549 D/memalloc(152): /dev/pmem: Allocated buffer base:0x2ca66000 size:393216 offset:0 fd:36
04-20 03:44:33.549 D/memalloc(1588): /dev/pmem: Mapped buffer base:0x47d3e000 size:393216 offset:0 fd:46
04-20 03:44:33.589 I/ALSAModule(156): ALSA Module: closing down output device
04-20 03:44:33.629 D/ALSAModule(156): open called for devices 00000000 in mode 0...
04-20 03:44:33.659 I/ALSAModule(156): Set global parms
04-20 03:44:33.659 I/ALSAModule(156): Setting interleved PCM
04-20 03:44:33.679 I/ALSAModule(156): Buffer size: 2400, chunk 4800, latency 54421
04-20 03:44:33.679 I/ALSAModule(156): Initialized ALSA PLAYBACK device default
04-20 03:44:33.679 E/AudioHardwareALSA(156): RE-OPEN AFTER STANDBY:: took 87 msecs
04-20 03:44:33.749 D/dalvikvm(1588): GC_CONCURRENT freed 385K, 33% free 7695K/11335K, paused 2ms+15ms
04-20 03:44:35.399 D/memalloc(1588): /dev/pmem: Unmapping buffer base:0x47d3e000 size:393216 offset:0
04-20 03:44:35.419 W/InputManagerService(229): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@2bee3060
04-20 03:44:35.659 D/memalloc(152): /dev/pmem: Freeing buffer base:0x2ca66000 size:393216 offset:0 fd:36
04-20 03:44:38.769 I/ALSAModule(156): ALSA Module: closing down output device
04-20 03:44:38.869 I/ALSAModule(156): ALSA Module: closing down output device
04-20 03:44:38.899 D/ALSAModule(156): open called for devices 00000000 in mode 0...
04-20 03:44:38.929 I/ALSAModule(156): Set global parms
04-20 03:44:38.929 I/ALSAModule(156): Setting interleved PCM
04-20 03:44:38.989 I/ALSAModule(156): Buffer size: 2400, chunk 4800, latency 54421
04-20 03:44:38.989 I/ALSAModule(156): Initialized ALSA PLAYBACK device default
04-20 03:44:38.989 E/AudioHardwareALSA(156): RE-OPEN AFTER STANDBY:: took 118 msecs
04-20 03:44:39.209 D/memalloc(152): /dev/pmem: Allocated buffer base:0x2ca66000 size:393216 offset:0 fd:36
04-20 03:44:39.219 D/memalloc(1588): /dev/pmem: Mapped buffer base:0x47d3e000 size:393216 offset:0 fd:46
04-20 03:44:41.159 D/memalloc(1588): /dev/pmem: Unmapping buffer base:0x47d3e000 size:393216 offset:0
04-20 03:44:41.169 W/InputManagerService(229): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@2bf8f338

Here's another logcat.

Code:
build.board: tenderloin
build.bootloader: unknown
build.brand: generic
build.cpu_abi: armeabi-v7a
build.cpu_abi2: armeabi
build.device: tenderloin
build.display: IMM76D
build.fingerprint: hp/hp_tenderloin/tenderloin:4.0.4/IMM76D/223971:user/release-keys
build.hardware: tenderloin
build.host: marjory
build.id: IMM76D
build.manufacturer: unknown
build.model: cm_tenderloin
build.product: touchpad
build.radio: unknown
build.serial: 6d2092c8a14f55aa15b6b794e3cdd6a6e1fd97e1
build.tags: test-keys
build.time: 1334763995000
build.type: userdebug
build.user: cm-hudson
version.codename: REL
version.incremental: eng.cm-hudson.20120418.094527
version.release: 4.0.4
version.sdk_int: 15

04-20 19:00:49.289 I/ALSAModule(155): ALSA Module: closing down output device
04-20 19:00:49.309 D/memalloc(152): /dev/pmem: Allocated buffer base:0x2ca66000 size:73728 offset:18612224 fd:39
04-20 19:00:49.319 D/memalloc(1490): /dev/pmem: Mapped buffer base:0x46e90000 size:18685952 offset:18612224 fd:70
04-20 19:00:49.319 D/ALSAModule(155): open called for devices 00000000 in mode 0...
04-20 19:00:49.349 I/ALSAModule(155): Set global parms
04-20 19:00:49.349 I/ALSAModule(155): Setting interleved PCM
04-20 19:00:49.549 I/ALSAModule(155): Buffer size: 2400, chunk 4800, latency 54421
04-20 19:00:49.549 I/ALSAModule(155): Initialized ALSA PLAYBACK device default
04-20 19:00:49.549 E/AudioHardwareALSA(155): RE-OPEN AFTER STANDBY:: took 262 msecs
04-20 19:00:49.729 D/dalvikvm(1490): GC_CONCURRENT freed 992K, 17% free 6919K/8263K, paused 3ms+5ms
04-20 19:00:51.919 D/dalvikvm(517): GC_FOR_ALLOC freed 278K, 10% free 7375K/8135K, paused 24ms
04-20 19:00:52.739 I/ALSAModule(155): ALSA Module: closing down output device
04-20 19:00:52.799 D/memalloc(1490): /dev/pmem: Unmapping buffer base:0x46e90000 size:18685952 offset:18612224
04-20 19:00:53.339 D/memalloc(152): /dev/pmem: Freeing buffer base:0x2dc26000 size:73728 offset:18612224 fd:39
04-20 19:00:56.809 I/lights  (221): Disabling touch screen
04-20 19:00:56.809 D/lights  (221): Send ts socket 1 byte(s): 'C'
04-20 19:00:56.809 D/ts_srv  (148): Socket received 1 byte(s): 'C'
04-20 19:00:56.809 D/ts_srv  (148): uart closed: 0
04-20 19:00:56.809 I/ts_power(148): touchscreen_power: enable=0, ts_state=1
04-20 19:00:56.809 I/power   (221): *** set_screen_state 0
04-20 19:00:56.809 D/SurfaceFlinger(152): About to give-up screen, flinger = 0xf918
04-20 19:00:56.809 D/Sensors (221): sensor activation called: handle=3, enabled=0********************************
04-20 19:00:56.819 D/Sensors (221): sensor activation called: handle=0, enabled=0********************************
04-20 19:00:56.829 V/TransportControlView(221): Create TCV com.android.internal.widget.TransportControlView@2beba768
04-20 19:00:56.889 D/dalvikvm(221): GC_FOR_ALLOC freed 610K, 13% free 10026K/11463K, paused 44ms
04-20 19:00:56.919 I/CpuGovernorService(221): intent action: android.intent.action.SCREEN_OFF
04-20 19:00:56.979 D/dalvikvm(221): GC_FOR_ALLOC freed 66K, 9% free 10432K/11463K, paused 37ms
04-20 19:00:57.049 I/ALSAModule(155): ALSA Module: closing down output device
04-20 19:00:57.089 D/ALSAModule(155): open called for devices 00000000 in mode 0...
04-20 19:00:57.109 D/dalvikvm(221): GC_EXPLICIT freed 21K, 9% free 10493K/11527K, paused 2ms+11ms
04-20 19:00:57.119 I/ALSAModule(155): Set global parms
04-20 19:00:57.119 I/ALSAModule(155): Setting interleved PCM
04-20 19:00:57.119 D/memalloc(152): /dev/pmem: Allocated buffer base:0x2ca66000 size:3014656 offset:12582912 fd:39
04-20 19:00:57.139 D/memalloc(221): /dev/pmem: Mapped buffer base:0x4c6b3000 size:15597568 offset:12582912 fd:255
04-20 19:00:57.149 I/TabletStatusBar(354): DISABLE_CLOCK: yes
04-20 19:00:57.179 D/memalloc(152): /dev/pmem: Allocated buffer base:0x2ca66000 size:3014656 offset:19005440 fd:43
04-20 19:00:57.189 D/memalloc(221): /dev/pmem: Mapped buffer base:0x4e51e000 size:22020096 offset:19005440 fd:258
04-20 19:00:57.309 I/ALSAModule(155): Buffer size: 2400, chunk 4800, latency 54421
04-20 19:00:57.309 I/ALSAModule(155): Initialized ALSA PLAYBACK device default
04-20 19:00:57.309 E/AudioHardwareALSA(155): RE-OPEN AFTER STANDBY:: took 257 msecs
04-20 19:00:57.359 D/dalvikvm(1490): GC_CONCURRENT freed 239K, 15% free 7081K/8263K, paused 4ms+6ms
04-20 19:00:57.539 D/memalloc(152): /dev/pmem: Allocated buffer base:0x2ca66000 size:3014656 offset:6029312 fd:54
04-20 19:00:57.549 D/memalloc(221): /dev/pmem: Mapped buffer base:0x4d593000 size:9043968 offset:6029312 fd:264
04-20 19:01:00.229 W/ThrottleService(221): unable to find stats for iface rmnet0
04-20 19:01:00.549 I/ALSAModule(155): ALSA Module: closing down output device
04-20 19:01:31.889 D/dalvikvm(517): GC_FOR_ALLOC freed 258K, 10% free 7374K/8135K, paused 27ms
04-20 19:03:47.730 I/power   (221): *** set_screen_state 1
04-20 19:03:47.760 D/Sensors (221): sensor activation called: handle=3, enabled=1********************************
04-20 19:03:47.770 D/Sensors (221): sensor activation called: handle=0, enabled=1********************************
04-20 19:03:47.800 I/CpuGovernorService(221): intent action: android.intent.action.SCREEN_ON
04-20 19:03:47.800 E/WifiStateMachine(221): set suspend optimizations failed!
04-20 19:03:47.830 I/lights  (221): Enabling touch screen
04-20 19:03:47.830 D/lights  (221): Send ts socket 1 byte(s): 'O'
04-20 19:03:47.830 D/ts_srv  (148): Socket received 1 byte(s): 'O'
04-20 19:03:47.830 I/ts_power(148): touchscreen_power: enable=1, ts_state=0
04-20 19:03:47.830 I/WindowManager(221): Lock screen displayed!
04-20 19:03:48.010 D/SurfaceFlinger(152): Screen about to return, flinger = 0xf918
04-20 19:03:48.030 D/ts_srv  (148): uart opened at 15
04-20 19:03:48.150 D/dalvikvm(1490): GC_CONCURRENT freed 365K, 15% free 7105K/8263K, paused 2ms+3ms
04-20 19:03:48.920 D/dalvikvm(517): GC_FOR_ALLOC freed 258K, 10% free 7374K/8135K, paused 34ms
04-20 19:03:49.340 D/OpenGLRenderer(221): Flushing caches (mode 0)
04-20 19:03:49.350 D/memalloc(221): /dev/pmem: Unmapping buffer base:0x4c6b3000 size:15597568 offset:12582912
04-20 19:03:49.350 D/memalloc(221): /dev/pmem: Unmapping buffer base:0x4e51e000 size:22020096 offset:19005440
04-20 19:03:49.350 D/memalloc(221): /dev/pmem: Unmapping buffer base:0x4d593000 size:9043968 offset:6029312
04-20 19:03:49.350 D/memalloc(152): /dev/pmem: Freeing buffer base:0x2d666000 size:3014656 offset:12582912 fd:39
04-20 19:03:49.350 D/memalloc(152): /dev/pmem: Freeing buffer base:0x2d026000 size:3014656 offset:6029312 fd:54
04-20 19:03:49.360 I/ALSAModule(155): ALSA Module: closing down output device
04-20 19:03:49.380 D/dalvikvm(354): GC_CONCURRENT freed 430K, 8% free 7657K/8263K, paused 4ms+1ms
04-20 19:03:49.380 D/ALSAModule(155): open called for devices 00000000 in mode 0...
04-20 19:03:49.400 I/TabletStatusBar(354): DISABLE_CLOCK: no
04-20 19:03:49.410 I/ALSAModule(155): Set global parms
04-20 19:03:49.410 I/ALSAModule(155): Setting interleved PCM
04-20 19:03:49.440 V/TabletStatusBar(354): setLightsOn(true)
04-20 19:03:49.470 I/ALSAModule(155): Buffer size: 2400, chunk 4800, latency 54421
04-20 19:03:49.470 I/ALSAModule(155): Initialized ALSA PLAYBACK device default
04-20 19:03:49.470 E/AudioHardwareALSA(155): RE-OPEN AFTER STANDBY:: took 113 msecs
04-20 19:03:49.500 W/InputManagerService(221): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@2bec6328
04-20 19:03:49.610 D/memalloc(152): /dev/pmem: Freeing buffer base:0x2dc86000 size:3014656 offset:19005440 fd:43
04-20 19:03:52.670 I/ALSAModule(155): ALSA Module: closing down output device
 
pgzerwer
Old
#315  
Senior Member
Thanks Meter 141
Posts: 345
Join Date: Aug 2011
Location: Peoria
Ashtrai, have not seen many other references to this issue, but did notice this (see link) was to be added to next nightly. Don't know if it will help you or not.

http://review.cyanogenmod.com/#/c/14962/

Sent from my cm_tenderloin using Tapatalk 2
 
tichs
Old
#316  
Senior Member
Thanks Meter 20
Posts: 189
Join Date: Oct 2011
I think there is a few more issues before RC comes out. The videos still are laggy and stop randomly. Beats Audio has to be enabled as well
 
lafester
Old
#317  
lafester's Avatar
Senior Member
Thanks Meter 235
Posts: 1,981
Join Date: Feb 2007
Quote:
Originally Posted by pgzerwer View Post
Ashtrai, have not seen many other references to this issue, but did notice this (see link) was to be added to next nightly. Don't know if it will help you or not.

http://review.cyanogenmod.com/#/c/14962/

Sent from my cm_tenderloin using Tapatalk 2
I've been posting about that issue since cm7 broke it with alpha 3.
For some reason it only affects a small minority of tp owners.

If that patch does not fix it then you can use bricked kernel for now... its the only kernel that fixes the sound bug as far as I know.
Stop the madness... Delete your 'SENT FROM MY' Sig
 
emuX
Old
#318  
Senior Member
Thanks Meter 84
Posts: 370
Join Date: Sep 2009
Quote:
Originally Posted by zard View Post
Do you mind pointing me to the Chainfire 3D drivers? Thanks.

Sent from my GT-N7000 using Tapatalk 2
They are in the Google Play store, as I think its already been said (sorry don't check every thread every day!)

I have the purchased version and use the Beta EGL driver in case that makes a difference. Can't take the credit if it works, as it was a guy on the CM9 thread that pointed it out first.
 
ashtrai
Old
#319  
Junior Member
Thanks Meter 3
Posts: 24
Join Date: Jan 2011
Quote:
Originally Posted by lafester View Post
I've been posting about that issue since cm7 broke it with alpha 3.
For some reason it only affects a small minority of tp owners.

If that patch does not fix it then you can use bricked kernel for now... its the only kernel that fixes the sound bug as far as I know.
I found out today that if you keep headphones in your TP, the sound wont stop working even if your TP goes into deep sleep. So that's something to help figure this out i guess.

I'm using my SGSII headphones, with the extra microphone ring btw, so that might be the problem? Anyone using headphones with built in microphones
 
Adan.Mejia3
Old
#320  
Adan.Mejia3's Avatar
Member
Thanks Meter 7
Posts: 62
Join Date: Feb 2011
What min/max do you guys run? I personally run 756/1782 interactive and have nice performance results.

Sent from my cm_tenderloin

Tags
test
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes