Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Acer Recovery Intaller 2.99beta1 (A100/A101/A200/A500/A501)

OP Euclid's Brother

22nd April 2012, 05:19 PM   |  #21  
Senior Member
Thanks Meter: 57
 
161 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by Euclid's Brother

This is a beta release of the latest Acer Recovery Installer. Once the beta is finished, it will be release on the android market as version 3.0.

Please let me know if I can help test the A510 for support when the times comes. I would love to have this running on the A510.

Thanks!
23rd April 2012, 02:58 AM   |  #22  
Senior Member
Flag Kalifornia
Thanks Meter: 84
 
188 posts
Join Date:Joined: Feb 2012
I'm trying it out today so far so good. It's the easiest way to get cwm on the A100 that I have tried so far. I was able to create a backup on the external sd card without a problem. I like the green text color too.

Nice work man. I'm glad I tried it out.
23rd April 2012, 11:40 PM   |  #23  
Senior Member
Flag Łódź
Thanks Meter: 42
 
364 posts
Join Date:Joined: Nov 2010
More
hm I've got 2 messages.
1) Your Iconia A501 may not be supported! If you are running a custom rom, it may be reporting a different model.
2)Unable to download latest list of recoveries.

but after changing the model name in build.prop from Iconia A501 to A501 the first message is gone. Second is still there.
24th April 2012, 06:20 PM   |  #24  
Euclid's Brother's Avatar
OP Senior Member
Flag Dallas, TX
Thanks Meter: 256
 
900 posts
Join Date:Joined: May 2011
Donate to Me
Are you connected to the internet when you run it? Not sure why it wouldn't be able to download the list.

Quote:
Originally Posted by macia10

hm I've got 2 messages.
1) Your Iconia A501 may not be supported! If you are running a custom rom, it may be reporting a different model.
2)Unable to download latest list of recoveries.

but after changing the model name in build.prop from Iconia A501 to A501 the first message is gone. Second is still there.



My apologies to for not having another update ready yet. I haven't had much time to work on it the past couple of weeks. I should be able to work on it some this week for a possible weekend update.

If someone can send me a stock recovery for the A510, I'll repack thor1.7 cwm using that kernel.
27th April 2012, 11:00 PM   |  #25  
Senior Member
Thanks Meter: 59
 
332 posts
Join Date:Joined: Jun 2010
I assume this
Quote:

Since this version is not on the android market, it cannot validate any premium licenses, although it will use one if you already have a local license file.

is why I'm getting this
Quote:

Your locally cached license is about to expire. Please connect to the internet soon to refresh your license status.



---------- Post added at 05:00 PM ---------- Previous post was at 04:37 PM ----------

This is not new to ARI 2.99beta1, but I thought this would be a good thread to report this issue.

One problem I noticed after I updated my ROM to FlexReaper 12.5 is that when I would go into ARI and select "Backup all partitions" is that it would reboot into recovery and then almost immediately reboot without running a backup. /cache/recovery/last_log didn't show any useful error.

I finally figured out it was because in FR 12.5, the ro.display.id property contains a ':' character. This was then used in the default filename for the backup, which fails as colon is an illegal character in the FAT32 filesystem. Manually changing the ':' to '_' resolves the problem.

You should probably filter this character out by default in your next release.
3rd May 2012, 01:19 PM   |  #26  
Junior Member
Thanks Meter: 4
 
25 posts
Join Date:Joined: Sep 2011
when the version 3?
4th May 2012, 07:28 AM   |  #27  
hatefuel19's Avatar
Senior Member
Flag Lex
Thanks Meter: 108
 
299 posts
Join Date:Joined: Sep 2010
More
Will this allow me to flash a working gpl compliant recovery on unlocked bl v3?

Sent from my MB860 using Tapatalk 2
4th May 2012, 09:54 PM   |  #28  
Euclid's Brother's Avatar
OP Senior Member
Flag Dallas, TX
Thanks Meter: 256
 
900 posts
Join Date:Joined: May 2011
Donate to Me
Thanks, I'll definately do that!

Been doing alot of updates on the licensing. Beta2 is in the link of the OP, but I just haven't had a chance to make a changelog. It supports A510, but not sure how stable the cwm is for it. Will be working on adding twrp support soon.

Beta3 should come hopefully sunday night (may not have twrp support yet).



Quote:
Originally Posted by elborak

I assume this

is why I'm getting this


---------- Post added at 05:00 PM ---------- Previous post was at 04:37 PM ----------

This is not new to ARI 2.99beta1, but I thought this would be a good thread to report this issue.

One problem I noticed after I updated my ROM to FlexReaper 12.5 is that when I would go into ARI and select "Backup all partitions" is that it would reboot into recovery and then almost immediately reboot without running a backup. /cache/recovery/last_log didn't show any useful error.

I finally figured out it was because in FR 12.5, the ro.display.id property contains a ':' character. This was then used in the default filename for the backup, which fails as colon is an illegal character in the FAT32 filesystem. Manually changing the ':' to '_' resolves the problem.

You should probably filter this character out by default in your next release.

The Following User Says Thank You to Euclid's Brother For This Useful Post: [ View ]
4th May 2012, 09:56 PM   |  #29  
Euclid's Brother's Avatar
OP Senior Member
Flag Dallas, TX
Thanks Meter: 256
 
900 posts
Join Date:Joined: May 2011
Donate to Me
Quote:
Originally Posted by hatefuel19

Will this allow me to flash a working gpl compliant recovery on unlocked bl v3?

Sent from my MB860 using Tapatalk 2

yes. If the cwm is listed in the app, then it is GPL compliant. It does support the ICS bootloader.. Doesn't matter if it's the .11-ICS or the .12-UNL
The Following 2 Users Say Thank You to Euclid's Brother For This Useful Post: [ View ]
6th May 2012, 03:14 AM   |  #30  
hatefuel19's Avatar
Senior Member
Flag Lex
Thanks Meter: 108
 
299 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by Euclid's Brother

yes. If the cwm is listed in the app, then it is GPL compliant. It does support the ICS bootloader.. Doesn't matter if it's the .11-ICS or the .12-UNL

I think I should clarify. I don't want thors recovery so will this allow me to flash a working RA or twrp with ics boot loader.

Sent from my MB860 using Tapatalk 2

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes