Post Reply

[Q] Photon CM9 connecting to 802.1x network

OP DennDennMagoo

17th April 2012, 05:21 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jan 2012
Hi,

I'm on CM9 Beta0.5. I have never connected my phone to work wifi but I want to give it a try.

On my Mac, it says this in the settings:
802.1X: WPA: staff-wlan
Authenticated via PEAP (GTC)

When I go to wifi settings I see staff-wlan but it says it's secured with WEP. I try my password and it just keeps cycling through "obtaining IP address".

When I try to add a new network with all the correct information (802.1x, username, pw, etc) it just says not in range and doesn't recognize the network.

I've tried researching the issue a bit. Apparently you can adjust the settings of an already established network using "Advanced Wifi Editor" from the market. Only problem.... doesn't work on ICS.

I've also read that you can manually adjust the settings in the wpa_supplicant.conf file. I opened up the file and saw this:
update_config=1
ctrl_interface=wlan0
eapol_version=1
ap_scan=1
fast_reauth=1


That's all that's in there... what exactly can I type in to possibly get this network connected?
22nd April 2012, 07:02 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jan 2012
Photon CM9 802.1x wpa_supplicant.conf
I figured it out in case anyone runs into the problem in the future. When Googling, I didn't find anything specific to the Photon, however it seems that CM9 has some problems when it comes to 802.1x networks. Basically, ICS is capable of handling 802.1x but the UI isn't up to par. So for whatever reason, my work network was showing up as WPA or WEP or whatever (I think it changed a few times honestly). I wasn't able to edit the settings at all. When I added a new network as 802.1x, it would say not in range.

So as I mentioned above, people said you can edit the wpa_supplicant.conf file to adjust the settings. I was originally editing the wpa_supplicant.conf file in /system/etc/wifi to no avail, then I found out, there's a different wpa_supplicant.conf in /data/misc/wifi. I used Root Explorer to mount as rw then opened wpa_supplicant.conf with Text Editor.

THIS time I saw all my previously saved networks with all their info. This is what I should have been seeing the whole time.

From that point it was as easy as editing the existing entry for my work wifi. I typed

network={
ssid="network name"
key_mgmt=1EEE8021X
eap=PEAP
identity="email@work.com"
password="password"
phase2="auth=EAP-GTC"
priority=4
}

Saved the changes. Most likely rebooted and the wifi connected!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes