Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,536 Members 53,724 Now Online
XDA Developers Android and Mobile Development Forum
View Poll Results: What Would You Like to See Added/Removed
Remove Rom Manager 15 38.46%
Keep Rom Manager 22 56.41%
Remove Fun & Games 29 74.36%
Keep Fun & Games 9 23.08%
Add ConnectBot 6 15.38%
Do Not Add ConnectBot 22 56.41%
Add Dolphin Browser HD 7 17.95%
Do Not Add Dolphin Browser HD 26 66.67%
Add exDialer w/ ICS Theme AC 9 23.08%
Do Not Add exDialer w/ ICS Theme AC 19 48.72%
Add Play Music 23 58.97%
Do Not Add Play Music 11 28.21%
Add SuperSU 22 56.41%
Do Not Add SuperSU 11 28.21%
Add OpenExplorer Beta 8 20.51%
Do Not Add OpenExplorer Beta 22 56.41%
Add Alarm Clock Plus 12 30.77%
Do Not Add Alarm Clock Plus 21 53.85%
Multiple Choice Poll. Voters: 39. You may not vote on this poll

[ROM][CDMA]CM9 - Built for R800x - U:0605

Tip us?
 
KeiranFTW
Old
#361  
KeiranFTW's Avatar
Recognized Developer
Thanks Meter 2724
Posts: 2,639
Join Date: Nov 2011
Location: Sunderland

 
DONATE TO ME
Quote:
Originally Posted by agraceful View Post
I can test it out probably later today or tomorrow, and yes we change it to xperia play, I don't think there would be a problem if we changed it to zeusc.. You can edit it in the build.prop and try for yourself if you like. It's just what me, pax, and chevy have been branding it

---------- Post added at 01:02 PM ---------- Previous post was at 12:59 PM ----------



I do what chevy did and just edit it myself then re-zip and re-sign it.. I'll try to just make a patch this week if I find the time. Cm and stock are set up entirely different as far as I've learned with it. I have yet to do any developing as far as stock goes so I'm not much help there lol
If you are setting zeusc as board, you shouldn't do that, because you also use the zeus board. Besides I think we have to leave the board property field blank.

Hows my kernel doing
Sony Xperia SP - C5303 O2

illumination app for Xperia SP
The Following User Says Thank You to KeiranFTW For This Useful Post: [ Click to Expand ]
 
paxChristos
Old
#362  
paxChristos's Avatar
Retired Forum Moderator - OP
Thanks Meter 1463
Posts: 2,036
Join Date: Aug 2011
Location: Milwaukee

 
DONATE TO ME
Quote:
Originally Posted by Mogul345 View Post
Hey, is anyone out there also using Robert Broglia's .emu line of emulators in the market? I've been trying to work through an issue I've been having since the beginning of chevy's ports of CM9 to our devices, which is that when I first open any of his emulators and start a ROM for the first time in that instance of the emu, I get an all white screen for the playfield, which only goes away after I enter the emu's menu and make it redraw itself somehow (by scrolling or choosing an option or just exiting out of the menu). After that it doesn't happen again, even if I load a new ROM/Savestate.

Unfortunately, Robert has an R800at, not an R800x, and he just installed FXP116 yesterday and he was unable to reproduce. So I'm worried that it's either my specific phone, or something in our build.

If anyone out there is willing to test, his port of SNES9x is free at his website - http://www.explusalpha.com/home/snes9x-ex/downloads.

Also, pax/agraceful, are you guys consistent in what you're setting as the name of our device in the build.prop? I ask b/c there's another bug he fixed already, but part of the fix requires detecting our device, and in FXP116 on his R800at he said the device name came up as "zeus" but in previous logcats I submitted to him, our name was "R800x". And I looked in the build.prop of the 4/19 build, and the name looks like it's "Xperia Play" now.
Just tested it out on 04/21, no problems when loading a game (haven't tried multiple, yet.)

I normally changed the build.prop in mine to this:
Code:
Select Code
ro.product.model=R800x
ro.product.brand=Sony Ericsson
ro.product.name=Xperia Play
ro.product.device=zeusc
ro.product.board=zeusc
When I do it straight from code, it does come out as this:
Code:
Select Code
ro.product.model=Xperia Play
ro.product.brand=SEMC
ro.product.name=R800i
ro.product.device=zeus
ro.product.board=zeus
Normally i'm pretty good about changing that one :P

Quote:
Originally Posted by netizenmt View Post
Is the cdma conversion done by patching or is it another recompile? It seems by now we ought to be able to have a patch we could use to experiment with other roms. And I'm also curious to know what is so different about ICS that we can't use that same process to get cdma working on it.

Sent from my R800x using xda premium
If you look in the folder, there's a zip file name porting libs.zip. That's what's used to port to .88 baseband, but be forewarned, it ONLY work with CM based roms.

Stock based requires SemcPhone.apk tweaks, along with framework.jar tweaks (and probably tweaks to everything that depends on semcphone.apk)

(NOTE: I have tried just copying pasting the files from the zip (and fixing build.prop) for .368 .42 .62, PlayIcsBeta, & a couple of others (icXperia has issues (i had an issue where the home launcher wouldn't load)) MIUI had issues with phone.apk crashing (similar to icsBeta)) and that's all I can think of )

Pax
Tips:
*Logcat or it never happened. *Search before posting *Go to User CP -> Edit Options -> switch "Number of Posts to Show Per Page" to 50. *Reporting Posts

Looks like I won't be doing anything android for a long time

Thanks for the lul'z

Pax
 
Mogul345
Old
#363  
Senior Member
Thanks Meter 36
Posts: 239
Join Date: Apr 2006
pax/agraceful,

Thanks for the quick response on the .emu thing. I did leave out one detail. Make sure you guys have the on-screen controls disabled (Menu -> Options -> Input -> On-screen Controls). If the on-screen controls are enabled, I don't have the issue. If you already did this, crap I guess it's just me

As for the name in the build.prop, I'm just hoping to find something common between our builds and the GSM builds for Robert to use as an identifier, because he's about to go back and change what he was using before to detect, and I think it might end up breaking detection on our devices. From the email he sent me:

"1. The model name is "zeus" instead of "r800*" so the app doesn't default to the Xperia Play control mapping, fixing that in the next update"

Re-reading that, I looked at our build.prop again, I think I'm looking at the wrong value. I think he's referring to ro.product.model, which is R800x in our builds. Is it just "zeus" in the GSM build from FXP?
The Following User Says Thank You to Mogul345 For This Useful Post: [ Click to Expand ]
 
paxChristos
Old
#364  
paxChristos's Avatar
Retired Forum Moderator - OP
Thanks Meter 1463
Posts: 2,036
Join Date: Aug 2011
Location: Milwaukee

 
DONATE TO ME
Quote:
Originally Posted by Mogul345 View Post
pax/agraceful,

Thanks for the quick response on the .emu thing. I did leave out one detail. Make sure you guys have the on-screen controls disabled (Menu -> Options -> Input -> On-screen Controls). If the on-screen controls are enabled, I don't have the issue. If you already did this, crap I guess it's just me
Quick response: yes disabling on screen controls does hang on a white screen on 4/21. I tried opening up the gamepad & got a reboot

Sent from my phone, please excuse any Swypos.
Tips:
*Logcat or it never happened. *Search before posting *Go to User CP -> Edit Options -> switch "Number of Posts to Show Per Page" to 50. *Reporting Posts

Looks like I won't be doing anything android for a long time

Thanks for the lul'z

Pax
 
KeiranFTW
Old
#365  
KeiranFTW's Avatar
Recognized Developer
Thanks Meter 2724
Posts: 2,639
Join Date: Nov 2011
Location: Sunderland

 
DONATE TO ME
Set ro.product.board to zeus even if you are the CDMA variant, you still use the same board
Sony Xperia SP - C5303 O2

illumination app for Xperia SP
The Following User Says Thank You to KeiranFTW For This Useful Post: [ Click to Expand ]
 
paxChristos
Old
#366  
paxChristos's Avatar
Retired Forum Moderator - OP
Thanks Meter 1463
Posts: 2,036
Join Date: Aug 2011
Location: Milwaukee

 
DONATE TO ME
Quote:
Originally Posted by KeiranFTW View Post
Set ro.product.board to zeus even if you are the CDMA variant, you still use the same board
I'll fix the build.prop I use so from 4/2x on it'll be ro.product.board= zeus (as long as it doesn't break data, knowing Verizon, it probably will )

Sent from my phone, please excuse any Swypos.
Tips:
*Logcat or it never happened. *Search before posting *Go to User CP -> Edit Options -> switch "Number of Posts to Show Per Page" to 50. *Reporting Posts

Looks like I won't be doing anything android for a long time

Thanks for the lul'z

Pax
 
Mogul345
Old
#367  
Senior Member
Thanks Meter 36
Posts: 239
Join Date: Apr 2006
Quote:
Originally Posted by paxChristos View Post
Quick response: yes disabling on screen controls does hang on a white screen on 4/21. I tried opening up the gamepad & got a reboot

Sent from my phone, please excuse any Swypos.
Hmm, good to know it's not just me then. Although I can't repro the reboot. Maybe you just got unlucky, although I usually start games with the gamepad already open.

I sent Robert a link to this thread, hopefully he'll see this stuff. In any case, I'll relay this info to Robert.

Thanks guys!
 
paxChristos
Old
#368  
paxChristos's Avatar
Retired Forum Moderator - OP
Thanks Meter 1463
Posts: 2,036
Join Date: Aug 2011
Location: Milwaukee

 
DONATE TO ME
Quote:
Originally Posted by Mogul345 View Post
Hmm, good to know it's not just me then. Although I can't repro the reboot. Maybe you just got unlucky, although I usually start games with the gamepad already open.

I sent Robert a link to this thread, hopefully he'll see this stuff. In any case, I'll relay this info to Robert.

Thanks guys!
Otherwise if Robert hops on this thread/sends me a pm, I'm more than willing to try to get it fixed! (I'm definitely a fan of getting as many programs working with this as possible)

Sent from my phone, please excuse any Swypos.
Tips:
*Logcat or it never happened. *Search before posting *Go to User CP -> Edit Options -> switch "Number of Posts to Show Per Page" to 50. *Reporting Posts

Looks like I won't be doing anything android for a long time

Thanks for the lul'z

Pax
 
lightningdude
Old
#369  
lightningdude's Avatar
Senior Member
Thanks Meter 277
Posts: 795
Join Date: Oct 2010
Quote:
Originally Posted by lightningdude View Post
I tried using Keiran's "newboot.img" that is supposed to make video playback work again. Whenever I boot and try to get my Link2SD working, on my ext4 sd-ext, it gives me the following error:

"Mount Script cannot be created.
mount: mounting /dev/block/vold/179:2 on /data/sdext2 failed: No such device
ext4 may not be supported on your device. Try FAT32 on the second partition."

That error message is obvious enough, but my question for Keiran is, does your kernel actually not support ext4, or is there a bug somewhere else? I'm back on DooMKerneL until I receive an answer either way. I don't really want to switch everything over if it's a smaller issue.
Sorry to quote myself, but Keiran did ask how his kernel was doing and it seems I was completely skipped over.

Sent from my R800x using XDA
 
KeiranFTW
Old
#370  
KeiranFTW's Avatar
Recognized Developer
Thanks Meter 2724
Posts: 2,639
Join Date: Nov 2011
Location: Sunderland

 
DONATE TO ME
Quote:
Originally Posted by lightningdude View Post
Sorry to quote myself, but Keiran did ask how his kernel was doing and it seems I was completely skipped over.

Sent from my R800x using XDA
Ext4 might not be enabled in kernel, will post fix tomorrow if I can

Sent from my Sony Xperia™ PLAY using Tapatalk 2
Sony Xperia SP - C5303 O2

illumination app for Xperia SP

The Following User Says Thank You to KeiranFTW For This Useful Post: [ Click to Expand ]
Tags
awesomeness, bazinga, cdma, cyanogenmod, first xperia play cm9 with theme manager!!, ics, legend-wait-for-it-dary!, penut butter jelly time!, r800x, sudo install!, unofficial cm9, why haven't you installed this yet?, xperia play, zeusc
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes