5,593,587 Members 38,833 Now Online
XDA Developers Android and Mobile Development Forum

Help !Auto rotation not working in any rom(including cm 7.2 rc1,gsf r4 etc)

Tip us?
 
mfaarouq
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2012
Location: Lagos
Unhappy Help !Auto rotation not working in any rom(including cm 7.2 rc1,gsf r4 etc)

Pls help! i av been all over d internet for a solution, i av an osf(zte blade) gen2, installed cm 7.1 stable and for abt 2 weeks or so everything was fine but after then accelerometer began to lag and finally stopped working. i av tried every possible solution i came by but no luck. i insalled ss rls5 with softbank kernel as some users suggested still no auto rotate, tried different 2.2 roms swedish snow,jj etc no show i even tried cm 7.2 rc1 still no show then i heard wbaws gsf did it for some pple with d problem.then thinking that was d answer to my problem, flashed gsf r4 and still no show
from emode helper, sensor test shows acc x,y,z: fail magnetic x,y,z:fail
some pple said it is a kernel issue etc but i av tried diff roms(from above) with diff kernels. and auto rotate is ticked in d display settings and also cm settings. pls i need ur help badly to rturn my blade to what it once was!
 
saaransh9
Old
#2  
Senior Member
Thanks Meter 149
Posts: 701
Join Date: Jul 2011
seems to be a hardware problem use warranty if there or give it for repairs
Current device- ZTE blade
ROM- Cyanogemod 7.2 kang burgerz 29 feb,cm9 coldfuion

Mods-
Beats audio
Bravia engine
New adreno libs

I HELPED YOU ???
Do HIT THIS BUTTON
The Following User Says Thank You to saaransh9 For This Useful Post: [ Click to Expand ]
 
mfaarouq
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2012
Location: Lagos
Question how to repair zte accelerometer sensor

thanks! s warranty is void since I rooted it,but do u think I will av to change d sensors or what do u think might be d hardware fault,and can any accelerometer sensor work for it if it is to be repaired?
 
saaransh9
Old
#4  
Senior Member
Thanks Meter 149
Posts: 701
Join Date: Jul 2011
Quote:
Originally Posted by mfaarouq View Post
thanks! s warranty is void since I rooted it,but do u think I will av to change d sensors or what do u think might be d hardware fault,and can any accelerometer sensor work for it if it is to be repaired?
Just flash the stock of your country and its unrooted and back in warranty
Current device- ZTE blade
ROM- Cyanogemod 7.2 kang burgerz 29 feb,cm9 coldfuion

Mods-
Beats audio
Bravia engine
New adreno libs

I HELPED YOU ???
Do HIT THIS BUTTON
 
Hellz0wn
Old
#5  
Hellz0wn's Avatar
Member
Thanks Meter 10
Posts: 63
Join Date: Jan 2012
try checking every settings.

especially in: "display"
"cyanogenmod --> display" <-- only if you have cyanogenmod

-
Send from ZTE Blade
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes