Post Reply

Lumia 900 wont power on after battery drain..bricked!!

OP sridhar618

14th April 2012, 03:23 AM   |  #11  
Member
Thanks Meter: 3
 
69 posts
Join Date:Joined: Feb 2011
More
if your phone can't boot after a deep discharge, try hooking it up with the original cable to a computer USB port.
14th April 2012, 04:23 PM   |  #12  
Member
Thanks Meter: 0
 
38 posts
Join Date:Joined: Jun 2009
I guess my first questions is how are you charging it in the first place? USB or Electric outlet? USB usually takes longer and can be a weaker charge.

Second, like some people mention are us using another charger by a different company like HTC and etc..?

This will help us understand the issue better to help you.
14th April 2012, 05:49 PM   |  #13  
Senior Member
Flag Miami
Thanks Meter: 110
 
1,169 posts
Join Date:Joined: Oct 2008
More
That being said, my HD7 pulled this with me once... All was well after though.
Last edited by prbassplayer; 22nd April 2012 at 11:59 PM. Reason: Mod edit
14th April 2012, 06:53 PM   |  #14  
hx4700 Killer's Avatar
Senior Member
Texas
Thanks Meter: 256
 
1,218 posts
Join Date:Joined: Oct 2007
Quote:
Originally Posted by FiyaFleye

Do you think any of us give a damn about your Galaxy Nexus in the Lumia section? Honestly? Because if you do, then I think you need to re-examine the idea behind a LUMIA forum.

That being said, my HD7 pulled this with me once... All was well after though.

Don't feed the troll... otherwise you will just get more oxygen/blood deprived answers from someone trying to type one handed, not skip a stroke and sound like they aren't trolling. Probably has a thing for the latest and greatest but is locked in to a contract....
16th April 2012, 03:24 PM   |  #15  
sridhar618's Avatar
OP Member
VA
Thanks Meter: 1
 
50 posts
Join Date:Joined: May 2009
More
Quote:
Originally Posted by johnnybrav0

I guess my first questions is how are you charging it in the first place? USB or Electric outlet? USB usually takes longer and can be a weaker charge.

Second, like some people mention are us using another charger by a different company like HTC and etc..?

This will help us understand the issue better to help you.

After the charge completely depleted, i hooked it to the wall using the nokia supplied charger for abt 7 hrs. The phone did not respond on trying to power it up. I tried all button combos, plugging to comp, plugging and unplugging multiple times etc (you name it and I have tried) but none of them worked. I tried to resurrect it for a full. I finally gave up and swapped for a another device at the ATT store.

The device should reach you guys via your channels for your R&D.
21st April 2012, 04:20 AM   |  #16  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Apr 2012
I just bought the phone. After 3 hours of charging using the Nokia charger. Phone is still not booting. After connecting the charger cable it vibrates and the 3 button lights turn on, but thats all that happens.
22nd April 2012, 04:32 AM   |  #17  
Member
Thanks Meter: 1
 
49 posts
Join Date:Joined: Mar 2008
Quote:
Originally Posted by davel8135

I just bought the phone. After 3 hours of charging using the Nokia charger. Phone is still not booting. After connecting the charger cable it vibrates and the 3 button lights turn on, but thats all that happens.

If the Lumia 900 is drained completely it will not power on until it gets a 20% charge. If your phone wasn't charged to that in 3 hrs. you should take it back and get another phone.
22nd April 2012, 03:17 PM   |  #18  
hx4700 Killer's Avatar
Senior Member
Texas
Thanks Meter: 256
 
1,218 posts
Join Date:Joined: Oct 2007
I want to say that it was at least two hours if not 3 before my phone came on from a total discharge.

The phone would vibrate and flash if I plugged or unplugged etc... I played with it enough that it came on was still pretty much dead on the charge but once on and plugged in it actually charged so what I read above that it won't charge if its not on seems to hold true.

Of course that was all before the update.
23rd April 2012, 12:00 AM   |  #19  
prbassplayer's Avatar
Recognized Developer / Retired Forum Moderator
Thanks Meter: 11,843
 
9,579 posts
Join Date:Joined: Mar 2011
Donate to Me
More
Keep it civil
Thread cleaned.
23rd April 2012, 12:47 AM   |  #20  
Member
Thanks Meter: 2
 
39 posts
Join Date:Joined: Jan 2009
I experienced the same thing last night. When it finally did power back on, it was at 22%... And hard reset!

Calling it a PITA is an understatement.

Post Reply Subscribe to Thread

Tags
att, brick, lumia 900, nokia
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes