Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Unable To Turn on Wi-Fi

OP mbrentrowe

23rd April 2012, 02:45 AM   |  #1  
OP Member
Thanks Meter: 4
 
30 posts
Join Date:Joined: Jul 2011
I'm having an issue with wi-fi. I'm running Andromadus Audacity 2. Yesterday I ran into an issue where my phone was randomly rebooting. I decided to reflash the rom and when I did so I could no longer connect to Wi-Fi. I can turn Wi-Fi on but it will immediately turn back off. In settings it will only say turning wi-fi on and hang up there.

I don't think that the issue is the router since my wife's G2 and other devices we have in the house still work fine on wi-fi.

Also it's not the rom because I have superwiped and reinstalled, then tried installing cm7, and ilwt. The issue persists on each rom. I have superwiped each time before installing.

I am really at a loss for what to do, I didn't change any settings on the phone and regardless, I don't know what I could have changed that would have carried over through flashing a new rom. I would appreciate any ideas on what to do.

ETA - I have changed the radio and the kernel and still no luck.
Last edited by mbrentrowe; 24th April 2012 at 01:28 PM.
25th April 2012, 07:30 PM   |  #2  
Member
Thanks Meter: 13
 
66 posts
Join Date:Joined: Apr 2012
Check

Sent from my HTC Vision using XDA
25th April 2012, 07:31 PM   |  #3  
Member
Thanks Meter: 13
 
66 posts
Join Date:Joined: Apr 2012
Sorry accidental send, check the /etc/wifi/wpa*.conf permissions and ownership. This happened to me when that file was off.

Sent from my HTC Vision using XDA
25th April 2012, 11:52 PM   |  #4  
OP Member
Thanks Meter: 4
 
30 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by A_Elizondo

Sorry accidental send, check the /etc/wifi/wpa*.conf permissions and ownership. This happened to me when that file was off.

Sent from my HTC Vision using XDA

When you say off do you mean it was absent?

When I got to /etc/wifi/ there is a file named wpa_supplicant.conf, it is the only file in the folder

the text file says:

update_config=1
ctrl_interface=wlan0
eapol_version=1
ap_scan=1
fast_reauth=1
27th April 2012, 03:20 AM   |  #5  
Member
Thanks Meter: 13
 
66 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by mbrentrowe

When you say off do you mean it was absent?

When I got to /etc/wifi/ there is a file named wpa_supplicant.conf, it is the only file in the folder

the text file says:

update_config=1
ctrl_interface=wlan0
eapol_version=1
ap_scan=1
fast_reauth=1

Sorry my English is not as great as I wished it would be, this is what happens when I try to use "slang". When I say off I mean not correct. That is the correct file "wpa_supplicant.conf"

/etc/wifi/wpa_supplicant.conf --> needs rw-r--r--
/system/bin/wpa_supplicant --> needs rwxr-xr-x

I just checked my files and they are both owned by root and all works well so I guess its not an issue that wifi does not own them.
The Following User Says Thank You to A_Elizondo For This Useful Post: [ View ]
27th April 2012, 04:56 AM   |  #6  
OP Member
Thanks Meter: 4
 
30 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by A_Elizondo

Sorry my English is not as great as I wished it would be, this is what happens when I try to use "slang". When I say off I mean not correct. That is the correct file "wpa_supplicant.conf"

/etc/wifi/wpa_supplicant.conf --> needs rw-r--r--
/system/bin/wpa_supplicant --> needs rwxr-xr-x

I just checked my files and they are both owned by root and all works well so I guess its not an issue that wifi does not own them.

Sorry I just misunderstood.

I checked both files and they had the same permissions that you wrote out.
27th April 2012, 05:37 AM   |  #7  
Member
Thanks Meter: 13
 
66 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by mbrentrowe

Sorry I just misunderstood.

I checked both files and they had the same permissions that you wrote out.

Not sure if this helps but this is what's under my /etc/wifi/wpa_supplicant.conf file
update_config=1
ctrl_interface=eth0
eapol_version=1
ap_scan=1
fast_reauth=1

Notice my ctrl_interface=eth0 (thats a zero) I'd test that out see if it fixes it, if not then I'd download another rom and extract both /etc/wifi/wpa_supplicant.conf and /system/bin/wpa_supplicant files from it and replace yours. Again verify permissions are correct.
The Following User Says Thank You to A_Elizondo For This Useful Post: [ View ]
27th April 2012, 06:52 PM   |  #8  
OP Member
Thanks Meter: 4
 
30 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by A_Elizondo

Not sure if this helps but this is what's under my /etc/wifi/wpa_supplicant.conf file
update_config=1
ctrl_interface=eth0
eapol_version=1
ap_scan=1
fast_reauth=1

Notice my ctrl_interface=eth0 (thats a zero) I'd test that out see if it fixes it, if not then I'd download another rom and extract both /etc/wifi/wpa_supplicant.conf and /system/bin/wpa_supplicant files from it and replace yours. Again verify permissions are correct.

Hey I'm on lunch now, in that file it says for ctrl_interface=wlan0. I am using es file explorer, it won't let me change it there but I think I read somewhere I can create a text file saying what I want it to and place it in the folder. Not sure if that will work.

As for the other roms, wifi doesn't work on any rom that I use.
28th April 2012, 02:59 AM   |  #9  
Member
Thanks Meter: 13
 
66 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by mbrentrowe

Hey I'm on lunch now, in that file it says for ctrl_interface=wlan0. I am using es file explorer, it won't let me change it there but I think I read somewhere I can create a text file saying what I want it to and place it in the folder. Not sure if that will work.

As for the other roms, wifi doesn't work on any rom that I use.

You can replace the file using a terminal emulator here are the steps
  1. Open terminal emulator and log in as super user by typing the following
    su
  2. Make the System Partition have read/write access by typing the following
    mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
  3. Now you can modify the file using es file explorer
  4. When complete make the system partition read only by doing the following
    mount -o ro,remount -t yaffs2 /dev/block/mtdblock3 /system

You can also copy and replace the file using adb, not sure how familiar you are with that but the above should work.
The Following User Says Thank You to A_Elizondo For This Useful Post: [ View ]
28th April 2012, 02:36 PM   |  #10  
OP Member
Thanks Meter: 4
 
30 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by A_Elizondo

You can replace the file using a terminal emulator here are the steps

  1. Open terminal emulator and log in as super user by typing the following
    su
  2. Make the System Partition have read/write access by typing the following
    mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
  3. Now you can modify the file using es file explorer
  4. When complete make the system partition read only by doing the following
    mount -o ro,remount -t yaffs2 /dev/block/mtdblock3 /system

You can also copy and replace the file using adb, not sure how familiar you are with that but the above should work.

Hmmm, I went into terminal emulator and did just as you said. This is what it says after I pasted in what you wrote to give me read/write access:

Usage: mount [-r] [-w] [-o options] [-t type] device directory

After I did that it still won't let me change that file.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes