Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Installing the V21Y 2.3.4 Update

OP enyahs

22nd April 2012, 05:19 AM   |  #11  
Senior Member
Thanks Meter: 35
 
329 posts
Join Date:Joined: Feb 2010
Do I need to downgrade
TO I need to install stock first or can I just do this from my current rom and then install the rooted stock rom?
22nd April 2012, 05:45 AM   |  #12  
Core Memory's Avatar
Senior Member
Flag Toronto
Thanks Meter: 736
 
1,287 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by lowrider262

tried it from an XP computer today, still didn't work. for some reason running the script fails on me everytime, I've tried it on 3 different computers (2 win7 and an XP). I'm actually trying to downgrade from 21y back to 21e.



Try just running UpTestEX_mod2_marwin.exe in XP mode or Windows XP after you install the drivers in Windows 7 or Windows XP and the other stuff in XP Mode or Windows XP, plug in your phone (with the battery in and the phone on), attach the phone's USB port through the USB menu in XP Mode (You won't have to with Windows XP) and run the script. Even if the script fails, it may allow the update. You have to change the product type to 3GQCT and the PhoneMode to Emergency and select the .kdz file you want to use. Then start the upgrade. If it decrypts the .kdz file successfully, it will check your phone then start upgrade. With XP Mode, you may hear an alert sound which means that the phone's USB port has detached. Reattach it through the XP Mode USB menu each time it detaches. It will pause as it updates and the dialog box will show a list of errors until it finishes and reboots the phone. After the phone reboots, wait a few minutes then detach the phone and reboot. Hopefully that will work.
Last edited by Core Memory; 22nd April 2012 at 05:48 AM.
22nd April 2012, 05:49 AM   |  #13  
Junior Member
Thanks Meter: 2
 
25 posts
Join Date:Joined: Dec 2007
For what its worth, I managed to update successfully using Windows Sever 2008 R2. I followed the instruction after changing the host file manually. Everything went without any problem and the whole process took about 10 minutes.
22nd April 2012, 05:52 AM   |  #14  
enyahs's Avatar
OP Member
Flag Warrensburg
Thanks Meter: 20
 
76 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by gpmartinson

TO I need to install stock first or can I just do this from my current rom and then install the rooted stock rom?

I did mine straight from the weapon rom

Sent from my LG-P999 using XDA
23rd April 2012, 01:14 AM   |  #15  
Member
Thanks Meter: 9
 
86 posts
Join Date:Joined: Jan 2011
Thumbs up
After many, many attempts, I successfully flashed the 21y kdz this morning. Thanks to Core Memory, Overground, enyahs and many others. I am not sure what finally "did it" after many tries, but I will share some notes.

1. Keep at it. I was ready to give up many times, but somehow hung in there.

2. I used XP. I did not try some of the methods folks have suggested for using virtual machines or win7.

3. I flashed stock recovery first.

4. I was coming from Tsugi, but after numerous failures, I reflashed CWM in and restored a stock gb nandroid. I don't think this was important to my eventual success, since it still took many tries, but at least I eliminated one variable.

5. At first I used the KDZ_FW_UPD_EN program from speedsk8x, following his instructions. Specifically, I used the CDMA and DIAG settings. This failed repeatedly. The program seemed to get stuck at "CDMA: wParam = xxx, lParam = yyy" I cannot remember the xxx or yyy, but the numbers would not cycle as speedsk8x's instructions said they would. I waited up to 10 minutes multiple times. Later, I tried again using the "3GQCT" and "EMERGENCY" setting with no success.

6. I then tried the method from this post. That did not work either. Multiple attempts. The VB script seemed to work fine, but the UpTestEX_mod2_marwin.exe program would consistently crash just as the flash process was nearly completion. I tried mutiple USB ports. I did not try a different USB cable.

7. Finally, I started to experiment. I finally tried the "Start Upgrade" button instead of the "Normal web upgrade test" button. The area beneath the button logged very similar steps as the KDZ_FW_UPD_EN method, but wParam and iParam did cycle from 1 up to 100. Finally after 100 my phone rebooted. About phone showed 21y with the new baseband and 2.3.4.

8. Interestingly, UpTestEX_mod2_marwin.exe never "completed." But since the phone seemed rebooted and working fine, I unplugged the USB and closed the program. Phone is working fine. Better than fine, so far. I flashed kwes's rooted 2.3.4 ROM, deleted some bloat, and the phone is functioning great. Everything seems to work and is snappy. GPS locked immediately (used to take 1-5-forever minutes).
The Following 2 Users Say Thank You to substanceneil For This Useful Post: [ View ]
23rd April 2012, 01:41 AM   |  #16  
enyahs's Avatar
OP Member
Flag Warrensburg
Thanks Meter: 20
 
76 posts
Join Date:Joined: Mar 2010
More
Grats. glad you finally got it working.

im loving it. My battery is way better.
Light use today and has been off charger for about 8 hours and still have about 60 perccent battery. (which is waYYYY better than what i had before)
23rd April 2012, 06:01 AM   |  #17  
Junior Member
Thanks Meter: 1
 
25 posts
Join Date:Joined: Aug 2010
I still can't get it to install. After step 6 in the instructional word document, it asks me to check the internet line and execute problem again. It says to ignore it on step 8 but nothing happens. Is there something im doing wrong?
23rd April 2012, 06:17 AM   |  #18  
enyahs's Avatar
OP Member
Flag Warrensburg
Thanks Meter: 20
 
76 posts
Join Date:Joined: Mar 2010
More
Did you turn on windows enabler when it told you.?

Sent from my LG-P999 using XDA
23rd April 2012, 06:22 AM   |  #19  
sambodie's Avatar
Senior Member
Thanks Meter: 17
 
178 posts
Join Date:Joined: Apr 2011
More
Modifications to Update Procedure...
Quote:
Originally Posted by substanceneil

After many, many attempts, I successfully flashed the 21y kdz this morning. Thanks to Core Memory, Overground, enyahs and many others. I am not sure what finally "did it" after many tries, but I will share some notes.

1. Keep at it. I was ready to give up many times, but somehow hung in there.

2. I used XP. I did not try some of the methods folks have suggested for using virtual machines or win7.

3. I flashed stock recovery first.

4. I was coming from Tsugi, but after numerous failures, I reflashed CWM in and restored a stock gb nandroid. I don't think this was important to my eventual success, since it still took many tries, but at least I eliminated one variable.

5. At first I used the KDZ_FW_UPD_EN program from speedsk8x, following his instructions. Specifically, I used the CDMA and DIAG settings. This failed repeatedly. The program seemed to get stuck at "CDMA: wParam = xxx, lParam = yyy" I cannot remember the xxx or yyy, but the numbers would not cycle as speedsk8x's instructions said they would. I waited up to 10 minutes multiple times. Later, I tried again using the "3GQCT" and "EMERGENCY" setting with no success.

6. I then tried the method from this post. That did not work either. Multiple attempts. The VB script seemed to work fine, but the UpTestEX_mod2_marwin.exe program would consistently crash just as the flash process was nearly completion. I tried mutiple USB ports. I did not try a different USB cable.

7. Finally, I started to experiment. I finally tried the "Start Upgrade" button instead of the "Normal web upgrade test" button. The area beneath the button logged very similar steps as the KDZ_FW_UPD_EN method, but wParam and iParam did cycle from 1 up to 100. Finally after 100 my phone rebooted. About phone showed 21y with the new baseband and 2.3.4.

8. Interestingly, UpTestEX_mod2_marwin.exe never "completed." But since the phone seemed rebooted and working fine, I unplugged the USB and closed the program. Phone is working fine. Better than fine, so far. I flashed kwes's rooted 2.3.4 ROM, deleted some bloat, and the phone is functioning great. Everything seems to work and is snappy. GPS locked immediately (used to take 1-5-forever minutes).

First, I had hosed my USB drivers somehow, sometime. So uninstalled and reinstalled the LG drivers.

The Automatic Offline Procedures vb file would not work for me, missing a file in line 25. So I just started UpTestEX_mod2_marwin.exe and tried per the Word file. Things did not go like the instructions, so I did as you suggested and selected the "Start Upgrade" button. Went through the 100 items on the left hand window as you desribed, phone rebooted after it hit 100.

Looks OK, touch selections are very snappy. Will root and add CWM, drive this week and see.
23rd April 2012, 06:52 AM   |  #20  
Junior Member
Thanks Meter: 1
 
25 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by enyahs

Did you turn on windows enabler when it told you.?

Sent from my LG-P999 using XDA

nevermind got it working, had to disable all antivirus and firewalls, brainfart.
Last edited by mgkaotic; 23rd April 2012 at 08:54 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes