Watch This Now!

Brand New Blaze: Google Voice Not Working - Help

428 posts
Thanks Meter: 9
By Legaleye3000, Senior Member on 22nd April 2012, 11:46 PM
Post Reply Subscribe to Thread Email Thread
I just got the Blaze 4G and when I try to choose "Google Voice" in voicemail settings, it just shows my T-mobile voicemail phone # and that's it. On my other Android phones, I would click on Google Voice in voicemail settings and that would be it.

Please help. Thanks!
23rd April 2012, 03:39 AM |#2  
Bradlees's Avatar
Senior Member
Flag Haverhill
Thanks Meter: 5
Pretty sure google voice does not work with tmobile. You have to port your number to gvoice in order to get the functionality you
23rd April 2012, 03:52 AM |#3  
OP Senior Member
Thanks Meter: 9
No- It works with all of my other tmobile phones... this is just happening on the new samsung blaze 4g...
23rd April 2012, 09:17 AM |#4  
dudekiller's Avatar
Senior Member
Thanks Meter: 5
Yea its just weird put in your google voice number and it will work if you don't know it sign into your voice account and it will have it next to your name or in your settings

Sent from my SGH-T769 using XDA
27th April 2012, 11:29 PM |#5  
Cirkustanz's Avatar
Senior Member
Thanks Meter: 83
Log in to google voice at, click the little tool icon on the right side, and if you hit the edit button, it will give you a string of characters very similar to this:

##004#612-555-1234## with the number being your number of course.

You punch that in the dialer and it will change your settings automatically. Much easier than setting it manually.

BTW, tmobile prepaid is really hard to get google voice to work, I'm sure it's doable, but I've read many people say it's not possible.

I just ported my service from ATT about 2 weeks ago, and it works just fine.

Last edited by Cirkustanz; 27th April 2012 at 11:37 PM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes