Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Want to go from CM7 to ICS, need some help

OP Mintyass

21st April 2012, 04:24 AM   |  #11  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Feb 2011
So I was able to use blackrose to repartition my system cache, but now I've got a problem. In the bootloader, when I select "Recovery" the phone hangs on the Nexus "X" logo, and I'm unable to get my phone to reboot into anything but the bootloader.
21st April 2012, 04:29 AM   |  #12  
rugmankc's Avatar
Senior Member
Flag Dayton, Ohio
Thanks Meter: 1,849
 
7,575 posts
Join Date:Joined: Jun 2010
More
you probably lost recovery and need to re fastboot it

i once had to fastboot erase system before the recovery would flash

all these issues are in the thread
21st April 2012, 04:35 AM   |  #13  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Feb 2011
Would this be the correct thing to do? http://forum.xda-developers.com/wiki...ecovery_Images
21st April 2012, 04:39 AM   |  #14  
rugmankc's Avatar
Senior Member
Flag Dayton, Ohio
Thanks Meter: 1,849
 
7,575 posts
Join Date:Joined: Jun 2010
More
good info but if you have sdk and know fastboot do this



Copy recovery-RA-passion-v2.2.1.img to a location where fastboot can find it. Usually tools folder.

Boot your phone into fastboot mode (power on while holding the trackball)

Connect your phone via usb to your pc

type fastboot devices (to make sure that fastboot "sees" your phone)

type fastboot flash recovery recovery-RA-passion-v2.2.1.img or whatever exact name your recovery is
The Following User Says Thank You to rugmankc For This Useful Post: [ View ]
21st April 2012, 06:12 AM   |  #15  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Feb 2011
I was able to get into recovery, but now when I select "Flash zip from sdcard", I get an error saying that there was No Signature and that the Verification Failed.
21st April 2012, 12:35 PM   |  #16  
taodan's Avatar
Senior Member
Thanks Meter: 219
 
933 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by Mintyass

I was able to get into recovery, but now when I select "Flash zip from sdcard", I get an error saying that there was No Signature and that the Verification Failed.

You need to disable the signature verification in the recovery and then flash the ROM
22nd April 2012, 06:25 PM   |  #17  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Feb 2011
Thanks so much for everyone's help! I've got ICS up and running now thanks to you.

Since this forum account is too new to post in the BCM thread, I guess I'll try asking a question here instead.

So far there's two problems I've encountered that would be dealbreakers for BCM. I saw on the BCM thread that voice search is currently broken, but it seems like it's kind of unexpected and will likely be fixed. The other issue I have, that I can't find anyone else complaining about, is that I don't seem to have the Car Home app anymore. Has anybody else run into this issue, or know a fix? I use my phone in my car pretty much every day in my car dock, and make extensive use of both the car home app and the voice search feature for getting navigation directions.

If there's a better place to post these questions, feel free to let me know!

Thanks
22nd April 2012, 07:22 PM   |  #18  
rugmankc's Avatar
Senior Member
Flag Dayton, Ohio
Thanks Meter: 1,849
 
7,575 posts
Join Date:Joined: Jun 2010
More
audio has been ab issue for me and others on ics and sense roms lately, don't know why. i am back on CM7 Kangs atm bc of it. hope it is found and fixed. the current remedies don't work for me

glad you are up and running, all these roms have issues of some type for a few at least. goes with the territory--

someone should be able to get you a car home apk you can install or push thru adb--i always delete mine as i don't use--sorry. might be able to find it thru search/google

posting here is perfectly fine--it a couple general threads for a "meaningful" post and you will be to ten real quick


enjoy rom


ken
23rd April 2012, 06:08 PM   |  #19  
Member
Flag Boston, MA
Thanks Meter: 14
 
59 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by Mintyass

This is great! I found blackrose_manual_120216.zip, but the only .nb0 file in it was hboot_blackrose.nb0. Will this work, or do I need to keep looking?

Sorry, I wasn't watching this thread over the weekend and I see you have already moved past this. But to answer the question...

I thought the pre-partitioned blackrose-220-10-206 was in that zip, but I see now that I found it on the Evervolv ROM thread in the Nexus One development forum. Sorry for not remembering to mention that.

---------- Post added at 12:08 PM ---------- Previous post was at 11:58 AM ----------

Quote:
Originally Posted by Mintyass

Thanks so much for everyone's help! I've got ICS up and running now thanks to you.

You're welcome.

Quote:

So far there's two problems I've encountered that would be dealbreakers for BCM. I saw on the BCM thread that voice search is currently broken, but it seems like it's kind of unexpected and will likely be fixed. The other issue I have, that I can't find anyone else complaining about, is that I don't seem to have the Car Home app anymore. Has anybody else run into this issue, or know a fix? I use my phone in my car pretty much every day in my car dock, and make extensive use of both the car home app and the voice search feature for getting navigation directions.

BCM Version RC3.3Ux has very broken voice input. Many folk (including me) have commented that no VoIP apps work with it. Hopefully this will be fixed soon. BCM3.2U2 works fine, so I have reverted to that version for now.

You can install the CarHome app from the Play Store; it doesn't seem to be included in the BCM zip file.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes