View Poll Results: What do you think of me as a developer?
You really suck 9 4.48%
You're not that good 5 2.49%
You're ok 26 12.94%
You're just good 46 22.89%
You're really great 115 57.21%
Voters: 201. You may not vote on this poll

Post Reply

[Rom GSM][19/06]KA14 Ice Cream Sony test version [Recontinued Rom]

24th April 2012, 11:09 PM   |  #641  
cyrusalmighty's Avatar
Senior Member
Flag Hartford
Thanks Meter: 146
 
811 posts
Join Date:Joined: May 2009
Donate to Me
More
The download link for :KA12 reboot + 30steps media volume + AOSP lockscreen add-on isnt working. But I thought I read somewhere in thread that it made no changes to the rom and wasnt working. Is this true?

---------- Post added at 06:09 PM ---------- Previous post was at 05:57 PM ----------

Quote:
Originally Posted by Kasper DG

Is this not a steady daily driver yet? Sounds like everything works, including camera and mms (which are 50/50 in other roms), but still get reboots randomly?

Don't know if it helps any, but I'm on stock 2.3.3, rooted with zergrush and locked bootloader, and I occasionally get reboots. Maybe once, possibly twice every month.


Edit:
Also. when looking at DoomLord ICS kernel, he has one for 2.0ghz and 1.6ghz. How do I know which one to use?

Bottom line: This Rom is pretty stable and might serve most as a daily driver(like myself), but it does have its lags and reboots once in a while as it is still based off the beta. As far as the lower boot or higher boot(1.6 or 2.0 ghz), it is completely up to the owner. The higher boot is more aggressive, but your phone may not be able to take being overclocked that much. I personally always stay with the lower boot(1.6), but this is only because I have never OC'ed my phone higher then 1.402 ghz.
Q: Can anyone confirm whether the 380mb to 420mb tweak works on this Rom?
EDIT**- It worked fine on this KA12 rom so I have 40 extra mbs now.
Last edited by cyrusalmighty; 24th April 2012 at 11:46 PM.
25th April 2012, 12:27 AM   |  #642  
netizenmt's Avatar
Senior Member
Thanks Meter: 359
 
1,205 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by Kasper DG

Is this not a steady daily driver yet? Sounds like everything works, including camera and mms (which are 50/50 in other roms), but still get reboots randomly?

Don't know if it helps any, but I'm on stock 2.3.3, rooted with zergrush and locked bootloader, and I occasionally get reboots. Maybe once, possibly twice every month.


Edit:
Also. when looking at DoomLord ICS kernel, he has one for 2.0ghz and 1.6ghz. How do I know which one to use?

Which kernel you choose depends on how high you plan to overclock.

But you can't use this on a locked bootloader.

Sent from my R800x using xda premium
25th April 2012, 03:39 AM   |  #643  
Member
Flag Michigan
Thanks Meter: 2
 
34 posts
Join Date:Joined: Sep 2011
netizenmt,

If I am reading your posts correctly, 3G data does NOT work yet for the R800x?
25th April 2012, 03:55 AM   |  #644  
netizenmt's Avatar
Senior Member
Thanks Meter: 359
 
1,205 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by gertman

netizenmt,

If I am reading your posts correctly, 3G data does NOT work yet for the R800x?

That would be correct. You can get it sort of working, in that the phone detects you are on a 3G network. But you can't actually use it other than to possibly browse the market or net, and that's spotty at best. Which is too bad because th ROM works pretty well otherwise.
Sent from my R800x using xda premium
26th April 2012, 01:09 AM   |  #645  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Sep 2008
face unlock couldn't start
i flashed the KA12Faceunlock zip file

any advice?
26th April 2012, 06:21 AM   |  #646  
netizenmt's Avatar
Senior Member
Thanks Meter: 359
 
1,205 posts
Join Date:Joined: Jan 2011
More
So, I am in the mood for a fight tonight... meaning I'm going to fiddle with this ROM again tonight and see how far I get with it. I really like this ROM, and it annoys the tar out of me that I had it working exactly ONCE with the data on the R800x. I know it can work, I just have to figure out what I did that made it happen..
26th April 2012, 06:40 AM   |  #647  
paxChristos's Avatar
Retired Forum Moderator
Flag Milwaukee
Thanks Meter: 1,490
 
2,036 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Quote:
Originally Posted by netizenmt

So, I am in the mood for a fight tonight... meaning I'm going to fiddle with this ROM again tonight and see how far I get with it. I really like this ROM, and it annoys the tar out of me that I had it working exactly ONCE with the data on the R800x. I know it can work, I just have to figure out what I did that made it happen..

An idea that I had but never got around to doing is decompiling framework.jar on both this/CM9 & replace all of the icsBeta cdma files with CM9 ones & recompiling & checking to see if that works... If your up to the task, here's a quick tutorial I found: http://adrynalyne-teachtofish.blogsp...e-jar.html?m=1

You'll need smali, baksmali and a good zip utility (I suggest izarc). Once you get classes.dex decompiled, you'll need to do a little but of browsing to find the telephony folder. (Hopefully, that's the magical one)

Godspeed and good luck on your endeavors :P
Pax

Sent from my phone, please excuse any Swypos.
Last edited by paxChristos; 26th April 2012 at 06:45 AM.
The Following User Says Thank You to paxChristos For This Useful Post: [ View ]
26th April 2012, 08:05 AM   |  #648  
Senior Member
Thanks Meter: 391
 
582 posts
Join Date:Joined: May 2011
Quote:
Originally Posted by netizenmt

So, I am in the mood for a fight tonight...


Quote:
Originally Posted by paxChristos

An idea that I had but never got around to doing is decompiling framework.jar on both this/CM9 & replace all of the icsBeta cdma files with CM9 ones & recompiling & checking to see if that works... If your up to the task, here's a quick tutorial I found: http://adrynalyne-teachtofish.blogsp...e-jar.html?m=1

You'll need smali, baksmali and a good zip utility (I suggest izarc). Once you get classes.dex decompiled, you'll need to do a little but of browsing to find the telephony folder. (Hopefully, that's the magical one)

Godspeed and good luck on your endeavors :P
Pax

Sent from my phone, please excuse any Swypos.

I can help you guys out with this if you like. I've got some stuff to finish up for an update for ICS++, but I've noticed loads of cdma toggles/specific files, so was planning to take a look into it at some point anyways.

I've had my head knee-deep in dex code over the last few weeks and am willing to lend a hand.

Sent from my R800i using XDA
The Following User Says Thank You to Atarii For This Useful Post: [ View ]
26th April 2012, 08:16 AM   |  #649  
netizenmt's Avatar
Senior Member
Thanks Meter: 359
 
1,205 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by Atarii

I can help you guys out with this if you like. I've got some stuff to finish up for an update for ICS++, but I've noticed loads of cdma toggles/specific files, so was planning to take a look into it at some point anyways.

I've had my head knee-deep in dex code over the last few weeks and am willing to lend a hand.

Sent from my R800i using XDA

Well, I can guarantee you would be more likely to have success than I will, as I have never done anything like this. I'm game though!

And Thanks also to Pax !

EDIT: So far so good - I have calls working properly, with one error message the first call each time I reboot. I'm trying to figure out the instructions with that whole dex code jar thingy Pax posted up. Don't look for any amazing developments from me; I'm clueless here.

EDIT #2: Well, I replaced the CDMA sections with those from CM9 as Pax suggested. (That's the limit of my abilities.) Recompiled classes.dex, stuck it back in the KA12 zip file, and tried installing it. However, it just bootlooped on the kernel splash screen.

Reinstalled the original KA12 first and got that to boot up, then reinstalled my file. This time it booted OK. However, CDMA still has no service. In fact, it's a bit worse because even using the patches from Krabappel2548, I can't get the CDMA signal enabled at all now.
Last edited by netizenmt; 26th April 2012 at 11:17 AM.
26th April 2012, 03:06 PM   |  #650  
paxChristos's Avatar
Retired Forum Moderator
Flag Milwaukee
Thanks Meter: 1,490
 
2,036 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Quote:
Originally Posted by netizenmt

EDIT #2: Well, I replaced the CDMA sections with those from CM9 as Pax suggested. (That's the limit of my abilities.) Recompiled classes.dex, stuck it back in the KA12 zip file, and tried installing it. However, it just bootlooped on the kernel splash screen.

Shucks, it's too bad we don't have AdamOutler's genius on this forum. (If you don't watch xda-tv, he "unboxes" (tears apart a phone & explains some of the stuff about the boards used, including how testpoints work with kernel debugging, because if it bootloops on the kernel splash screen, logcat won't work ))
Quote:

Reinstalled the original KA12 first and got that to boot up, then reinstalled my file. This time it booted OK. However, CDMA still has no service. In fact, it's a bit worse because even using the patches from Krabappel2548, I can't get the CDMA signal enabled at all now.

There's something fishy about this beta... I don't know why it's so hit-or-miss, there's something really weird with it then...

Pax

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Play Android Development by ThreadRank