Post Reply

[DEV] Unofficial Cyanogenmod 7 for Lenovo Ideapad A1

25th April 2012, 05:27 PM   |  #711  
Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: May 2010
Hi, thanks for the development for the lenovo A1. I had been using it for months. However, there is 1 small problem. When i plug the A1 to the windows 7 pc, it did not show the USB mounting and the windows 7 also did not show the mounting of the A1. Not sure is it the hardware problem or is it the software problem.
25th April 2012, 07:19 PM   |  #712  
MadPriest's Avatar
Senior Member
Flag Toronto
Thanks Meter: 47
 
318 posts
Join Date:Joined: Mar 2007
More
Quote:
Originally Posted by wanderer87sg

Hi, thanks for the development for the lenovo A1. I had been using it for months. However, there is 1 small problem. When i plug the A1 to the windows 7 pc, it did not show the USB mounting and the windows 7 also did not show the mounting of the A1. Not sure is it the hardware problem or is it the software problem.

what build are you using?
try switching to a different cable and check with other USB ports
25th April 2012, 08:08 PM   |  #713  
monsieurtalbot's Avatar
Senior Member
Flag West Palm Beach
Thanks Meter: 156
 
271 posts
Join Date:Joined: Aug 2010
Donate to Me
Quote:
Originally Posted by wanderer87sg

Hi, thanks for the development for the lenovo A1. I had been using it for months. However, there is 1 small problem. When i plug the A1 to the windows 7 pc, it did not show the USB mounting and the windows 7 also did not show the mounting of the A1. Not sure is it the hardware problem or is it the software problem.

I noticed this issue when I wasn't using an SD card...

Try going to:

Settings>Cyanogenmod settings>Application settings

-and tick the "use internal storage" box. Then reboot.

Then try again. Should fix the problem **IF you don't have an external SD**. :)
26th April 2012, 12:01 AM   |  #714  
monsieurtalbot's Avatar
Senior Member
Flag West Palm Beach
Thanks Meter: 156
 
271 posts
Join Date:Joined: Aug 2010
Donate to Me
So I went ahead and compiled JUST the uimage into a little 1.2ghz kernel (apparently there's a new version that fixes reboot. Looking now)... (STILL won't reboot unless I do it via CWM)... Then everything is fine. Not a big deal, just a little pain in the ass. Especially if you get a random restart... Then it can get dicey.

Here's the download... 1.2Ghz Overclock Kernel (flash with CWM) - (REMOVED DUE TO BOOT ISSUES see this post for download link of fixed kernel http://forum.xda-developers.com/show...&postcount=150)

-and here's a CWM flashable .Zip of the stock kernel so you can go back if need be... http://www.mediafire.com/?o6c67k927i23y2v

^I can confirm flashing the stock DOES fix the (re)boot issue caused by the overclock kernel. Hopefully this .Zip saves some people from un needed wipes if you have to go back.

I was hoping someone with a little more know how than myself could take a look and see if it's something dumb keeping it from cold starting and rebooting. Would greatly appreciate any insight... Thanks!


Can someone please upload the uImage with the boot fixed please? I'll compile it into a CWM flashable .Zip... Thanks!
Last edited by monsieurtalbot; 26th April 2012 at 06:40 AM.
26th April 2012, 01:36 AM   |  #715  
Senior Member
Thanks Meter: 6
 
160 posts
Join Date:Joined: May 2009
Quote:
Originally Posted by gmarkall

Yes. I don't think this problem exists anymore anyway - are you having crashes? If so, what nightly build are you using?

It doesn't happen at all with mine
The Following User Says Thank You to Neuralgia For This Useful Post: [ View ]
26th April 2012, 08:15 AM   |  #716  
Junior Member
Flag Huenxe
Thanks Meter: 2
 
7 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by wanderer87sg

Hi, thanks for the development for the lenovo A1. I had been using it for months. However, there is 1 small problem. When i plug the A1 to the windows 7 pc, it did not show the USB mounting and the windows 7 also did not show the mounting of the A1. Not sure is it the hardware problem or is it the software problem.

Did you see anything in the status bar of the A1 after you connect the A1 with Win7?
26th April 2012, 01:29 PM   |  #717  
Member
Thanks Meter: 5
 
34 posts
Join Date:Joined: Sep 2010
Does dock mode (audio out of USB) function with this rom?
26th April 2012, 01:30 PM   |  #718  
milaq's Avatar
Recognized Developer
Flag NRW
Thanks Meter: 2,379
 
616 posts
Join Date:Joined: Feb 2009
Donate to Me
More
Exclamation custom kernel now included
from now on, our custom kernel will be included in the nightlies.
that means a new kernel will be fused upon flashing cm7.

please consider updating your u-boot to the new fastboot included version by gmarkall (instructions in first post).
in case anything goes wrong you can easily recover everything via fastboot without having to build an sdboot package.

any change making it into the kernel repo does NOT necessarily mean that we already included it in the nightlies. we are pushing prebuilt kernels to the device repos. i.e. keep an eye out for commits to the device repo like "update prebuilt kernel".

have fun and pls report back.

cheers
Last edited by milaq; 26th April 2012 at 03:19 PM.
The Following 5 Users Say Thank You to milaq For This Useful Post: [ View ]
26th April 2012, 03:23 PM   |  #719  
Senior Member
Flag Detroit
Thanks Meter: 7
 
119 posts
Join Date:Joined: Nov 2010
More
Does this kernel fix the upside down camera?
26th April 2012, 03:31 PM   |  #720  
Junior Member
Thanks Meter: 13
 
29 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by rhay

Does this kernel fix the upside down camera?

Havent found anything about it in commit log, so NO.

The Following 2 Users Say Thank You to drozda For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
lenovo ideapad a1 unofficial cyanogenmod
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Miscellaneous Android Development by ThreadRank