Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[NAND][CM9][ICS]testbuild for X1

OP Brickpsp

25th April 2012, 07:14 AM   |  #11  
OP Member
Thanks Meter: 21
 
76 posts
Join Date:Joined: Aug 2010
i will post testbuild1 after check a few functions to certain work

P/S : updated #1
Last edited by Brickpsp; 25th April 2012 at 03:50 PM.
The Following 2 Users Say Thank You to Brickpsp For This Useful Post: [ View ]
25th April 2012, 11:03 PM   |  #12  
Senior Member
Thanks Meter: 407
 
656 posts
Join Date:Joined: Dec 2011
Donate to Me
hhmm with the kernel in zip i never got past your boot screen 'x1 forever' either i get stuck in there or in white lines during different driver inits or it reboots somewhere there

i tried a kernel i built from a combination of zargloub's and hackun's repo with this i got to the pin request but screen was corrupted and flashing between terminal lines and boot animation / ics pin request...

so far my experiences

EDIT: oh forgot here are keymaps: http://forum.xda-developers.com/show...2&postcount=52
Last edited by Elibl; 25th April 2012 at 11:20 PM.
26th April 2012, 03:56 AM   |  #13  
OP Member
Thanks Meter: 21
 
76 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by Elibl

hhmm with the kernel in zip i never got past your boot screen 'x1 forever' either i get stuck in there or in white lines during different driver inits or it reboots somewhere there

i tried a kernel i built from a combination of zargloub's and hackun's repo with this i got to the pin request but screen was corrupted and flashing between terminal lines and boot animation / ics pin request...

so far my experiences

EDIT: oh forgot here are keymaps: http://forum.xda-developers.com/show...2&postcount=52

It will load very slow in first time, if you want know what's android loading, use command "adb logcat"

P/S: i tried your keymaps, it not working ,maybe ics mapping difference gb or system not load
Last edited by Brickpsp; 26th April 2012 at 08:12 AM.
26th April 2012, 12:26 PM   |  #14  
Senior Member
Thanks Meter: 407
 
656 posts
Join Date:Joined: Dec 2011
Donate to Me
Quote:
Originally Posted by Brickpsp

It will load very slow in first time, if you want know what's android loading, use command "adb logcat"

P/S: i tried your keymaps, it not working ,maybe ics mapping difference gb or system not load

you are right .kcm.bin is now .kcm and in java code i will make the maps for you but give me some time it's a hell of work

one time i got a connection via adb and it rebooted after:
Code:
D/dalvikvm(   70): DexOpt: --- BEGIN 'android.policy.jar' (bootstrap=1) ---
afterwards i never got a connection via adb no matter if stuck before boot screen or in it also after fresh installation

and for you it boots every time fine into the rom?
26th April 2012, 12:53 PM   |  #15  
OP Member
Thanks Meter: 21
 
76 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by Elibl

you are right .kcm.bin is now .kcm and in java code i will make the maps for you but give me some time it's a hell of work

one time i got a connection via adb and it rebooted after:

Code:
D/dalvikvm(   70): DexOpt: --- BEGIN 'android.policy.jar' (bootstrap=1) ---
afterwards i never got a connection via adb no matter if stuck before boot screen or in it also after fresh installation

and for you it boots every time fine into the rom?

yes ,boot with no fail

When boot screen load ,you must wait a little ,after that type "adb logcat"

you can check partition system by commands "adb shell" after that "df -h system" ,it equal 200mb?

P/S :can you upload your logcat ?
Last edited by Brickpsp; 26th April 2012 at 12:59 PM.
26th April 2012, 01:02 PM   |  #16  
Senior Member
Thanks Meter: 407
 
656 posts
Join Date:Joined: Dec 2011
Donate to Me
Quote:
Originally Posted by Brickpsp

yes ,boot with no fail

When boot screen load ,you must wait a little ,after that type "adb logcat"

you can check partition system by commands "adb shell" after that "df -h system" ,it equal 200mb?

P/S :can you upload your logcat ?

can i check it in fastboot or recovery somehow? cause i get no adb connection...
but your lk must be presented cause i had cyan text before and now green

EDIT:
Code:
--------- beginning of /dev/log/main
E/logwrapper(   64): executing /system/xbin/run-parts failed: No such file or di
rectory
I/logwrapper(   63): /system/xbin/run-parts terminated by exit(255)
I/DEBUG   (   68): debuggerd: Feb 12 2012 22:51:15
--------- beginning of /dev/log/system
I/Vold    (   66): Vold 2.1 (the revenge) firing up
I/Netd    (   67): Netd 1.0 starting
D/Vold    (   66): Volume sdcard state changing -1 (Initializing) -> 0 (No-Media
)
E/Netd    (   67): Unable to create netlink socket: Protocol not supported
E/Netd    (   67): Unable to open quota2 logging socket
D/Vold    (   66): Volume sdcard state changing 0 (No-Media) -> 1 (Idle-Unmounte
d)
D/AndroidRuntime(   70):
D/AndroidRuntime(   70): >>>>>> AndroidRuntime START com.android.internal.os.Zyg
oteInit <<<<<<
D/AndroidRuntime(   70): CheckJNI is ON
I/        (   71): ServiceManager: 0xf958
I/AudioFlinger(   71): Loaded primary audio interface from Default audio HW HAL
(audio)
I/AudioFlinger(   71): Using 'Default audio HW HAL' (audio.primary) as the prima
ry audio interface
I/AudioFlinger(   71): Loaded a2dp audio interface from A2DP Audio HW HAL (audio
)
I/CameraService(   71): CameraService started (pid=71)
E/HAL     (   71): load: module=/system/lib/hw/camera.msm7k.so
E/HAL     (   71): Cannot load library: link_image[1936]:    71 could not load n
eeded library 'libcamera.so' for 'camera.msm7k.so' (load_library[1091]: Library
'libcamera.so' not found)
E/CameraService(   71): Could not load camera HAL module
I/AudioFlinger(   71): AudioFlinger's thread 0x10448 ready to run
W/AudioFlinger(   71): Thread AudioOut_1 cannot connect to the power manager ser
vice
W/AudioFlinger(   71): Thread AudioOut_1 cannot connect to the power manager ser
vice
I/AudioPolicyService(   71): Loaded audio policy from LEGACY Audio Policy HAL (a
udio_policy)
D/dalvikvm(   70): DexOpt: --- BEGIN 'core.jar' (bootstrap=1) ---
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/Object;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/Class;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/ref/Reference
;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/ref/Reference
Queue;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/ref/Finalizer
Reference;
D/dalvikvm(   98): DexOpt: load 480ms, verify+opt 6418ms
D/dalvikvm(   70): DexOpt: --- END 'core.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/core.jar': unzip in 1963ms, rewri
te 8280ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'bouncycastle.jar' (bootstrap=1) ---
D/dalvikvm(  114): DexOpt: load 146ms, verify+opt 2201ms
D/dalvikvm(   70): DexOpt: --- END 'bouncycastle.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/bouncycastle.jar': unzip in 475ms
, rewrite 2853ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'ext.jar' (bootstrap=1) ---
D/dalvikvm(  115): DexOpt: load 244ms, verify+opt 3580ms
D/dalvikvm(   70): DexOpt: --- END 'ext.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/ext.jar': unzip in 771ms, rewrite
 4489ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'framework.jar' (bootstrap=1) ---
D/dalvikvm(  116): Note: class Landroid/opengl/GLWrapperBase; has 250 unimplemen
ted (abstract) methods
D/dalvikvm(  116): DexOpt: load 2427ms, verify+opt 23013ms
D/dalvikvm(   70): DexOpt: --- END 'framework.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/framework.jar': unzip in 5994ms,
rewrite 29450ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'android.policy.jar' (bootstrap=1) ---
after that reboot

and the strange is with my boot.img it boots up even in normal speed

here are the changes i merged with zargloubs kernel: https://gitorious.org/~hackun/linux-...n-linux-xperia
Last edited by Elibl; 26th April 2012 at 01:08 PM.
26th April 2012, 01:30 PM   |  #17  
OP Member
Thanks Meter: 21
 
76 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by Elibl

can i check it in fastboot or recovery somehow? cause i get no adb connection...
but your lk must be presented cause i had cyan text before and now green

EDIT:

Code:
--------- beginning of /dev/log/main
E/logwrapper(   64): executing /system/xbin/run-parts failed: No such file or di
rectory
I/logwrapper(   63): /system/xbin/run-parts terminated by exit(255)
I/DEBUG   (   68): debuggerd: Feb 12 2012 22:51:15
--------- beginning of /dev/log/system
I/Vold    (   66): Vold 2.1 (the revenge) firing up
I/Netd    (   67): Netd 1.0 starting
D/Vold    (   66): Volume sdcard state changing -1 (Initializing) -> 0 (No-Media
)
E/Netd    (   67): Unable to create netlink socket: Protocol not supported
E/Netd    (   67): Unable to open quota2 logging socket
D/Vold    (   66): Volume sdcard state changing 0 (No-Media) -> 1 (Idle-Unmounte
d)
D/AndroidRuntime(   70):
D/AndroidRuntime(   70): >>>>>> AndroidRuntime START com.android.internal.os.Zyg
oteInit <<<<<<
D/AndroidRuntime(   70): CheckJNI is ON
I/        (   71): ServiceManager: 0xf958
I/AudioFlinger(   71): Loaded primary audio interface from Default audio HW HAL
(audio)
I/AudioFlinger(   71): Using 'Default audio HW HAL' (audio.primary) as the prima
ry audio interface
I/AudioFlinger(   71): Loaded a2dp audio interface from A2DP Audio HW HAL (audio
)
I/CameraService(   71): CameraService started (pid=71)
E/HAL     (   71): load: module=/system/lib/hw/camera.msm7k.so
E/HAL     (   71): Cannot load library: link_image[1936]:    71 could not load n
eeded library 'libcamera.so' for 'camera.msm7k.so' (load_library[1091]: Library
'libcamera.so' not found)
E/CameraService(   71): Could not load camera HAL module
I/AudioFlinger(   71): AudioFlinger's thread 0x10448 ready to run
W/AudioFlinger(   71): Thread AudioOut_1 cannot connect to the power manager ser
vice
W/AudioFlinger(   71): Thread AudioOut_1 cannot connect to the power manager ser
vice
I/AudioPolicyService(   71): Loaded audio policy from LEGACY Audio Policy HAL (a
udio_policy)
D/dalvikvm(   70): DexOpt: --- BEGIN 'core.jar' (bootstrap=1) ---
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/Object;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/Class;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/ref/Reference
;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/ref/Reference
Queue;
D/dalvikvm(   98): Ignoring duplicate verify attempt on Ljava/lang/ref/Finalizer
Reference;
D/dalvikvm(   98): DexOpt: load 480ms, verify+opt 6418ms
D/dalvikvm(   70): DexOpt: --- END 'core.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/core.jar': unzip in 1963ms, rewri
te 8280ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'bouncycastle.jar' (bootstrap=1) ---
D/dalvikvm(  114): DexOpt: load 146ms, verify+opt 2201ms
D/dalvikvm(   70): DexOpt: --- END 'bouncycastle.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/bouncycastle.jar': unzip in 475ms
, rewrite 2853ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'ext.jar' (bootstrap=1) ---
D/dalvikvm(  115): DexOpt: load 244ms, verify+opt 3580ms
D/dalvikvm(   70): DexOpt: --- END 'ext.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/ext.jar': unzip in 771ms, rewrite
 4489ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'framework.jar' (bootstrap=1) ---
D/dalvikvm(  116): Note: class Landroid/opengl/GLWrapperBase; has 250 unimplemen
ted (abstract) methods
D/dalvikvm(  116): DexOpt: load 2427ms, verify+opt 23013ms
D/dalvikvm(   70): DexOpt: --- END 'framework.jar' (success) ---
D/dalvikvm(   70): DEX prep '/system/framework/framework.jar': unzip in 5994ms,
rewrite 29450ms
D/dalvikvm(   70): DexOpt: --- BEGIN 'android.policy.jar' (bootstrap=1) ---
after that reboot

and the strange is with my boot.img it boots up even in normal speed

here are the changes i merged with zargloubs kernel: https://gitorious.org/~hackun/linux-...n-linux-xperia

yes ,my friend compile lk in https://www.gitorious.org/lk-msm7200...200a-htc-wince ,maybe it old version

D/dalvikvm( 70): DexOpt: --- BEGIN 'android.policy.jar' (bootstrap=1) ---

This is just start unzip framework, if error happen, system will show error and loop , i don't know why your device is reboot

your boot.img reboot,too ?
Last edited by Brickpsp; 26th April 2012 at 01:34 PM.
26th April 2012, 01:38 PM   |  #18  
Senior Member
Thanks Meter: 407
 
656 posts
Join Date:Joined: Dec 2011
Donate to Me
Quote:
Originally Posted by Brickpsp

yes ,my friend compile lk in https://www.gitorious.org/lk-msm7200...200a-htc-wince ,maybe it old version

D/dalvikvm( 70): DexOpt: --- BEGIN 'android.policy.jar' (bootstrap=1) ---

This is just start unzip framework, if error happen, system will show error and loop , i don't know why your device is reboot

your boot.img reboot,too ?

no
26th April 2012, 01:40 PM   |  #19  
OP Member
Thanks Meter: 21
 
76 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by Elibl

no

so you booted into android?
26th April 2012, 01:50 PM   |  #20  
Senior Member
Thanks Meter: 407
 
656 posts
Join Date:Joined: Dec 2011
Donate to Me
Quote:
Originally Posted by Elibl

i tried a kernel i built from a combination of zargloub's and hackun's repo with this i got to the pin request but screen was corrupted and flashing between terminal lines and boot animation / ics pin request...

but the screen is nearly unreadable... touch worked also i looked a bit around in ics and after some time reboot to boot animation (no full reboot)

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes