Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[HOWTO] Enable the car dock external audio without Samsung's Home apps

OP TheBeano

29th February 2012, 02:00 PM   |  #181  
elhennig's Avatar
Senior Member
Thanks Meter: 99
 
494 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by greasyguy

But when I try to connect to AUX in of my car radio the sound still comes out of the internal phone speaker. What am I doing wrong?

Did you install the app from this thread? What does it show when you start it?
1st March 2012, 07:04 AM   |  #182  
Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Feb 2009
Quote:
Originally Posted by elhennig

Now I am back to Semaphore. In 0.9.0 the car dock works well. The sound quality is still not too good, but hopefully this can be fixed, too.

Hi,

How did you actually manage to get this working on ICSSGS 4.2?

I've tried Glitch, Semaphore and Devil (which are all supposed to support dock audio since latest releases) in every possible combination with either TheBeano's DockSpeaker_1.1 and XCaliburinhand's Dock Sound Redirector (from the Market).

XCaliburinhand's app displays a warning that no supported ROM or kernel was found. It works for CM9 and AFAIR it used to work for Onecosmic's before the ROM got odexed (that was RC3, right?).

The dock sound support is the only thing that pulled me away from ICSSGS and keeps me with CM9.

What am I missing that makes it work for you? Please help...
1st March 2012, 09:11 AM   |  #183  
elhennig's Avatar
Senior Member
Thanks Meter: 99
 
494 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by marek.cichecki

How did you actually manage to get this working on ICSSGS 4.2?
[...]
XCaliburinhand's Dock Sound Redirector (from the Market).

XCaliburinhand's app displays a warning that no supported ROM or kernel was found. It works for CM9 and AFAIR it used to work for Onecosmic's before the ROM got odexed (that was RC3, right?).

It worked out of the box with Icy Glitch Beta5 and Semaphore 0.9.x with XCaliburinhand's app, version 1.8
The Following User Says Thank You to elhennig For This Useful Post: [ View ]
1st March 2012, 04:52 PM   |  #184  
TaC's Avatar
Senior Member
Flag Córdoba
Thanks Meter: 1
 
179 posts
Join Date:Joined: Aug 2007
More
ICSSGS4.2 or CM9?
1st March 2012, 07:04 PM   |  #185  
greasyguy's Avatar
Senior Member
Thanks Meter: 37
 
155 posts
Join Date:Joined: Jan 2011
More
I now tried it with teamics 4.2 and devil's 1.1.5. When snapping the phone into the dock I can hear a crack out off my speakers. When I open sound redirect app from this thread I tick "car dock" but nothing happens. Can't get it working. Maybe I try with semaphore again. Could it be a wrong cable as well?

Gesendet von meinem GT-I9000 mit Tapatalk
1st March 2012, 11:00 PM   |  #186  
Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Feb 2009
Quote:
Originally Posted by elhennig

It worked out of the box with Icy Glitch Beta5 and Semaphore 0.9.x with XCaliburinhand's app, version 1.8

Thanks a lot for such a quick response. I tried redownloading, wiping, flashing, reflashing etc. a few times but to no avail.

I'm wondering if this could be a matter of you flashing 4.2 over some previous ROM with dock sound capability (or rather Xcaliburinhand-friendly vs. me coming from stock Samsung ROM via CM7, doing all the recommended wipes.

Anyway, I decided not to investigate that matter any further and just stick to CM9. Still, thank you very much for sharing your experience.
2nd March 2012, 08:05 AM   |  #187  
elhennig's Avatar
Senior Member
Thanks Meter: 99
 
494 posts
Join Date:Joined: Feb 2011
More
I came from XXJVU with car dock not working. It only works since I use Icy Glitch and later Semaphore 0.9.x

Sent from another galaxy
19th March 2012, 05:34 PM   |  #188  
Junior Member
Thanks Meter: 3
 
3 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by marek.cichecki

The dock sound support is the only thing that pulled me away from ICSSGS and keeps me with CM9.

What am I missing that makes it work for you? Please help...

Hi,

Here is the workaround for those who are unable to redirect sound using ICSSGS RC4.2 and XCaliburinhand's Galaxy Dock Sound Redirector:

Edit your /system/build.prop file and replace the following line
ro.product.manufacturer=unknown
with
ro.product.manufacturer=Samsung

Reboot, finished.

Confirmed working on Icy Glitch V14b5 kernel, should also work on other (redirection capable) kernels (e.g. Semaphore 0.9.x). Latest Icy Glitch kernel has now full voice call redirection also working!

Be extra careful when editing build.prop (create a backup of file etc.)!

Details: I checked the source code of Dock Sound Redirector on github and found that it checks if: 1. the manufacturer string is 'samsung' 2. /sys/devices/virtual/misc/dockredir/dockredir_support file exists and contains '1' in the first line. If any of these fails, will throw the error message.

In this thread, you'll find a CWM-flashable (latest) version of Google Car Home -- could be also interesting.

Have a nice day,

pn
The Following 2 Users Say Thank You to PerpetuumNobile For This Useful Post: [ View ]
26th April 2012, 10:39 PM   |  #189  
TaC's Avatar
Senior Member
Flag Córdoba
Thanks Meter: 1
 
179 posts
Join Date:Joined: Aug 2007
More
It works perfect with ICSSGS and Semaphore 1.0.0.

Thanks PerpetuumNobile.
27th April 2012, 06:44 AM   |  #190  
greasyguy's Avatar
Senior Member
Thanks Meter: 37
 
155 posts
Join Date:Joined: Jan 2011
More
@Tac: how did you get it running?

Gesendet von meinem GT-I9000 mit Tapatalk 2

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes