Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,968 Members 42,603 Now Online
XDA Developers Android and Mobile Development Forum

Problem with edited APK's - xpost from General

Tip us?
 
Mark98
Old
#1  
Junior Member - OP
Thanks Meter 18
Posts: 29
Join Date: Mar 2012
Default Problem with edited APK's - xpost from General

Hi all,

First of all, apologies for the xpost...

Question re: weird behaviour on APK files I've edited according to http://forum.xda-developers.com/show...07&postcount=2

I use a couple of apps regularly and have tried modifying them to make the UI suit me a bit better. For what it's worth, one's a Twitter app and one's a keyboard.

I've used apktool to decompile them, edited certain res .xml files to change the interface and then compiled them again with apktool. I've then signed them using Sigare (obviously it's not signed using the original developers key, but a key that I've made)

I've then replaced the apk in data\app with my modified one.

The problem is that, while the new app works for a little white, after a while it just disappears from my app list. When I go to run it directly, I get a message that the app won't load.

TL;DR: apps I've modified work to start with and then don't. Anyone think of a reason?
 
Mark98
Old
#3  
Junior Member - OP
Thanks Meter 18
Posts: 29
Join Date: Mar 2012
Quote:
Originally Posted by spirosbond View Post
I did thanks. Giving it a go now
 
Mark98
Old
#4  
Junior Member - OP
Thanks Meter 18
Posts: 29
Join Date: Mar 2012
Default Arrow Problem with edited APK's (updated

I've tried a couple of things and got these edited APK's to install and work

...initially.

Fire it up the next morning and find that the app crashes

Ideas?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes