Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,479 Members 48,317 Now Online
XDA Developers Android and Mobile Development Forum

Battery Dead

Tip us?
 
Quinny899
Old
#1  
Quinny899's Avatar
Recognized Contributor - OP
Thanks Meter 3827
Posts: 6,218
Join Date: Jan 2011
Location: Bolton le Sands, Near Lancaster, UK

 
DONATE TO ME
Default Battery Dead

So my 80 G9 got the dreaded battery dead issue (bug in the android UI made it think it was charging when it wasn't, so it drained and died)
Now I'm stuck. I've got it plugged in and it's doing the pulse 4 times then long blank then pulse 4 times... On the LED, and I'm trying to get it to charge. Any ideas?

Sent from my HTC Desire HD using XDA

 
Devices:
Nexus 5
Galaxy Nexus
Nexus 7 FHD
Archos 80 G9
LG GT540
 
- Swift -
Old
#2  
- Swift -'s Avatar
Recognized Contributor
Thanks Meter 800
Posts: 2,858
Join Date: Sep 2011
Location: Galway, Ireland

 
DONATE TO ME
Quote:
Originally Posted by Quinny899 View Post
So my 80 G9 got the dreaded battery dead issue (bug in the android UI made it think it was charging when it wasn't.
That happened to me before.
I left my G9 flat for a good bit and left it charging for a day.
It booted.
Sent from my R800i using xda premium
GOOGLE Nexus 4
GOOGLE Nexus 7 (2013)

---
Devices:
 
The Following User Says Thank You to - Swift - For This Useful Post: [ Click to Expand ]
 
Quinny899
Old
#3  
Quinny899's Avatar
Recognized Contributor - OP
Thanks Meter 3827
Posts: 6,218
Join Date: Jan 2011
Location: Bolton le Sands, Near Lancaster, UK

 
DONATE TO ME
Got it back

Sent from my ARCHOS 80G9 using XDA Premium HD app

 
Devices:
Nexus 5
Galaxy Nexus
Nexus 7 FHD
Archos 80 G9
LG GT540
The Following User Says Thank You to Quinny899 For This Useful Post: [ Click to Expand ]
 
DeeDroid
Old
(Last edited by DeeDroid; 28th April 2012 at 06:44 PM.)
#4  
Member
Thanks Meter 12
Posts: 67
Join Date: Jan 2009
Location: Karlsruhe
My G9 seems to be tatally dead since this morning.
It happened once before that it didn't start up, only flashing LEDs but than it suddenly worked again after some hours being connected to the charger.

But now it's different. I was using my tablet, i think the battery was not empty but the device got unresponsive and I hold power 10 seconds to switch it off and on to reset the device. But it didn't turn on again. Not even flashing LEDs, nothing, just dead, and still dead after some hours charging. I regret having bought a G9, this device is nothing but trouble.

EDIT: OMG, power LED just turned green after having had the charger disconnected half an hour and than reattached it.
Looks promising, will leave it charging an hour before I try to switch it on.

EDIT2: grrr, green LED just means the still dead brick is fully charged
The Following 2 Users Say Thank You to DeeDroid For This Useful Post: [ Click to Expand ]
 
jmd1213
Old
#5  
jmd1213's Avatar
Junior Member
Thanks Meter 1
Posts: 17
Join Date: Jan 2012
Default Same here.

Tried everything. Could not get it to charge. I returned it and got a new one.
The Following User Says Thank You to jmd1213 For This Useful Post: [ Click to Expand ]
 
- Swift -
Old
#6  
- Swift -'s Avatar
Recognized Contributor
Thanks Meter 800
Posts: 2,858
Join Date: Sep 2011
Location: Galway, Ireland

 
DONATE TO ME
Quote:
Originally Posted by Quinny899 View Post
Got it back

Sent from my ARCHOS 80G9 using XDA Premium HD app
Looks like it worked for you too

Sent from my R800i using xda premium
GOOGLE Nexus 4
GOOGLE Nexus 7 (2013)

---
Devices:
 
The Following User Says Thank You to - Swift - For This Useful Post: [ Click to Expand ]
 
Shano56
Old
#7  
Shano56's Avatar
Senior Member
Thanks Meter 548
Posts: 1,382
Join Date: Oct 2011
Location: Seattle
I've suffered from 2 battery issues.
1) i drained the battery so much it would not turn on even after plugging it in
solution: plug it in for a few minutes/hours/days untill it wants to turn on

2) device would not receive a charge (who knows if this was my fault or archos fault)
solution: hope you have not had your device more than 1 year so you are still under warranty and ship to archos for them to fix

right now i'm waiting for archos to ship me a new device
LG Nexus 5
The Following User Says Thank You to Shano56 For This Useful Post: [ Click to Expand ]
 
- Swift -
Old
#8  
- Swift -'s Avatar
Recognized Contributor
Thanks Meter 800
Posts: 2,858
Join Date: Sep 2011
Location: Galway, Ireland

 
DONATE TO ME
Quote:
Originally Posted by Shano56 View Post
I've suffered from 2 battery issues.
1) i drained the battery so much it would not turn on even after plugging it in
solution: plug it in for a few minutes/hours/days untill it wants to turn on

2) device would not receive a charge (who knows if this was my fault or archos fault)
solution: hope you have not had your device more than 1 year so you are still under warranty and ship to archos for them to fix

right now i'm waiting for archos to ship me a new device
Both happened to me.
DIY FTW

Sent from my R800i using xda premium
GOOGLE Nexus 4
GOOGLE Nexus 7 (2013)

---
Devices:
 
The Following User Says Thank You to - Swift - For This Useful Post: [ Click to Expand ]
 
Shano56
Old
#9  
Shano56's Avatar
Senior Member
Thanks Meter 548
Posts: 1,382
Join Date: Oct 2011
Location: Seattle
Quote:
Originally Posted by IrishStuff09 View Post
Both happened to me.
DIY FTW

Sent from my R800i using xda premium
if i was not under warranty i would be with u on that one. i've heard of ppl getting free upgrades after they ship for repair...might as well take the gamble xD
LG Nexus 5
The Following User Says Thank You to Shano56 For This Useful Post: [ Click to Expand ]
 
mn555
Old
#10  
Junior Member
Thanks Meter 6
Posts: 28
Join Date: May 2011
Location: jerusalem
my device is not charging at all and usb is not working and battery level is 28% any
suggestions?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes