FORUMS

[FTF] Sony Xperia Z Lollipop Release

Sony rolled out a Lollipop update for Xperia Z just yesterday. If you still haven’t gotten … more

Original Moto G Receives Lollipop, OTA Captured

The original Moto G was released almost two years ago. Motorola still continues to … more

Device Review: No.1 X1 Rugged Smartphone

We are almost at the end of Q2 for 2015, and we have seen most of the flagship phones for the … more

When a Friend or Family Member Asks for a Phone Recommendation, What Do You Tell Them?

The majority of us here at XDA would consider … more
Post Reply Subscribe to Thread Email Thread

GB ROM that supports Bluetooth Keyboards/Mouse

28th April 2012, 08:11 AM |#1  
knowthenazz's Avatar
OP Senior Member
Flag Vancouver, Canada (Samsung Galaxy S2/Samsung Galaxy Nexus/Google Nexus 7)
Thanks Meter: 3
 
More
Hi,

I'm trying to find a P1000 Gingerbread ROM that will support Bluetooth keyboards and mice.

I'm currently running Overcome 4.10, and RedPill 2.00 kernel. With this combination and with the original Overcome kernel, I was able to pair with my Bluetooth keyboard, but, not connect to it.

From this post:

http://forum.xda-developers.com/show....php?t=1502638


It seems like a 2.3.5 and a 2.3.6 kernel wont work properly with Bluetooth connections..

So is there still a stable, fast 2.3.4 ROM that supports Bluetooth keyboards and mice available? I don't even mind going back to stock, but, I can't seem to find one.

I'm on the Canadian Bell P1000.

Thanks!
 
 
28th April 2012, 09:37 PM |#2  
Junior Member
Thanks Meter: 0
 
More
I am on BOCA RC2 v2.0.8. I've tried a Logitech diNovo Mini keyboard/mouse combo on this ROM, and it first behaved as you say: paired bu not connected. It stayed the same when I selected it and tried to connect. However, I could use both the mouse and keyboard functionality in this state. Later, when I looked at it on the Blutooth settings page, I've seen that the state changed to "connected".
28th April 2012, 10:13 PM |#3  
knowthenazz's Avatar
OP Senior Member
Flag Vancouver, Canada (Samsung Galaxy S2/Samsung Galaxy Nexus/Google Nexus 7)
Thanks Meter: 3
 
More
Quote:
Originally Posted by vhallac

I am on BOCA RC2 v2.0.8. I've tried a Logitech diNovo Mini keyboard/mouse combo on this ROM, and it first behaved as you say: paired bu not connected. It stayed the same when I selected it and tried to connect. However, I could use both the mouse and keyboard functionality in this state. Later, when I looked at it on the Blutooth settings page, I've seen that the state changed to "connected".


Hi vhallac,

Thanks for getting back to me.

I've read that in other threads as well, and I've tried it with Overcome, but it didn't seem to work for me.

Did you do anything else to get the keyboard/mouse to work? Or did you just wait a bit?

Thanks!
28th April 2012, 11:04 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by knowthenazz

Did you do anything else to get the keyboard/mouse to work? Or did you just wait a bit?

Nothing special. I got stuck on pairing a little until I figured out entering the PIN. Clicked the device, selected connect, and while it was trying to connect (which took a while), I got bored and moved the mouse, and I had a pointer on screen (while it was still reporting that it wanted to connect). I switched to an edit box and tried the keyboard, and it worked. When I got back to the settings screen, it reported that it was connected. Probably a refresh issue on the UI.

Out of curiosity, do you have the file /system/lib/bluez-plugin/input.so? I guess that's the library for handling HID.
28th April 2012, 11:19 PM |#5  
knowthenazz's Avatar
OP Senior Member
Flag Vancouver, Canada (Samsung Galaxy S2/Samsung Galaxy Nexus/Google Nexus 7)
Thanks Meter: 3
 
More
Quote:
Originally Posted by vhallac

Nothing special. I got stuck on pairing a little until I figured out entering the PIN. Clicked the device, selected connect, and while it was trying to connect (which took a while), I got bored and moved the mouse, and I had a pointer on screen (while it was still reporting that it wanted to connect). I switched to an edit box and tried the keyboard, and it worked. When I got back to the settings screen, it reported that it was connected. Probably a refresh issue on the UI.

Out of curiosity, do you have the file /system/lib/bluez-plugin/input.so? I guess that's the library for handling HID.


Hi again,

Yup, I have the directory and the input.so file.

Hmm, well, I suspect that it's a bit flaky for 2.3.6.

Thanks for your help. I'm hoping someone might post link to a 2.3.4 ROM that might work properly. But few ROMs seem to keep the links to previous versions for some reason.

Thanks again for your help!
29th April 2012, 02:46 PM |#6  
alexgogan's Avatar
Senior Member
Flag Dublin
Thanks Meter: 26
 
Donate to Me
More
Had the same issue with a few that I tried, and none worked "out of the box" but when you grab an app from the market then had no probs https://play.google.com/store/apps/d...roid.blueinput or this one https://play.google.com/store/apps/d...uekeyboard.ime worked perfectly for me
The Following User Says Thank You to alexgogan For This Useful Post: [ View ]
29th April 2012, 10:04 PM |#7  
knowthenazz's Avatar
OP Senior Member
Flag Vancouver, Canada (Samsung Galaxy S2/Samsung Galaxy Nexus/Google Nexus 7)
Thanks Meter: 3
 
More
Quote:
Originally Posted by alexgogan

Had the same issue with a few that I tried, and none worked "out of the box" but when you grab an app from the market then had no probs https://play.google.com/store/apps/d...roid.blueinput or this one https://play.google.com/store/apps/d...uekeyboard.ime worked perfectly for me

Hi alexgogan,

Thanks for your suggestions. I'll try them out and report back!
1st May 2012, 01:18 AM |#8  
alexgogan's Avatar
Senior Member
Flag Dublin
Thanks Meter: 26
 
Donate to Me
More
No probs hope they work out for ya



Sent from my LT26i using XDA
1st May 2012, 12:46 PM |#9  
Member
Thanks Meter: 9
 
More
I am using a chinese BT keyboard with the Overcome 4.1.0 and it's working out of the box. I used to use a BT mouse as well, but that was with 4.0.0.

I don't know the exact problem you are getting. The only problem i got with keyboard was, when pairing, it asked to enter some digits in keyboard and press the enter key. But it gave me around 2 seconds to do that, failing which resulted in no pairing. So i just sped up my fingers and it paired and worked beautifully.

I can't verify more things now, as currently I am on CM9 ICS 4.0.4 build. Keyboard works fine here as well though.
17th May 2012, 09:58 AM |#10  
knowthenazz's Avatar
OP Senior Member
Flag Vancouver, Canada (Samsung Galaxy S2/Samsung Galaxy Nexus/Google Nexus 7)
Thanks Meter: 3
 
More
Quote:
Originally Posted by alexgogan

Had the same issue with a few that I tried, and none worked "out of the box" but when you grab an app from the market then had no probs https://play.google.com/store/apps/d...roid.blueinput or this one https://play.google.com/store/apps/d...uekeyboard.ime worked perfectly for me

Hi alexgogan,

I finally managed to get the Galaxy Tab back in my hands for a bit, and I tried your suggestion. Actually, I tried this one (Only because it was reviewed slightly higher):

Bluetooth Keyboard Easyconnect
https://play.google.com/store/apps/d...2JzZXJ2aWNlIl0.


And like you said, it seems to work now! My bluetooth icon doesn't indicate a connection for some reason, but, the keyboards connect quite well.

Thanks for your help!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes