Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,750 Members 42,425 Now Online
XDA Developers Android and Mobile Development Forum

[FIXED!]Buggy Menu Dividers in Official ICS Port and MiniCMSandwich ROM!!!!!!!!!!

Tip us?
 
danist727
Old
(Last edited by danist727; 18th May 2012 at 03:13 AM.)
#1  
Senior Member - OP
Thanks Meter 183
Posts: 334
Join Date: Mar 2012
Location: Hong Kong
Talking [FIXED!]Buggy Menu Dividers in Official ICS Port and MiniCMSandwich ROM!!!!!!!!!!

I don't know if anyone mind for the buggy (and ugly) menu dividers in the Official ICS Port and MiniCMSandwich ROM, but at lease I do.
Here there is a method to fix it.
Download the ZipThemer mod zip and use ZipThemer to patch the SemcGenericUxpRes.apk in system/framework to remove the buggy dividers, but other dividrrs originally without bug will not be affected. You don't have to turn Force GPU Rendering anymore.


Sorry for the traditional Chinese texts but I'm lazy to change the language for the screenshot.
Attached Files
File Type: zip FixDividers.zip - [Click for QR Code] (2.3 KB, 134 views)
The Following 3 Users Say Thank You to danist727 For This Useful Post: [ Click to Expand ]
 
shufuking
Old
#2  
shufuking's Avatar
Senior Member
Thanks Meter 2,542
Posts: 375
Join Date: Dec 2011
Location: Taipei
thanks!
it really helps me a lot
wonder why this method could help :P
 
danist727
Old
#3  
Senior Member - OP
Thanks Meter 183
Posts: 334
Join Date: Mar 2012
Location: Hong Kong
Quote:
Originally Posted by shufuking View Post
thanks!
it really helps me a lot
wonder why this method could help :P
Me2! I wonder what is the relationship between list divider and gpu...
But you can see its still buggy, we need to mod the framework-res.apk to make a perfect fix...

Sent from my WT19i using XDA
 
skramz
Old
#4  
skramz's Avatar
Member
Thanks Meter 21
Posts: 85
Join Date: Apr 2012
Location: Las Piņas
Cool, that was a quick fix. Just a noob question with ICS, with the Force GPU rendering option does it somehow eat performance and affect the battery drainage?
Current Phones
Main Nexus 5 D821 Black (16GB)
Android L LPV81C + TWRP 2.7.1.1

Backup Sony Xperia E1 D2005 Black
Stock firmware 20.1.A.0.47 / Android 4.4.2 / rooted + Xposed Modules



Previous Phones
Sony Ericsson W200i Black
Samsung Galaxy 5 I5500 Black
Sony Ericsson Xperia Live With Walkman WT19i Black
Nexus 4 E960 Black (16GB)
 
shufuking
Old
#5  
shufuking's Avatar
Senior Member
Thanks Meter 2,542
Posts: 375
Join Date: Dec 2011
Location: Taipei
Quote:
Originally Posted by skramz View Post
Cool, that was a quick fix. Just a noob question with ICS, with the Force GPU rendering option does it somehow eat performance and affect the battery drainage?
seems that i have this problem too

after force gpu rendering i got much battery drainage
 
skramz
Old
#6  
skramz's Avatar
Member
Thanks Meter 21
Posts: 85
Join Date: Apr 2012
Location: Las Piņas
Quote:
Originally Posted by shufuking View Post
seems that i have this problem too

after force gpu rendering i got much battery drainage
Battery seems okay here, normal drain. Did you check CPU settings?
Current Phones
Main Nexus 5 D821 Black (16GB)
Android L LPV81C + TWRP 2.7.1.1

Backup Sony Xperia E1 D2005 Black
Stock firmware 20.1.A.0.47 / Android 4.4.2 / rooted + Xposed Modules



Previous Phones
Sony Ericsson W200i Black
Samsung Galaxy 5 I5500 Black
Sony Ericsson Xperia Live With Walkman WT19i Black
Nexus 4 E960 Black (16GB)
 
danist727
Old
#7  
Senior Member - OP
Thanks Meter 183
Posts: 334
Join Date: Mar 2012
Location: Hong Kong
Quote:
Originally Posted by skramz View Post
Cool, that was a quick fix. Just a noob question with ICS, with the Force GPU rendering option does it somehow eat performance and affect the battery drainage?
Besides battery drain problem, some apps like ES File Browser, Ninjump, XPERIA S music will appear buggy after [Force GPU Rendering] is turned on though.
The Following User Says Thank You to danist727 For This Useful Post: [ Click to Expand ]
 
danist727
Old
#8  
Senior Member - OP
Thanks Meter 183
Posts: 334
Join Date: Mar 2012
Location: Hong Kong
Fixed 80%!

Sent from my WT19i using xda premium
 
danist727
Old
(Last edited by danist727; 18th May 2012 at 06:34 AM.)
#9  
Senior Member - OP
Thanks Meter 183
Posts: 334
Join Date: Mar 2012
Location: Hong Kong
Quote:
Originally Posted by MasterPiece Tsui View Post
Sent from my LT18i using xda premium
Hey what?
U use arc s so is that you have xm or xmp or lww or active? Right?
Sent from my WT19i using xda premium
 
danist727
Old
#10  
Senior Member - OP
Thanks Meter 183
Posts: 334
Join Date: Mar 2012
Location: Hong Kong
I will continue to discover how to fix this witgout removing the dividers...

Sent from my WT19i using xda premium

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


And the Winners in the XDA Pebble Development Challenge Are…

Almost two months ago, we set out with Pebble to findthree amazing … more

MediaTek Releases Full Kernel Source for First Android One Devices

Those who might have thought that MediaTek wouldnever release working … more

Submitting a Patch to Gerrit – Featuring XplodWild – XDA Developer TV

Not every developer specializes in every area of … more

Learn How to Make a Live Wallpaper all by Yourself

Stillimages can bebeautiful, but some of you prefer to see animations on your screens. … more