Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Camera not working

OP sarin5711

3rd May 2012, 02:54 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Jul 2011
I rooted my phone about two months ago and didnt have any problems at all. Used HTC's website and loaded cleanrom reborn 1.1 and the kernel that came with it is 2.6.35.13-g277012f

Recently, about a week or two ago, I noticed the camera starting to fail. It occasionally wouldnt load in 2D mode, just give me a black screen. Now, it rarely loads at all. Either the whole screen is black or it brings up the camera app (stock, instagram, fb, all the same) but the part of the screen that would show the picture is black. When I turn it to 3D mode the screen freezes, then flickers, and quickly closes to the home screen and still flickers for about 3 seconds then is fine.

My questions are this, could this be caused due to needing an update, a new ROM or new hardware? Also what do you all recommend as far as the best ROM for taking pictures?

And on an unrelated note, does anyone know a good ROM that supports 4G hotspot instead of it just automatically switching to 3G??

Thanks
3rd May 2012, 04:04 AM   |  #2  
jslim38's Avatar
Senior Member
Flag Saint Petersburg
Thanks Meter: 119
 
817 posts
Join Date:Joined: Jul 2011
More
As for the camera failing sorry to here that but you can down load the amaze camera from the dev section and they have all different version of it and its for both CDMA and gsm

Sent from my HTC EVO 3D X515m using xda premium
3rd May 2012, 04:16 AM   |  #3  
GrimReaper24's Avatar
Retired Forum Moderator
Thanks Meter: 1,089
 
5,473 posts
Join Date:Joined: Feb 2011
More
That sounds like a software issue.. Might be the rom or the kernel.
3rd May 2012, 08:50 AM   |  #4  
Keion's Avatar
Senior Member
Flag Danville, California
Thanks Meter: 350
 
1,312 posts
Join Date:Joined: Nov 2011
Donate to Me
More
Are you on ics?

Sent from my EVO 3D S using xda premium
3rd May 2012, 05:27 PM   |  #5  
Senior Member
Thanks Meter: 63
 
339 posts
Join Date:Joined: Mar 2010
My camera just started acting up also, I went ahead and wiped everything and installed bone stock rom (rooted only) and camera is still messed up.

When I use the main camera it works fine, when I switch to front facing camera - it stays on the main camera and just inverts the image

Is this a hardware or software issue? I am guessing it is the hardware

Let me know what you guys think.
3rd May 2012, 11:56 PM   |  #6  
Senior Member
Thanks Meter: 63
 
339 posts
Join Date:Joined: Mar 2010
Quote:
Originally Posted by Heaterz16

My camera just started acting up also, I went ahead and wiped everything and installed bone stock rom (rooted only) and camera is still messed up.

When I use the main camera it works fine, when I switch to front facing camera - it stays on the main camera and just inverts the image

Is this a hardware or software issue? I am guessing it is the hardware

Let me know what you guys think.

Nobody has seen this issue???
4th May 2012, 12:56 AM   |  #7  
laie1472's Avatar
Senior Member
Thanks Meter: 828
 
4,540 posts
Join Date:Joined: Feb 2010
Try running an ruu.

#Root-Hack_Mod*Always\
4th May 2012, 09:20 PM   |  #8  
Senior Member
Thanks Meter: 63
 
339 posts
Join Date:Joined: Mar 2010
Quote:
Originally Posted by laie1472

Try running an ruu.

#Root-Hack_Mod*Always\

If am S-off would I have to re-root if I tried that?
4th May 2012, 10:24 PM   |  #9  
laie1472's Avatar
Senior Member
Thanks Meter: 828
 
4,540 posts
Join Date:Joined: Feb 2010
Yup. Running an ruu removes root. Just don't run the hboot1.5 ruu if your on hboot1.4. It will save you a headache.

#Root-Hack_Mod*Always\
4th May 2012, 11:50 PM   |  #10  
greeg32's Avatar
Senior Member
Green Bay, WI
Thanks Meter: 135
 
541 posts
Join Date:Joined: Sep 2011
I would reflash the rom before ruuing

Sent from my PG86100 using Tapatalk 2

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes