FORUMS

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

Sunday Debate: How Can We Get a No-Compromise Phone?

Join us in a fun Sunday Debate on Compromises. Come with your opinions and … more

[MOD] Improve your battery life

1,374 posts
Thanks Meter: 5,114
 
By Hero, Recognized Developer on 27th April 2012, 04:12 AM
Thread Closed Subscribe to Thread Email Thread
5th May 2012, 03:55 AM |#261  
AeonWorld's Avatar
Recognized Contributor
Flag Somewhere I Belong
Thanks Meter: 2,368
 
Donate to Me
More
Wink
Quote:
Originally Posted by ferotakis

Airplane modes not count

Sent from my E10i using xda premium

yeah that's right, it drains no matter what when display is on and radio is on, but there where issues regarding battery drain even in airplane mode that's why I shared. of course no use when running
 
 
5th May 2012, 08:08 AM |#262  
ferotakis's Avatar
Senior Member
Flag Sofia-Munchen-Venezia Santa Lucia - Ηρακλείου
Thanks Meter: 154
 
More
Ok now I must explayn you all something simple to stop those there who biching and give the happyness to those who happy with this mod.
For 50% of you this work but for 50% - not. Why?
There is why:
For those who notice batt + the reason is on your kernel , your dev for some reason make your kernels in somehow bad way and when you apply those changes you force your divace work better and you notice + of batt juice. That's it - simple as hell.
For those who not notice +batt it bicoz your devs make kernel for your phone perfect and applyng this not give you +juice . That's it
And for those who notice bad pefr -batt and etc mean this values its high or conflict whit something your dev integrate into your kernel and etc.
In the end that's it ,no need bad feelings ,spams , show us how big engeneer you are , how google must be Boogle or Woogle , trow smartphone to the wall and go to buy Nokia 1100 for montly charge the batt and etc and etc.
Like my mom say :
Change your words change your World

Hawe nice day

Sent from my E10i using xda premium
The Following User Says Thank You to ferotakis For This Useful Post: [ View ]
5th May 2012, 12:29 PM |#263  
Tof37's Avatar
Senior Member
Flag Tours
Thanks Meter: 2,695
 
Donate to Me
More
@PureMotive

Thanks for these tweaks ...

Which permissions needs init.d ?

There are set to "set_perm_recursive 0 0 0777 0777" is it good for your script ?


Thanks a lot
5th May 2012, 12:44 PM |#264  
jimbub's Avatar
Senior Member
Flag The Moon
Thanks Meter: 51
 
More
Quote:
Originally Posted by losta

thank you so much, im gonna give it a try

edit : a few more questions after i make the new file in init.d, what command should i type from the terminal to know if the script is running as it should? i'm trying the second option you given me, using only the init.d and i deleted the sysctl.conf. many thanks before

"Sysctl -p" runs it
"Syscyl -a" or "sysctl -a | grep vm" checks it

Sent from my ADR6300 using xda premium
The Following User Says Thank You to jimbub For This Useful Post: [ View ]
5th May 2012, 02:37 PM |#265  
Senior Member
Thanks Meter: 26
 
More
Quote:
Originally Posted by jimbub

"Sysctl -p" runs it
"Syscyl -a" or "sysctl -a | grep vm" checks it

Sent from my ADR6300 using xda premium

Thanks for your response after running those command, here is what i get for the output, is this okay? Thanks in advance

Sent from my GT-I9100 using xda premium
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1336225004937.jpg
Views:	439
Size:	45.6 KB
ID:	1042324  
5th May 2012, 04:08 PM |#266  
mohsinraza's Avatar
Senior Member
Thanks Meter: 300
 
Donate to Me
More
I'm really sad that I flashed this MOD. it's been over 24 hours I've flashed this and from that time my phone takes 15 minutes to charge 1% battery. The battery drain is very fast. My phone doesn't charge fully even after 6,7 hours plugging the phone in. I've reflashed the rom with full wipe. Changed my kernel. I've done evrything I could do to sort out this problem but I failed...
Please tell me what should I do? My battery keeps on going down even if I do texting while charging the phone. Even when the phone is turned off it takes so much time to charge. HELP...!!!!
I'm writing while the phone is plugged in and it was 7% and now its 5% battery left. Help me asap.. plz.. I need my phone... How to cancel the effect of this zip file?
I've provided you with maximum details. I'm not near my computer for next 20 days. Not even in a wifi zone... Help me... Suggest me something I can do from phone only...

Sent from my HTC Desire
5th May 2012, 04:23 PM |#267  
cmlusco's Avatar
Senior Member
Flag Michigan City, IN
Thanks Meter: 937
 
Donate to Me
More
Quote:
Originally Posted by mohsinraza

I'm really sad that I flashed this MOD. it's been over 24 hours I've flashed this and from that time my phone takes 15 minutes to charge 1% battery. The battery drain is very fast. My phone doesn't charge fully even after 6,7 hours plugging the phone in. I've reflashed the rom with full wipe. Changed my kernel. I've done evrything I could do to sort out this problem but I failed...
Please tell me what should I do? My battery keeps on going down even if I do texting while charging the phone. Even when the phone is turned off it takes so much time to charge. HELP...!!!!
I'm writing while the phone is plugged in and it was 7% and now its 5% battery left. Help me asap.. plz.. I need my phone... How to cancel the effect of this zip file?
I've provided you with maximum details. I'm not near my computer for next 20 days. Not even in a wifi zone... Help me... Suggest me something I can do from phone only...

Sent from my HTC Desire

If you believe this mod is causing the issue, then go to /system/etc and delete sysctl.conf, then go to /system/etc/init.d, and delete the sysctl file and reboot. Problem should be fixed if its whats causing the issue.
5th May 2012, 04:24 PM |#268  
Recognized Developer
Thanks Meter: 4,707
 
More
Quote:
Originally Posted by mohsinraza

I'm really sad that I flashed this MOD. it's been over 24 hours I've flashed this and from that time my phone takes 15 minutes to charge 1% battery. The battery drain is very fast. My phone doesn't charge fully even after 6,7 hours plugging the phone in. I've reflashed the rom with full wipe. Changed my kernel. I've done evrything I could do to sort out this problem but I failed...
Please tell me what should I do? My battery keeps on going down even if I do texting while charging the phone. Even when the phone is turned off it takes so much time to charge. HELP...!!!!
I'm writing while the phone is plugged in and it was 7% and now its 5% battery left. Help me asap.. plz.. I need my phone... How to cancel the effect of this zip file?
I've provided you with maximum details. I'm not near my computer for next 20 days. Not even in a wifi zone... Help me... Suggest me something I can do from phone only...

Sent from my HTC Desire

If you've wiped system and flashed the rom again without the mod, the mod is definitely gone. However, it wouldn't be causing that excessive battery drain anyway. There's no way a file on the phone would affect it when it's off. It sounds to me like a hardware issue somewhere. Try a new charger or battery. Sorry I can't be of much help myself but most of what you say sounds hardware related and nothing to do with the mod.
5th May 2012, 04:37 PM |#269  
Senior Member
Thanks Meter: 327
 
More
So how can I tell if this is running for sure....other than battery
Edit:Got it. Did the terminal thing. I got a bunch of stuff from the file
Sent from my Galaxy Nexus using xda premium
Last edited by tacosrdelicioso; 5th May 2012 at 05:12 PM.
5th May 2012, 06:57 PM |#270  
prototype7's Avatar
Senior Member
Flag New Hampshire
Thanks Meter: 1,142
 
Donate to Me
More
Quote:

Quote:

Originally Posted by jimbub<br />
"Sysctl -p" runs it<br />
"Syscyl -a" or "sysctl -a | grep vm" checks it<br />
<br />
Sent from my ADR6300 using xda premium

<br />
<br />
Thanks for your response after running those command, here is what i get for the output, is this okay? Thanks in advance<br />
<br />
Sent from my GT-I9100 using xda premium

Yep, that looks good.

Sent from my Incredible 2 using Tapatalk 2 Beta-5
5th May 2012, 08:22 PM |#271  
MidnightDevil's Avatar
Senior Member
Flag Lisbon
Thanks Meter: 1,011
 
More
Well.. flashed yesterday using the zip.. I got the same output as losta... so I guess it's running and so far it's fine
The first thing I noticed is that takes a while longer to drop the percentage... but on heavy tasks such as using wifi or 3g can't really tell the diference so far... but I think i'm getting something out of this.. will know for sure in a couple of days

cheers for the effort.

HTC Desire

Read More
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes