Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Double Tap to Wake on the Nexus 6 Without Root

A few weeks ago, we featured an app which allowed the Nexus 6 to regain the double tap to wake … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Deleted

[REF] Don't Start A New Thread - Acer F1 Questions & Answers Here!

OP Fallen Spartan

3rd April 2012, 10:30 AM   |  #31  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Dec 2010
Hello, I have a problem with my Acer s200.
The phone doesn't turn on.. I've tried to connect it via usb to my pc but the screen constantly remains black. while connected to the pc only the led flashes red, and even in charge, I can't turn it on, normally or either in safe mode.
Any suggestion?

ps. nearly one year ago the update interrupted because the light went down..
7th April 2012, 12:31 AM   |  #32  
xHausx's Avatar
Forum Moderator / Recognized Developer
Flag Central Florida
Thanks Meter: 4,538
 
6,781 posts
Join Date:Joined: Jul 2010
Donate to Me
More
Quote:
Originally Posted by AmedeoFumagalli

Hello, I have a problem with my Acer s200.
The phone doesn't turn on.. I've tried to connect it via usb to my pc but the screen constantly remains black. while connected to the pc only the led flashes red, and even in charge, I can't turn it on, normally or either in safe mode.
Any suggestion?

ps. nearly one year ago the update interrupted because the light went down..

Your battery may have gone bad or gotten too low. Have you tried leaving it plugged in for awhile? It may be trying to slowly charge it back up to where it's usable again.
5th May 2012, 06:49 PM   |  #33  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by xHausx

Your battery may have gone bad or gotten too low. Have you tried leaving it plugged in for awhile? It may be trying to slowly charge it back up to where it's usable again.

I'll try thanks!
16th October 2012, 06:21 AM   |  #34  
Junior Member
Thanks Meter: 0
 
21 posts
Join Date:Joined: Aug 2011
any other threads for betouch e400?...anyone can help??

Sent from my E400 using xda premium
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes