FORUMS

Optimize Battery Life with This Useful App

Battery life is an important aspect of your smartphone, especially if you use it for more … more

The OnePlus 2 & The Year of Smartphone Compromises

We are very close to entering the last third of 2015, and we have now seen many of … more

OnePlus 2 Teardown, Major Android Vulnerability – XDA TV

The OnePlus 2 has been officially released. That and much more news is … more

What Do You Think About Fingerprint Scanners?

More and more phones are featuring fingerprint scanners, and with many promising … more

[REF] Don't Start A New Thread - Acer F1 Questions & Answers Here!

23,174 posts
Thanks Meter: 4,605
 
By Fallen Spartan, Senior Moderator / Moderator Committee Retired- Irish Pride, Spartan Legacy on 3rd February 2010, 09:20 AM
Thread Deleted Subscribe to Thread Email Thread
3rd April 2012, 09:30 AM |#31  
Junior Member
Thanks Meter: 0
 
More
Hello, I have a problem with my Acer s200.
The phone doesn't turn on.. I've tried to connect it via usb to my pc but the screen constantly remains black. while connected to the pc only the led flashes red, and even in charge, I can't turn it on, normally or either in safe mode.
Any suggestion?

ps. nearly one year ago the update interrupted because the light went down..
 
 
6th April 2012, 11:31 PM |#32  
xHausx's Avatar
Forum Moderator / Recognized Developer
Flag Central Florida
Thanks Meter: 4,550
 
Donate to Me
More
Quote:
Originally Posted by AmedeoFumagalli

Hello, I have a problem with my Acer s200.
The phone doesn't turn on.. I've tried to connect it via usb to my pc but the screen constantly remains black. while connected to the pc only the led flashes red, and even in charge, I can't turn it on, normally or either in safe mode.
Any suggestion?

ps. nearly one year ago the update interrupted because the light went down..

Your battery may have gone bad or gotten too low. Have you tried leaving it plugged in for awhile? It may be trying to slowly charge it back up to where it's usable again.
5th May 2012, 05:49 PM |#33  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by xHausx

Your battery may have gone bad or gotten too low. Have you tried leaving it plugged in for awhile? It may be trying to slowly charge it back up to where it's usable again.

I'll try thanks!
16th October 2012, 05:21 AM |#34  
Junior Member
Thanks Meter: 0
 
More
any other threads for betouch e400?...anyone can help??

Sent from my E400 using xda premium
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes