Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,908 Members 53,848 Now Online
XDA Developers Android and Mobile Development Forum

Rooting Stock UCKK4 Gingerbread 2.3.5 on a Ubuntu Machine

Tip us?
 
Ir0nLy0n
Old
#1  
Ir0nLy0n's Avatar
Senior Member - OP
Thanks Meter 137
Posts: 201
Join Date: Jul 2011
Location: Baton Rouge

 
DONATE TO ME
Default Rooting Stock UCKK4 Gingerbread 2.3.5 on a Ubuntu Machine

I recently had to go from ICS back to stock GB due to a bad flash.

I am now on UCKK4 stock and after hours of searching can't seem to find any way to root it on a ubuntu system. My windows machine died so using superoneclick or odin doesnt seem to be an option. I tried a couple heimdall packages with cwm kernels already in them but couldn't get them to flash. (they would hang at factoryfs) I tried all the suggestions in the connection issues guide and didnt find a solution.

If anyone knows how to root this on Ubuntu 12.04 the help would be much appreciated.

Sent from my SAMSUNG-SGH-I897 using xda premium
<-- Note II -->
<-- Nexus 7 -->
SuperSU by Chainfire
<-- Captivate (I-897) -->
The Following User Says Thank You to Ir0nLy0n For This Useful Post: [ Click to Expand ]
 
4-2ndtwin
Old
#2  
4-2ndtwin's Avatar
Recognized Contributor
Thanks Meter 2473
Posts: 3,034
Join Date: Dec 2010
Location: Arkansas

 
DONATE TO ME
Did u try Heimdall Suite 1.3.1 and flash the Corn Kernel (zImage) of ur choice and then Root through the CWM ??

Sent from my SAMSUNG-SGH-I897 using xda premium




The Following User Says Thank You to 4-2ndtwin For This Useful Post: [ Click to Expand ]
 
Ir0nLy0n
Old
(Last edited by Ir0nLy0n; 11th May 2012 at 05:01 PM.)
#3  
Ir0nLy0n's Avatar
Senior Member - OP
Thanks Meter 137
Posts: 201
Join Date: Jul 2011
Location: Baton Rouge

 
DONATE TO ME
I couldn't get heimdall suite to load the zimage. I'll try working with that again when I get home from work though.
Does it have to be 1.3.1 or should I install 1.3.2?

Sent from my SAMSUNG-SGH-I897 using xda premium
<-- Note II -->
<-- Nexus 7 -->
SuperSU by Chainfire
<-- Captivate (I-897) -->
The Following User Says Thank You to Ir0nLy0n For This Useful Post: [ Click to Expand ]
 
4-2ndtwin
Old
#4  
4-2ndtwin's Avatar
Recognized Contributor
Thanks Meter 2473
Posts: 3,034
Join Date: Dec 2010
Location: Arkansas

 
DONATE TO ME
I have used 1.3.1
Haven't downloaded/ installed 1.3.2 yet...

Sent from my SAMSUNG-SGH-I897 using xda premium




The Following User Says Thank You to 4-2ndtwin For This Useful Post: [ Click to Expand ]
 
Ir0nLy0n
Old
#5  
Ir0nLy0n's Avatar
Senior Member - OP
Thanks Meter 137
Posts: 201
Join Date: Jul 2011
Location: Baton Rouge

 
DONATE TO ME
Think this one click would work? http://forum.xda-developers.com/show....php?t=1350266
Just saw it today. May try it as well.

Sent from my SAMSUNG-SGH-I897 using xda premium
<-- Note II -->
<-- Nexus 7 -->
SuperSU by Chainfire
<-- Captivate (I-897) -->
 
Ir0nLy0n
Old
(Last edited by Ir0nLy0n; 12th May 2012 at 03:12 PM.) Reason: Addition.
#6  
Ir0nLy0n's Avatar
Senior Member - OP
Thanks Meter 137
Posts: 201
Join Date: Jul 2011
Location: Baton Rouge

 
DONATE TO ME
Ok. Tried flashing via Heimdall and this is what I end up with


Heimdall v1.3.2, Copyright (c) 2010-2012, Benjamin Dobell, Glass Echidna
http://www.glassechidna.com.au

This software is provided free of charge. Copying and redistribution is
encouraged.

If you appreciate this software and you would like to support future
development please consider donating:
http://www.glassechidna.com.au/donate/

Initialising connection...
Detecting device...
Claiming interface...
Attempt failed. Detaching driver...
Claiming interface again...
Setting up interface...

Checking if protocol is initialised...
Protocol is not initialised.
Initialising protocol...
Handshaking with Loke...

Beginning session...
Session begun with device of type: 0

Downloading device's PIT file...
PIT file download sucessful

Uploading KERNEL
0%

ERROR: Failed to send file part packet!
KERNEL upload failed!
Ending session...

Tried different USB Ports. Rebooting Computer Reentering download mode each time. Same thing

Edit: If I Repartition it makes it to 10% but still wont complete
<-- Note II -->
<-- Nexus 7 -->
SuperSU by Chainfire
<-- Captivate (I-897) -->
 
4-2ndtwin
Old
(Last edited by 4-2ndtwin; 12th May 2012 at 04:53 PM.)
#7  
4-2ndtwin's Avatar
Recognized Contributor
Thanks Meter 2473
Posts: 3,034
Join Date: Dec 2010
Location: Arkansas

 
DONATE TO ME
Try a different micro usb/ usb cable... U will b surprised at the difference that can make.


Sent from my SAMSUNG-SGH-I777 using xda premium




The Following User Says Thank You to 4-2ndtwin For This Useful Post: [ Click to Expand ]
 
Ir0nLy0n
Old
#8  
Ir0nLy0n's Avatar
Senior Member - OP
Thanks Meter 137
Posts: 201
Join Date: Jul 2011
Location: Baton Rouge

 
DONATE TO ME
Ok. I was able to use a one click and it went all the way through but now phone wont boot past cwm recovery.
<-- Note II -->
<-- Nexus 7 -->
SuperSU by Chainfire
<-- Captivate (I-897) -->
 
4-2ndtwin
Old
#9  
4-2ndtwin's Avatar
Recognized Contributor
Thanks Meter 2473
Posts: 3,034
Join Date: Dec 2010
Location: Arkansas

 
DONATE TO ME
Which one click ?? And u may have to do some wipes in the cwm and then try to reboot.




 
Ir0nLy0n
Old
#10  
Ir0nLy0n's Avatar
Senior Member - OP
Thanks Meter 137
Posts: 201
Join Date: Jul 2011
Location: Baton Rouge

 
DONATE TO ME
Ok. All the way back to stock and trying again. (different cable)
<-- Note II -->
<-- Nexus 7 -->
SuperSU by Chainfire
<-- Captivate (I-897) -->

The Following User Says Thank You to Ir0nLy0n For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes