Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,702 Members 45,519 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Thrown in water now does not boot properly, ideas?

Tip us?
 
goldohulk
Old
#1  
Member - OP
Thanks Meter 1
Posts: 67
Join Date: Sep 2009
Default [Q] Thrown in water now does not boot properly, ideas?

Hello all,

had a 32A magic, on which I installed CM 6.1. In my hands the poor device lived and prospered. Then I decided to give it to my daughter and hell broke loose.

She handed it to me, and it couldn't get into recovery. I tried and tried to avail. THEN she told me that it has slipped from her hands and fell in water (!)

The mobile probably got fried, but I've left it to dry out. Then I tried to boot into recovery and it worked. I could also start the phone but this worked intermittedly: while at some times I saw the "HTC Magic" text at boot, folllowed by the CM splash animation, followed by a normal entry to Android, at other times it got stuck at the initial "HTC Magic" screen for ever.... Now it gets stuck at "HTC Magic" does not proceed with boot

I tried wiping everything (factory,cache, dalvik), reinstalling CM & gapps. Nothing. I tried installing yoshi ginger. Same result...

Obviously this is not fully bricked, but may as well be damaged beyond repair. Any advice from the knowledgeable lads here?
Froyo 2.2 / PDA: I9000XWJPH / Phone: I9000XXJPP / CSC: I9000OXXJP9
 
dirtyyy
Old
(Last edited by dirtyyy; 12th May 2012 at 07:52 AM.)
#2  
Member
Thanks Meter 0
Posts: 37
Join Date: Oct 2011
Try submerging it fully in uncooked rice.

My iPhone died due to water but I left it in a bowl of rice for almost 2 weeks and it came back to life fully. I tested it occasionally during the 2 weeks and it slowly got better and better. After roughly 2 weeks apart from some cosmetic damage (some rust on lower screws and speaker) it was working fully again.

Depending on your phone remove phone cover (if you have), battery, battery cover, sim etc.

Albeit I can't guarantee it will work certainly I would recommend it. I know its best to stick it in rice asap.

Good luck in whatever you decide..

Sent from my HTC Desire HD A9191 using XDA
 
goldohulk
Old
#3  
Member - OP
Thanks Meter 1
Posts: 67
Join Date: Sep 2009
I sincerely hoped that there would a more technical solution (if any) for it. When I was informed of the issue, I did leave the phone in rice, but for a short interval (2-3) hours.

I still hope that there is something else that should/could be done here...
Froyo 2.2 / PDA: I9000XWJPH / Phone: I9000XXJPP / CSC: I9000OXXJP9
 
goldohulk
Old
#4  
Member - OP
Thanks Meter 1
Posts: 67
Join Date: Sep 2009
Well, I finally solved this by installing new radio (6.X, whereas I had the old 3.22 installed), hboot, rom, recovery.... Now the mobile boots and works just fine!
Froyo 2.2 / PDA: I9000XWJPH / Phone: I9000XXJPP / CSC: I9000OXXJP9
Tags
boot, magic, problem, splash
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes