FORUMS

Hauwei’s Rapid Rise to Third Place in the Smartphone Race

Huawei has quickly grown to become one of the world’s biggest … more

OnePlus 2 Bares All in New Tear Down Gallery

Last year, the launch of the OnePlus One, dubbed ‘the flagship killer’, visibly … more

Focus – An Attractive But Raw Gallery Replacement

Focus is an attractive new app built by XDA members Liam Spradlin … more

How to Root the LG G4 and Install TWRP Recovery – XDA TV

A rooting method has finally been found for the flagship LG G4. In this … more

[Q] Extremely bad internet speeds after rooting

9,076 posts
Thanks Meter: 13,856
 
Post Reply Subscribe to Thread Email Thread
Hello, so basically I have rooted my Speedy from 2.3.4 by using the bootloader unlock method posted by VICODAN in his tutorial but now I find that I am having insanely slow download/upload speeds compared to before rooting.

I have flashed the latest radio after finding THIS thread and I also tried the method from HERE to try and at least boost my speeds. I have also updated my profile and PRL through my Sense rom but nothing seems to help.

If anyone could give me any advice I would greatly appreciated it. I am on MikShifted-G v2.1 running dodgekernal v1.6. Thanks in advance.

I would also like to know if there is any way that I can go back to the stock 2.3.4 GB.

Download speed: 228 kbps
Upload speed: 25 kbps
Last edited by CNexus; 17th May 2012 at 02:03 AM. Reason: Misspelling in original
 
 
17th May 2012, 02:29 AM |#2  
drob311's Avatar
Senior Member
Flag Fond du Lac, WI
Thanks Meter: 962
 
More
Quote:
Originally Posted by CNexus

Hello, so basically I have rooted my Speedy from 2.3.4 by using the bootloader unlock method posted by VICODAN in his tutorial but now I find that I am having insanely slow download/upload speeds compared to before rooting.

I have flashed the latest radio after finding THIS thread and I also tried the method from HERE to try and at least boost my speeds. I have also updated my profile and PRL through my Sense rom but nothing seems to help.

If anyone could give me any advice I would greatly appreciated it. I am on MikShifted-G v2.1 running dodgekernal v1.6. Thanks in advance.

I would also like to know if there is any way that I can go back to the stock 2.3.4 GB.

Download speed: 228 kbps
Upload speed: 25 kbps

Welcome to sprint, the not now, maybe later network... :beer:

Sent from my PG06100
The Following User Says Thank You to drob311 For This Useful Post: [ View ]
17th May 2012, 03:00 AM |#3  
prboy1969's Avatar
Recognized Contributor
Flag Michigan
Thanks Meter: 7,322
 
More
Well I've found that your speeds depend on what time of day it is. I know that's BS, but it's what I've found. Posted some Screen Shots Below of my Speeds.
Attached Thumbnails
Click image for larger version

Name:	2012-05-16_21-27-07.jpg
Views:	179
Size:	65.3 KB
ID:	1065813   Click image for larger version

Name:	2012-05-16_21-39-40.jpg
Views:	177
Size:	63.9 KB
ID:	1065814  
17th May 2012, 03:27 AM |#4  
Senior Member
Thanks Meter: 345
 
More
The only time I get decent speeds from sprint is at night. Like 2am night.
17th May 2012, 04:11 AM |#5  
prboy1969's Avatar
Recognized Contributor
Flag Michigan
Thanks Meter: 7,322
 
More
You could also try the 3G Turbo Charger. You'll find it on THIS thread. Just make sure to read before installing.

TEAM MiK
MikROMs Since 3/13/11
Last edited by prboy1969; 17th May 2012 at 04:21 AM.
17th May 2012, 07:21 AM |#6  
Member
Thanks Meter: 8
 
More
Maybe you had roaming enabled in your old/stock rom and it's turned off be default in your new rom?
17th May 2012, 09:16 PM |#7  
CNexus's Avatar
OP Recognized Contributor
Flag ~/android
Thanks Meter: 13,856
 
Donate to Me
More
Well the thing is that I had perfectly fine speeds in my area prior to rooting.

I downloaded the "Network signal speeds booster" and "Fresh netowork booster", both from the play store and I am having almost back to normal speeds now, there was a dramatic increase in speed after I used both of those.

But I have also looked at the 3G Turbo Charger thread that prboy linked and I will definitely be trying that as well

Sent from my PG06100 using XDA
17th May 2012, 10:12 PM |#8  
CNexus's Avatar
OP Recognized Contributor
Flag ~/android
Thanks Meter: 13,856
 
Donate to Me
More
Screenshot to show my speeds now after using those

appsClick image for larger version

Name:	uploadfromtaptalk1337289088085.jpg
Views:	135
Size:	30.2 KB
ID:	1067402

Sent from my PG06100 using XDA
22nd May 2012, 11:50 AM |#9  
VICODAN's Avatar
Senior Member
Flag San Jose, CA
Thanks Meter: 476
 
Donate to Me
More
Try turning off data roaming.
22nd May 2012, 10:32 PM |#10  
CNexus's Avatar
OP Recognized Contributor
Flag ~/android
Thanks Meter: 13,856
 
Donate to Me
More
What does that do exactly?

Sent from my PG06100 using Tapatalk 2
3rd October 2012, 04:43 AM |#11  
CNexus's Avatar
OP Recognized Contributor
Flag ~/android
Thanks Meter: 13,856
 
Donate to Me
More
I Just noticed this (several months later), but prboy, for your top screenshot you're connected to 4G, and in the bottom you're using 3G? I think in yours specifically it was only the connection you were using and not actually the time of day...

Sent from my PG06100 using XDA premium

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes