FORUMS

Analysis & Opinion

Clock widgets stop working on ICS

874 posts
Thanks Meter: 190
 
By rec71, Senior Member on 17th May 2012, 08:01 PM
Post Reply Subscribe to Thread Email Thread
I have been seeing an issue on my Arc S where, after playing something quite memory intensive (such as Draw Something). when I return to the home screen my clock widget is not showing the correct time (see screen shot - note the time in the top-left is different to the widget). It's driving me nuts. Any ideas? Here's what I know:
  1. I have seen this on GB before back when I first got my Arc S in December last year. Again when using a lot of memory (Maps for example). So it isn't necessarily a new issue.
  2. It is much worse since the official release of ICS. I don't remember if this happened on the beta but it's possible I wasn't using my phone to play as many games.
  3. It affects all the clock widgets I've tried. I have tried the supplied analogue clocks, digital clocks and the HTC Sense 4 clock pictured.
  4. Sometimes if I leave the screen on the clock will sort itself out.
  5. Sometimes it stays like this for good until the widget is deleted and re-added.
  6. Sometimes locking the screen for a little while will fix it.
  7. A full reinstall doesn't fix this.
  8. I am now on 4.0.4 (clean install last night) and the issue persists.
  9. I am running the stock ICS kernel with CWM (from here http://forum.xda-developers.com/show....php?t=1591279)
  10. I know of one other user having this issue (and he's on Arconium)

I think this is probably an issue with the Sony Launcher but any suggestions are welcome because it's most annoying that I can't even rely on my clock widget to tell the right time!

I might try the Nexus launcher and see if the problem persists.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2012-05-17-19-42-54.jpg
Views:	169
Size:	32.2 KB
ID:	1067203  
 
 
17th May 2012, 10:46 PM |#2  
OP Senior Member
Flag Calne
Thanks Meter: 190
 
More
So I tried the stock ICS launcher (Launcher2) and the same problem exists.

Perhaps this is a kernel problem.
18th May 2012, 12:02 AM |#3  
Senior Member
Flag Quezon City
Thanks Meter: 88
 
More
Quote:
Originally Posted by rec71

So I tried the stock ICS launcher (Launcher2) and the same problem exists.

Perhaps this is a kernel problem.

Your clock widget gets killed due to out of memory when you run heavy applications . See "Running Services" at Settings>Applications. You will notice that the widget is 'restarting'.

Sent from my LT15i using XDA
Last edited by zangetsu2188; 18th May 2012 at 12:04 AM.
18th May 2012, 10:28 AM |#4  
OP Senior Member
Flag Calne
Thanks Meter: 190
 
More
So why doesn't it restart properly? Seems odd. Even if the launcher reloads completely the clock stays "stuck".

Guess I'll have to live with it.
18th May 2012, 10:35 AM |#5  
OP Senior Member
Flag Calne
Thanks Meter: 190
 
More
I could give SuperCharger a go and try to make the clock widget HTK...
The Following User Says Thank You to rec71 For This Useful Post: [ View ]
18th May 2012, 05:25 PM |#6  
^eLipS#'s Avatar
Senior Member
Flag Novi Sad
Thanks Meter: 11
 
More
This also happened to me while I was on Gingerbread, and I was unable to find a solution...

P.S. I accidentally pressed thanks button on your last post rec71, LOL
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes