FORUMS

Google No Longer Sending Calendar SMS Notifications

In a not entirely surprising move, Google announced that it’s putting an … more

Enable Multi-Window Mode on M Developer Preview

What was not mentioned in yeterday’s keynote was Android M’s multi-window … more

I/O Summary: Google Cardboard Virtual Reality

One year ago, Google introduced cardboard. Amazingly enough, that was all it took to fire … more

Android M Preview Images – XDA TV

Android M preview images are available. That and much more news is covered by Jordan when he … more

WhatsApp - Notification issues

Thanks Meter: 54
 
By Yze, Senior Member on 11th May 2012, 08:12 AM
Post Reply Subscribe to Thread Email Thread
So I had a Note previously, WhatsApp worked perfectly fine.

I notice now that there are a lot of weird notification issues now. I ran some tests and this is what I've found.

Screen On - Clear all apps with Task Manager. Exit to home screen. Meaning, WhatsApp is not running in the background, not running at all. I use my girlfriends phone to send me 10 + messages. I get NO pushed messages, no notifications. Nothing happens. I then launch the app and see that I have 10+ unread messages under her name. I click to read the messages, and exit back to the home screen (either back arrow or home button). I send another message from her phone, and NOW I see the notifications.

Screen Off - (sleeping but app is still in the background) - I send a message from her phone, get NO push notification. But... as soon as I hit the power button to light up the screen (wake from sleep), I get the notification in the bar. I read the message, clear the notification bar.. then put the phone back to sleep. Same thing happens. While the screen is off, I get no push notifications until I turn on the screen.


Anyone having weird issues with WhatsApp? It can't be the app because it works perfectly normal on my Samsung Note. I'm thinking ICS broke it some how.
 
 
11th May 2012, 11:49 AM |#2  
Member
Flag Boston
Thanks Meter: 0
 
More
The notifications works fine for me with whatsapp. The only thing is that when I hit clear in the notification bar and haven't read the actual message, the notification will reappear again.

Sent from my HTC One X using Tapatalk 2
20th May 2012, 11:27 PM |#3  
Senior Member
Thanks Meter: 3
 
More
Same thing here just happened with me on my HTC ONE S , if screen if off and whatsapp is running i get no notification, however as soon as i press the power button immediately i get notified and the weird thing is the notification sound is the default ringtone while in whatsapp settings i have another tone set. Whatsapp was working fine. I tried reinstalling, force stopping, rebooting.

My phone is stock rom no root any help would be appreciated



EDIT (SOLVED): Disable Fast Boot under power options in settings, disabling it fixed my problem (Read it somewhere online)
Last edited by at004; 20th May 2012 at 11:42 PM. Reason: SOLVED
The Following User Says Thank You to at004 For This Useful Post: [ View ]
21st May 2012, 02:44 AM |#4  
Alcoholic's Avatar
Senior Member
Thanks Meter: 75
 
More
I have problems with notifications when wifi is on. No problems w/out wifi
17th July 2012, 03:58 AM |#5  
cavagnaro's Avatar
Member
Thanks Meter: 8
 
More
I have exact same issue on my Xperia Arc...with or without Wifi...I have ICS 4.0.3
I think it is phone independent issue...
17th July 2012, 10:11 AM |#6  
nimrodsv's Avatar
Senior Member
Thanks Meter: 190
 
More
i think you all should stop closing all apps from the task manager and everything would be fine.

you cant shut down all apps and then expect from them to work.

(at004 solution could help too)
30th September 2012, 06:59 PM |#7  
Junior Member
Thanks Meter: 11
 
More
Sorry to revive this thread, but I have a solution to the problem (I think) and I thought I might share it.

Some routers flag push messages as "Anonymous Internet Requests" which the NAT dismisses. This will effectively kill push and you'll only get your messages on the next sync.

To counter this problem you can forward the google push port to your phone.
You'll need a static IP for the phone. The port Google uses for push messages is 5228 on TCP.

Good luck with your problems!
The Following 2 Users Say Thank You to Zendio For This Useful Post: [ View ]
23rd October 2012, 06:01 AM |#8  
daniLaLaLaLaLa's Avatar
Senior Member
Flag Kuala Lumpur
Thanks Meter: 132
 
More
ahh.. i got the notification problem.. there is no sound or vibrate for incoming whatsapp messages..
this happen affter i update the apps.. damn!
17th December 2012, 09:28 PM |#9  
calanizzle's Avatar
Senior Member
Flag Guayaquil
Thanks Meter: 169
 
Donate to Me
More
Quote:
Originally Posted by Yze

So I had a Note previously, WhatsApp worked perfectly fine.

I notice now that there are a lot of weird notification issues now. I ran some tests and this is what I've found.

Screen On - Clear all apps with Task Manager. Exit to home screen. Meaning, WhatsApp is not running in the background, not running at all. I use my girlfriends phone to send me 10 + messages. I get NO pushed messages, no notifications. Nothing happens. I then launch the app and see that I have 10+ unread messages under her name. I click to read the messages, and exit back to the home screen (either back arrow or home button). I send another message from her phone, and NOW I see the notifications.

Screen Off - (sleeping but app is still in the background) - I send a message from her phone, get NO push notification. But... as soon as I hit the power button to light up the screen (wake from sleep), I get the notification in the bar. I read the message, clear the notification bar.. then put the phone back to sleep. Same thing happens. While the screen is off, I get no push notifications until I turn on the screen.


Anyone having weird issues with WhatsApp? It can't be the app because it works perfectly normal on my Samsung Note. I'm thinking ICS broke it some how.

This happens on my brand new nexus 4
18th December 2012, 06:41 PM |#10  
EliWay's Avatar
Senior Member
Boston, MA
Thanks Meter: 67
 
More
This used to happen way back when I first got my One X, but it is solved now. I thought it was because I had rooted and gone with a newer build, but I got a replacement One X stock with 2.20 and notifications work fine when screen is off.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes