FORUMS

Analysis & Opinion

Top Forum Discussions

How to get MMS working on sim unlocked phones

3 posts
Thanks Meter: 3
 
By Assault88, Junior Member on 8th May 2011, 04:33 AM
Post Reply Subscribe to Thread Email Thread
18th April 2012, 11:17 PM |#21  
Junior Member
Flag Rio Rancho
Thanks Meter: 0
 
More
ok. after almost 2 month to try fixing my data issue on my phone today I thing was my lucky day.

check out r-tel.net/forum.html#/20120405/lg-c900-no-cell-data-1460613/

doesn't have to much sense to me but i have Internet on my phone no MMS do, yet.
 
 
19th April 2012, 08:52 AM |#22  
Junior Member
Thanks Meter: 0
 
More
mmsc settings ? how to modify using mfg
Ok so I have read this forum and noticed some people are having problems with simple mobile and sending mms I contacted them and they gave me the setting you need to change but I dont know how to do this using the mfg app so this is what I have any help will be greatly appreciated.

mmsc = 10.165.193.23/mms/wadenc
mms prop c = 216.155.165.50
mms port = 8080

apn is simple
username is blank
password is blank

I was able to get the internet working but still dont know where to make the changes for mmsc above
16th May 2012, 01:01 AM |#23  
Member
Flag Michigan
Thanks Meter: 4
 
More
Quote:
Originally Posted by NMRocket

this is what I did in the mean time.

I saved the PROV XML file from my phone
__PROV__ATT_US_310_410_ENG.xml

and I modified with the straight talk info but i'm not sure if is ok.

__PROV__ATTS_US_310_410_ENG.xml (this is after I renamed) and I can load it from MFG app and view it in the "View current profile" just is not working.

NMRocket, I remembered your pain when I finally got MMS working today! The key was a new Provisional XML, I did have to build my own, but this one is based off of the one I found in this thread. I've attached it. It works!

MMS. 3G. Woohoo!

Going to build a full guide for the people out there searching for "lg quantum straight talk mms" (like I was a few weeks ago).
Attached Files
File Type: zip __PROV__ST_US_310_410_ENG.zip - [Click for QR Code] (1.1 KB, 253 views)
The Following User Says Thank You to time pilot aka For This Useful Post: [ View ]
27th May 2012, 05:53 PM |#24  
Account currently disabled
Miami, FloriDuh
Thanks Meter: 82
 
More
Quote:
Originally Posted by time pilot aka

NMRocket, I remembered your pain when I finally got MMS working today! The key was a new Provisional XML, I did have to build my own, but this one is based off of the one I found in this thread. I've attached it. It works!

MMS. 3G. Woohoo!

Going to build a full guide for the people out there searching for "lg quantum straight talk mms" (like I was a few weeks ago).

It works!!! Thanks for altering the xml I had for the Focus/Omnia7. With the Telstra ROM I now have the most complete device on WP7 with Straight Talk (USB tethering, Internet Sharing, unlocked with the MFG app).

This is what makes this community work, everybody freely sharing their ideas and tidbits for the benefit of all without asking for money or glory.
29th May 2012, 04:39 AM |#25  
Junior Member
Thanks Meter: 0
 
More
I'm so close
I was able to get everything done, but still no luck. I must be missing something very simple.

I put your XML file into the Windows directory using WP7 Root Tools.

Then I ran MFG, put in 310 and 410, and the XML came up in the list.

I selected it, rebooted the phone, put the APN back to att.mvno, but still no MMS - I get "can't send message - Try again.

For the record, in the select network profile, I have "AlwaysON" to on, I have tried proxy enable both on and off, and auto update on.

Any idea what I'm screwing up?
29th May 2012, 02:37 PM |#26  
Account currently disabled
Miami, FloriDuh
Thanks Meter: 82
 
More
Quote:
Originally Posted by speertp

I was able to get everything done, but still no luck. I must be missing something very simple.

I put your XML file into the Windows directory using WP7 Root Tools.

Then I ran MFG, put in 310 and 410, and the XML came up in the list.

I selected it, rebooted the phone, put the APN back to att.mvno, but still no MMS - I get "can't send message - Try again.

For the record, in the select network profile, I have "AlwaysON" to on, I have tried proxy enable both on and off, and auto update on.

Any idea what I'm screwing up?

In settings>cellular, set your APN first, then do the MFG. For some reason, that's what worked for me. After you select the ST xml BACK OUT of the MFG, do not just reboot immediately.
30th May 2012, 02:00 AM |#27  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by speertp

I was able to get everything done, but still no luck. I must be missing something very simple.

I put your XML file into the Windows directory using WP7 Root Tools.

Then I ran MFG, put in 310 and 410, and the XML came up in the list.

I selected it, rebooted the phone, put the APN back to att.mvno, but still no MMS - I get "can't send message - Try again.

For the record, in the select network profile, I have "AlwaysON" to on, I have tried proxy enable both on and off, and auto update on.

Any idea what I'm screwing up?

Well, I figured out my own problem. It was the LG Network Settings app. I had installed it at one point hoping it would help me. As soon as I uninstalled it, MMS started working.

For those noobs like me, this poorly assembled instruction list might help.

I worked so long to get MMS working (on and off for 4 months), I forget what all I had to do, but here’s what I think worked. For the record, I'm on an LG Quantum with the Telstra ROM. I'm using Straight Talk's BYOD SIM on AT&T's towers.

Install Windows Phone SDK on a PC
This will allow the install of WP7 root tools as an xap to the phone via “application deployment”
Email yourself this XML file that Time Pilot AKA has above (unzipped)

(from now on everything is done on the phone)
Download the attachment and keep it open
Switch to WP7 Root Tools
Explore to application data, volatile, email attachments, ….to find the xml file
Copy to the windows directory
Close WP7 Root Tools
Open the MFG app (I don’t remember how I got this on, so you'll have to research it yourself)
I think I might just be able to dial ##634# as a phone number to open it
The password is 277634#*#
Engineer menu
Other setting
Set network profiles
Put in 310 and 410 for MCC and MNC then find
Click on the ST xml file that you had copied into the Windows folder
I had always on on, proxy enable on, auto update on

You might have to reboot, but I think it should work. You may also have to put att.mvno in as your apn under settings, cellular.
Last edited by speertp; 1st June 2012 at 01:03 PM. Reason: Updated 6/1 to reflect proxy set to on
20th July 2012, 03:10 AM |#28  
Junior Member
Thanks Meter: 0
 
More
Thumbs up Thank you! Good guide. Worked for me!
Thank you! I really appreciate the guide. It worked fine for me.

Quote:
Originally Posted by speertp

Well, I figured out my own problem. It was the LG Network Settings app. I had installed it at one point hoping it would help me. As soon as I uninstalled it, MMS started working.

For those noobs like me, this poorly assembled instruction list might help.

I worked so long to get MMS working (on and off for 4 months), I forget what all I had to do, but here’s what I think worked. For the record, I'm on an LG Quantum with the Telstra ROM. I'm using Straight Talk's BYOD SIM on AT&T's towers.

Install Windows Phone SDK on a PC
This will allow the install of WP7 root tools as an xap to the phone via “application deployment”
Email yourself this XML file that Time Pilot AKA has above (unzipped)

(from now on everything is done on the phone)
Download the attachment and keep it open
Switch to WP7 Root Tools
Explore to application data, volatile, email attachments, ….to find the xml file
Copy to the windows directory
Close WP7 Root Tools
Open the MFG app (I don’t remember how I got this on, so you'll have to research it yourself)
I think I might just be able to dial ##634# as a phone number to open it
The password is 277634#*#
Engineer menu
Other setting
Set network profiles
Put in 310 and 410 for MCC and MNC then find
Click on the ST xml file that you had copied into the Windows folder
I had always on on, proxy enable on, auto update on

You might have to reboot, but I think it should work. You may also have to put att.mvno in as your apn under settings, cellular.

2nd August 2012, 07:14 PM |#29  
Junior Member
Thanks Meter: 0
 
More
Hello everyone, longtime fan of the XDA forums, but a frustrating issue has caused me to come out of lurking. I'm just wondering, has anyone successfully configured MMS and Internet for the LG Quantum on Simple Mobile? I just activated the phone on Simple today, and following several steps, including the OP I have used the MFG app, LG's own Network Setup app, and the Add APN option through the Windows Phone menu but can get neither Data nor MMS to work. I've used MMC 310 and MNC 260 and while I did get a T-Mobile XML file, it is still not configured properly. I have a Dell Venue Pro on Simple Mobile and, after some trial and error, MMS and Data work great, so I don't understand why the LG is being so difficult. Any help anyone can give on the subject would be greatly appreciated, as I'm currently at my wits end.
3rd October 2012, 04:49 PM |#30  
Junior Member
Thanks Meter: 0
 
More
Exclamation LG Telestra Data
Quote:
Originally Posted by fatclue

It works!!! Thanks for altering the xml I had for the Focus/Omnia7. With the Telstra ROM I now have the most complete device on WP7 with Straight Talk (USB tethering, Internet Sharing, unlocked with the MFG app).

This is what makes this community work, everybody freely sharing their ideas and tidbits for the benefit of all without asking for money or glory.

I was looking for additional help with this on the Quantum (telestra rom). I cannot seem to get my data to work even after I had copied the new XML to the windows directory and set it as the the network (shows up fine inthe query) I have also added the APN att.mvno in the cellular settings under new apn any advice?
14th July 2015, 06:35 PM |#31  
Junior Member
Thanks Meter: 0
 
More
lg quantum 900c i need help on finding my mnc doi have to tell 1where i live? please
Quote:
Originally Posted by Assault88

OK I got my LG C900 AT&T working with MMS here in New Zealand after much painstaking investigation. Here's what I did:

1. Unlock the MFG app and log in to it. (probably best to dev unlock and prevent relock here while you are at it). Details here: http://forum.xda-developers.com/show....php?t=1021636

2. Make sure you are updated to Nodo update to have the latest carrier network provider files. T-mobile users must do this otherwise the files wont be there.

3. In MFG App, Enable ADC in the "engineer menu" under "other settings"

4. go to "set network profiles", if there are no network profiles in the box on the lower half of the page then observe the 2 boxes just above it, one is called MCC and one is called MNC.

5. You need to type in the correct numbers for your provider in these boxes. I de-compiled a flash rom and found out what these all are, you can also find out what they all are by browsing the windows directory of your phone and look for the provider XML files. In the file name of the XML file for your provider should be 2 numbers like this:

__PROV__TMU_US_310_800_ENG.xml

This is a T-Mobile US network provider file. The 2 numbers are MCC: 310 and MNC: 800

There may be mulitple config files for each carrier like the T-mobile guys have a lot of XML files and I dont know which is right for each of you so you will just have to try them one by one until you find what works. T-Mobile US is always MCC: 310 but MNC is different for different areas/states I guess. Here are the numbers for T-mobile:

MCC: 310 MNC: 160
MCC: 310 MNC: 200
MCC: 310 MNC: 210
MCC: 310 MNC: 220
MCC: 310 MNC: 230
MCC: 310 MNC: 240
MCC: 310 MNC: 250
MCC: 310 MNC: 260
MCC: 310 MNC: 270
MCC: 310 MNC: 300
MCC: 310 MNC: 310
MCC: 310 MNC: 490
MCC: 310 MNC: 530
MCC: 310 MNC: 580
MCC: 310 MNC: 590
MCC: 310 MNC: 640
MCC: 310 MNC: 660
MCC: 310 MNC: 800

So after you put in the two numbers, hit find and in the below box a provider config file will come up. Select it and your phone will now switch profiles and your MMS should now work, assuming you have the right provider config file. If you need help finding the right numbers for your provider, I may be able to find them for you.

I have no idea if this works on non-LG phones using the MFG app.

Hope this helps some people get MMS working

i have tried i think all of them but i still need help!!!!!!

Read More
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes