Post Reply

[APP] 14.6 v2 SmartSync Disabler: Disable the HTC Wifi/Data sleep policy during night

OP j4n87

j4n87
13th June 2012, 04:42 PM   |  #1  
Guest
Thanks Meter: 0
 
n/a posts
Redmond pie article:

HTC One X Turning 3G & Wi-Fi Off Overnight? A Fix Is Now In The Play Store


thanks to Oliver Haslam




Hi guys,


I found a solution for the HTC SmartSync Powersaving issue and provide here a simple app to disable this HTC feature..and the cool thing is:

It works for LOCKED devices without root too!


It should be compatible with each Sense 4.0 device and Sense 4.0 port.



What's this HTC SmartSync Powersaving issue?:


HTC introduced SmartSync with Sense ICS (all devices), which shall provide you the best battery life for your device.
Unfortunatly HTC messed it up again, because theres no interface to control this powersaving feature.
Isn't a problem you think? It is, and I tell you why:

HTC SmartSync system forces the wifi and data connections to go do sleep/disconnect after 15 minutes screen off time between 00:00 and 07:00 am.
For some this isnt an issue and can ignore this thread, but for some it is important to have a constant data/wifi connection during night.

The issue is disussed here in over 40 pages: wifi goes sleep even setting policy to "Always On"

Some people contacted HTC and HTC confirmed this "issue"...they call it more a feature to save battery during night and didnt make a statement if this "bug" will be fixed in the future.

mikeyxda posted a solution to this problem here, but its quite a dirty hack. To accomplish this you also need some basic knowledge with apktool. For me it causes issues with Exchange syncing as well.
But the biggest disadvantage with this solutution is, that you have to be rootet.




Some smali code which shows the issue (for experienced users):



Here you can see the timespan from 00:00 to 07:00 where the SmartSync to turn of data/wifi gets disabled


constructor of SmartSyncScreenOnOffTimeReceiver.smali


Code:
   const/4 v2, 0x0 ----> Stands for 00:00

    ....

    sput v1, Lcom/android/settings/framework/activity/powersaver/SmartSyncScreenOnOffTimeReceiver;->USERNIGHT_TIMESTART:I

    const/4 v2, 0x7 ----> Stands for 07:00

    sput v2, Lcom/android/settings/framework/activity/powersaver/SmartSyncScreenOnOffTimeReceiver;->USERNIGHT_TIMEEND:I
You see that this values are hardcoded which wouldnt allow a configuration...if an interface to it would exist, of course.
...theres lots more code I could show, but most of the users wouldnt have use for it =P.


I spent some hours to backtrace the the issue to find a cleaner solution than mikeyxda found. But thanks to him I got a point to start with
and found a cleaner solution...well even the possibility to provide this fix for none unlocked/rooted users.




How to test this issue immediatly:

  • Turn your wifi on
  • Go into Settings->Date and Time: Uncheck automatic date and time
  • Set the time to 00:00
  • Turn your screen off and let it off for 20 minutes
  • after >20 minutes turn your device on and see if your wifi/data is still connected.

-> You should see that you havent any data/wifi connection and wifi reconnects few seconds later
And this behaviour repeats each day during 00:00 and 07:00am.



Now do the similar steps again just
  • Start my app
  • Check the checkbox "Disable smartsync"
  • REBOOT
  • Turn your wifi on
  • Go into Settings->Date and Time: Uncheck automatic date and time
  • Set the time to 00:00
  • Turn your screen off and let it off for 20 minutes
  • after >20 minutes turn your device on and see if your wifi/data is still connected.


-> You should see that your wifi is still connected!



Disclaimer:

I tried to fix what HTC borked..but I'm not responsible if your data connection still disconnects and you miss important mails etc.
The app is properly testet and I got several reports that its working though.
Last edited by j4n87; 17th June 2012 at 11:30 AM.
The Following 68 Users Say Thank You to For This Useful Post: [ View ]
j4n87
13th June 2012, 09:39 PM   |  #2  
Guest
Thanks Meter: 0
 
n/a posts
Download:

Free version:

SmartSync Disabler

Donate version:


SmartSync Disabler Donate
Last edited by j4n87; 22nd June 2012 at 05:09 PM.
The Following 17 Users Say Thank You to For This Useful Post: [ View ]
13th June 2012, 09:42 PM   |  #3  
gpz1100's Avatar
Senior Member
Thanks Meter: 284
 
2,055 posts
Join Date:Joined: Nov 2009
j4n87, Thanks for the fix. Can you expand on how your fix differs?

Thanks!
The Following 2 Users Say Thank You to gpz1100 For This Useful Post: [ View ]
13th June 2012, 10:02 PM   |  #4  
H-KaN's Avatar
Senior Member
Flag Goslar
Thanks Meter: 136
 
608 posts
Join Date:Joined: Dec 2010
More
Im going to test it tonight and will report if it works. My Phone is completely stock, no root, nothing.

----------------------------------------------------

Edit: Not working for me.
Last edited by H-KaN; 14th June 2012 at 12:17 AM.
The Following User Says Thank You to H-KaN For This Useful Post: [ View ]
13th June 2012, 10:54 PM   |  #5  
Junior Member
Thanks Meter: 3
 
14 posts
Join Date:Joined: Apr 2012
Yes, I confirm this app works on locked non-rooted HOX 100% as described.

Thank you very much.
13th June 2012, 11:06 PM   |  #6  
Sergy330's Avatar
Member
Flag ///Madrid
Thanks Meter: 1
 
78 posts
Join Date:Joined: Aug 2008
I was testing the app this afternoon and works great!

Problem solved by j4n87

thx mate!
13th June 2012, 11:12 PM   |  #7  
Account currently disabled
Thanks Meter: 269
 
1,586 posts
Join Date:Joined: Oct 2011
It's fantastic, thanks man.
13th June 2012, 11:31 PM   |  #8  
modplan's Avatar
Senior Member
Thanks Meter: 35
 
136 posts
Join Date:Joined: Jun 2010
Awesome thanks!

Any way you could provide a Tasker/Locale plugin with this app, maybe a donate version that has this? (or a way to toggle it via command line, there is already a plugin to run commands)

I'd like to disable SmartSync when I'm at home (or charging) but re-enable it if I'm staying with a friend or something so my battery will last all night.
13th June 2012, 11:34 PM   |  #9  
Senior Member
Flag Hampton
Thanks Meter: 1,213
 
2,310 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by modplan

Awesome thanks!

Any way you could provide a Tasker/Locale plugin with this app, maybe a donate version that has this? (or a way to toggle it via command line, there is already a plugin to run commands)

I'd like to disable SmartSync when I'm at home (or charging) but re-enable it if I'm staying with a friend or something so my battery will last all night.

You could just set up profiles to turn off the data and wifi at particular times and location

Sent from my HTC One X using xda premium
13th June 2012, 11:36 PM   |  #10  
modplan's Avatar
Senior Member
Thanks Meter: 35
 
136 posts
Join Date:Joined: Jun 2010
I've already done that, but even with wifi on at night, SmartSync will disconnect it after 20 mins of screen off. I backup my sdcard to my home server nightly, and backups are failing because of SmartSync, even with wifi turned on.

Post Reply Subscribe to Thread

Tags
trolls
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in One X Themes and Apps by ThreadRank