Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Proximity Sensor Issues- Samsung Focus

OP Slowestofthepokes

24th December 2011, 08:41 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2011
Hello all.

I have a Samsung focus with an "always on" proximity sensor. So the phone does not light up after it has moved away from ones face during a phone call, making it impossible to use after any call without a restart.

I have tried the following solutions.

1- Soft Reset by pulling the battery and waiting
2- Hard reset using numeric codes provided in the ref threads
3- Using the diagnostic menu.

With regards to the third one. The proximity sensor menu shows that the sensor is always "on" no matter where the phone is. But there is no "set" or "reg' button that I can find with which to recalibrate it, the only option is "exit"

It is quite possible that I am missing a feature or function or I need a new solution. If anyone has any insight that would be really helpful.

Thank you in advance.
11th February 2012, 01:04 AM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2012
Same
I have exactly the same problem. Did you solve it ?
19th February 2012, 05:26 AM   |  #3  
Senior Member
Flag Chicago
Thanks Meter: 14
 
248 posts
Join Date:Joined: May 2009
More
You will need to give a little more information. What os version are you running and what diagnostic app are you running. I think the most up to date diagnostic app is ver(.0103).

1. uninstall your diagnostic app
2. install the diagnostic app again to get latest app ##634#
3. open the diagnostic app and type *#0*#
4. tap the proximity sensor button and see if you see set reg and exit soft keys
3rd July 2012, 10:35 PM   |  #4  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2012
Unhappy Issue with proximity sensor in Samsung focus sgh i917
I have the same problem. My LED screen broke recently and replaced it.

It looks like after the screen replacement, the phone's proximity sensor is always in detected mode [in the diag]. So when ever a phone is made or answered the LED screen goes blank disabling all functionality till the other person disconnects.
I ran the diag but it doesn't give me an option to calibrate the sensor. I tried to install the latest diag tool too but same results. There is only one button, "EXIT".

The diagnostic app version is .0628
OS version is 7.10.7720.68
Please help.
Last edited by kiran.adoor; 3rd July 2012 at 10:41 PM. Reason: to include OS and diag tool version
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes