FORUMS

Swappa’s New App Helps You Value Your Device

There comes a sad time in everyone’s life where you must part ways with your … more

Xiaomi Sold 34.7 Million Phones In 6 Months

2015 has been a phenomenal year for Xiaomi so far. With a stellar rise in 2014, 2015 saw … more

Sprint Reacts To Jab From T-Mobile

America’s cellular network space has always been a battle of the big four: Verizon, AT&T, … more

Floating Apps with Rovers – XDA App Review

There are a lot of great launchers to help customize your phone. Some Launchers allow … more

MTD issues

229 posts
Thanks Meter: 36
 
By klloyd, Senior Member on 11th September 2012, 01:43 AM
Post Reply Subscribe to Thread Email Thread
Ok, EVERY ics or above rom wipes my imei and renders the phone useless. I'm not a noob by any means, I follow the directions to the letter, and the imei number is toast EVERY time! I even backed it up, restored it... but it still shows just a bunch of stars. What in the world am I doing wrong?
The trouble started when I flashed the a mtd jb rom. I restored from the backup, got data back, but phone had no sound during calls. I had to go back to stock via a one click to restore the imei number. I was running jb right up until the mtd change. Now, I can't run ANYTHING, CM7 or above. No matter how or what I flash, it wipes the imei
I've been working on this for a week now, can't figure out what I'm doing wrong. I'm lost and back to gingerbread until I figure something out. Any help would be greatly appreciated.
 
 
11th September 2012, 02:29 AM |#2  
psal217050's Avatar
Senior Member
Flag Central PA
Thanks Meter: 326
 
More
Quote:
Originally Posted by klloyd

Ok, EVERY ics or above rom wipes my imei and renders the phone useless. I'm not a noob by any means, I follow the directions to the letter, and the imei number is toast EVERY time! I even backed it up, restored it... but it still shows just a bunch of stars. What in the world am I doing wrong?
The trouble started when I flashed the a mtd jb rom. I restored from the backup, got data back, but phone had no sound during calls. I had to go back to stock via a one click to restore the imei number. I was running jb right up until the mtd change. Now, I can't run ANYTHING, CM7 or above. No matter how or what I flash, it wipes the imei
I've been working on this for a week now, can't figure out what I'm doing wrong. I'm lost and back to gingerbread until I figure something out. Any help would be greatly appreciated.

Just wondering. Did you back it up with the EFS in the Infuse Toolkit? According to the OP, EFS Partition Backup (protect your phone's IMEI information, find unlock info) forum.xd

http://forum.xda-developers.com/show....php?t=1702026
11th September 2012, 02:57 AM |#3  
OP Senior Member
Thanks Meter: 36
 
More
No, I used what ever the app is posted on the jb pages. Quick and simple. Makes a folder called eds backup. Inside u find a .tar file with the whole folder zipped up. I didn't find a place in the toolkit for restoring just that info. I can't even do.cm7 now, anything above gingerbread wipes the imei number, every single time.
If there were a one click to ice or jb, might would help. Beats me. I'm.completely stumped now. Never had trouble flashing anything.
11th September 2012, 03:23 AM |#4  
psal217050's Avatar
Senior Member
Flag Central PA
Thanks Meter: 326
 
More
Quote:
Originally Posted by klloyd

No, I used what ever the app is posted on the jb pages. Quick and simple. Makes a folder called eds backup. Inside u find a .tar file with the whole folder zipped up. I didn't find a place in the toolkit for restoring just that info. I can't even do.cm7 now, anything above gingerbread wipes the imei number, every single time.
If there were a one click to ice or jb, might would help. Beats me. I'm.completely stumped now. Never had trouble flashing anything.

Which JB were you trying to use? You might as well one click back to GB, try the toolkit in CWM, back up the EFS, and then flash one of the ICS ROMS. After flashing ICS ROM and before you reboot, use the toolkit to restore EFS and test it to see if it works. Not sure why it is happening with ICS but you never know what will work sometimes. That's half the fun of testing and most of the frustration of testing.
11th September 2012, 03:48 AM |#5  
OP Senior Member
Thanks Meter: 36
 
More
I know ALL about frustrating! You know, with all I've done, restoring it BEFORE I reboot on the install hasn't even entered my mind! Ill give it a shot. As for which one.... all of them of course!
Ill look closer at the toolkit, maybe it will work. Ill let you know!
11th September 2012, 03:50 AM |#6  
OvaHex's Avatar
Senior Member
Thanks Meter: 36
 
More
Quote:
Originally Posted by klloyd

I know ALL about frustrating! You know, with all I've done, restoring it BEFORE I reboot on the install hasn't even entered my mind! Ill give it a shot. As for which one.... all of them of course!
Ill look closer at the toolkit, maybe it will work. Ill let you know!

Just curious, but what version of cwm are you flashing from? It was suggested somewhere that it may depend upon if your flashing from cwm5/6 or 3/2, and I believe it may be true.


Sent from my SGH-I997 using xda app-developers app
11th September 2012, 04:12 AM |#7  
OP Senior Member
Thanks Meter: 36
 
More
OK, I've backed up the efs folder via the toolkit, BUT, nowhere.in there is there an option to restore it. I looked and looked! Whole rom,, different scripts, nothing about restoring the info u just backed up.
Now I went from red cwm to cm9, blue, early version. Everything was working fine until I switched from Scott's 8/31 build to cypher.(is that right?) Cyphers worked fine, but I've never been able to flash any other rom since, unless its a gingerbread rom. They all fail. The failures started with paranoid 2.0 9/6 build. I had no trouble until then. I've run every rom out there at one time or another, never had a moments trouble. Now on the other hand, I'm stuck!
BTW, I've even tried roms prior to mtd, still wipes the imei number. That is cm7, cm9 early versions.
11th September 2012, 06:19 AM |#8  
Senior Member
Thanks Meter: 697
 
More
Quote:
Originally Posted by klloyd

OK, I've backed up the efs folder via the toolkit, BUT, nowhere.in there is there an option to restore it. I looked and looked! Whole rom,, different scripts, nothing about restoring the info u just backed up.
Now I went from red cwm to cm9, blue, early version. Everything was working fine until I switched from Scott's 8/31 build to cypher.(is that right?) Cyphers worked fine, but I've never been able to flash any other rom since, unless its a gingerbread rom. They all fail. The failures started with paranoid 2.0 9/6 build. I had no trouble until then. I've run every rom out there at one time or another, never had a moments trouble. Now on the other hand, I'm stuck!
BTW, I've even tried roms prior to mtd, still wipes the imei number. That is cm7, cm9 early versions.

Here you go.
http://forum.xda-developers.com/show...ht=restore+efs
12th September 2012, 12:14 AM |#9  
OP Senior Member
Thanks Meter: 36
 
More
I actually did the search on here... most of which pertains to the nexus and its imei being incorrect due to a GPS file. The windows file, efspro I've found is missing files, or doesn't work in.windows 7. I've not made it to trying Odin yet, but I'm gonna try tonight. The part that is confusingbme is, why can't I flash files BEFORE mtd? Something has changed...
I've been flashing things since the very day the captivate came out, I've not had trouble till now. Maybe someone can make a heimdall one.click to jb with the new filing system...? I'd pay $20 for for one!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes