Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,161 Members 52,626 Now Online
XDA Developers Android and Mobile Development Forum

missing "system sounds"

Tip us?
 
electricpete1
Old
(Last edited by electricpete1; 14th September 2012 at 04:06 AM.)
#1  
Senior Member - OP
Thanks Meter 156
Posts: 318
Join Date: Aug 2012
Default missing "system sounds"

[Rooted UCLB3 with Zen's Infusion A kernel, voodoo sound installed]

1 - When I go to Settings / Sound / Volume I see 4 sliders (Incoming Call Volume, Media Volume, System Volume, Notification Volume).
For 3 of the 4, when I move the slider I hear a sample of the volume as expected.
But for the system volume slider, when I move it I hear nothing at all. Doesn't matter where I move it, all I hear is silence.

2 - I think I haven't been getting any audible notifications for calendar appointments lately.

Is "system volume" used for calendar appointments? For anything else? How do you set the sound associated with system volume (it's different than notification apparently).
How to get it back?
 
Ryo Misaki
Old
#2  
Ryo Misaki's Avatar
Senior Member
Thanks Meter 264
Posts: 170
Join Date: Dec 2011
Location: Wichita Falls, Texas
Quote:
Originally Posted by electricpete1 View Post
[Rooted UCLB3 with Zen's Infusion A kernel, voodoo sound installed]

1 - When I go to Settings / Sound / Volume I see 4 sliders (Incoming Call Volume, Media Volume, System Volume, Notification Volume).
For 3 of the 4, when I move the slider I hear a sample of the volume as expected.
But for the system volume slider, when I move it I hear nothing at all. Doesn't matter where I move it, all I hear is silence.

2 - I think I haven't been getting any audible notifications for calendar appointments lately.

Is "system volume" used for calendar appointments? For anything else? How do you set the sound associated with system volume (it's different than notification apparently).
How to get it back?
Is there not an "Alarm" volume on your rom?
Calendar appointments may just fall under Notifications for you.
System Volume would be those innate clicks and UI sounds when you click or open things on your phone.

If your Calendar isn't making any sounds, check the settings in your calendar app to see what notification tone you have set for your reminders, and that the notifications and reminders are enabled.

Hopefully that helps!
The Following User Says Thank You to Ryo Misaki For This Useful Post: [ Click to Expand ]
 
electricpete1
Old
(Last edited by electricpete1; 14th September 2012 at 12:24 PM.)
#3  
Senior Member - OP
Thanks Meter 156
Posts: 318
Join Date: Aug 2012
Quote:
Originally Posted by Ryo Misaki View Post
Is there not an "Alarm" volume on your rom?
Calendar appointments may just fall under Notifications for you.
System Volume would be those innate clicks and UI sounds when you click or open things on your phone.

If your Calendar isn't making any sounds, check the settings in your calendar app to see what notification tone you have set for your reminders, and that the notifications and reminders are enabled.

Hopefully that helps!
Thanks, that was very helpful.

Quote:
System Volume would be those innate clicks and UI sounds when you click or open things on your phone.
Aha, so that’s what that system volume for.
With "audible selection" disabled in settings (my original configuration), the slider does nothing.
When I enabled “audible selection” in settings, then that slider produces a click when I move it. That explains why the slider wasn’t doing anything before (audible selections was off).

I had associated this system volume slider "symptom" with lack of calendar alarms since I noticed the slider movement didn't do anything at the time I was investigating my lack of calendar alarms... but that was an incorrect conclusion on my part.

Quote:
If your Calendar isn't making any sounds, check the settings in your calendar app to see what notification tone you have set for your reminders, and that the notifications and reminders are enabled.
After your post, I just tried a special calendar appointment with alarm set manually and it did work. (stock calendar app). That’s good.

It used to be that all my appointments had alarms occuring 15 minutes ahead, alarms set automatically with no action on my part to set an alarm for individual appointments.
Now it seems like I only get alarm if I manualy set them.
My challenge has now evolved to: how do I get alarms automatically scheduled on my calendar apponitments?

The appointments I’m interested in are ones sent to my work outlook email account. I have an outlook rule which auto-forwards everything to my gmail. When my gmail receives an invite it puts it on my gmail calendar which is sync’d to my android calendar.

It used to be the case that all these appointments sounded an alarm tied to the appointment, 15 minutes ahead. Now nothing happens (unless I set an alarm manually, which I didn't have to before). I almost missed a meeting yesterday as a result.

I checked Android calendar settings, don’t see it in there.
I checked gmail settings. Don’t see it in there. Actually there is an un-used option for gmail to notify me by text message of appointments on my gmail calendar ... but the old calendar notifications didn't come on text message. So I guess I have a solution available (notify of gmail appointments by text), but I'm wondering why it doesn't work the way it used to.
Maybe it is in my outlook calendar settings... I’ll check that next and report back results...
The Following User Says Thank You to electricpete1 For This Useful Post: [ Click to Expand ]
 
electricpete1
Old
#4  
Senior Member - OP
Thanks Meter 156
Posts: 318
Join Date: Aug 2012
Default resolved (sort of)

I checked MS outlook settings. There you can set an alarm for individual item but I donít think there is a default alarm (and even if there were, itís not logical that it would be relevant to my gmail/android which only knows about the invite, not whether it was accepted in outlook).

I donít know what changed. To be honest, I donít remember ever setting up my gmail/phone to provide meeting alarms, it just started happening automatically by itself immediately after I set up the outlook rule to forward all my work emails (including meeting invitations) to my personal gmail account. But after I started getting those meeting notifications on my phone, I did grow to expect that behavior and rely on them.

To restore my meeting notifications on my phone, I have now setup gmail to provide me with SMS 15 minutes before meeting. Should get the job done, and perhaps even a little more reliable than before because I will still get the SMS even for meetings scheduled at the last minute where my phone may not have had chance to sync to my gmail yet.

So, my problem is solved by setting up a different type of notification (sms from gmail calendar). Iím not sure what changed (open to comment if anyone knows), but doesnít matter other than for general understanding.
Thanks again Ryo for helping me figure out it had nothing to do with system volume.
 
Ryo Misaki
Old
#5  
Ryo Misaki's Avatar
Senior Member
Thanks Meter 264
Posts: 170
Join Date: Dec 2011
Location: Wichita Falls, Texas
Quote:
Originally Posted by electricpete1
Thanks, that was very helpful.

Aha, so thatís what that system volume for.
With "audible selection" disabled in settings (my original configuration), the slider does nothing.
When I enabled ďaudible selectionĒ in settings, then that slider produces a click when I move it. That explains why the slider wasnít doing anything before (audible selections was off).

I had associated this system volume slider "symptom" with lack of calendar alarms since I noticed the slider movement didn't do anything at the time I was investigating my lack of calendar alarms... but that was an incorrect conclusion on my part.

After your post, I just tried a special calendar appointment with alarm set manually and it did work. (stock calendar app). Thatís good.
I'm glad that fixed things!
Yeah, I used to keep the audible selections off all the time, so system volume was pretty useless.
Also, I think "system" controls the dial pad sounds on the Dialer app, as long as you have those enabled.

Quote:
It used to be that all my appointments had alarms occuring 15 minutes ahead, alarms set automatically with no action on my part to set an alarm for individual appointments.
Now it seems like I only get alarm if I manualy set them.
My challenge has now evolved to: how do I get alarms automatically scheduled on my calendar apponitments?

The appointments Iím interested in are ones sent to my work outlook email account. I have an outlook rule which auto-forwards everything to my gmail. When my gmail receives an invite it puts it on my gmail calendar which is syncíd to my android calendar.

It used to be the case that all these appointments sounded an alarm tied to the appointment, 15 minutes ahead. Now nothing happens (unless I set an alarm manually, which I didn't have to before). I almost missed a meeting yesterday as a result.

I checked Android calendar settings, donít see it in there.
I checked gmail settings. Donít see it in there. Actually there is an un-used option for gmail to notify me by text message of appointments on my gmail calendar ... but the old calendar notifications didn't come on text message. So I guess I have a solution available (notify of gmail appointments by text), but I'm wondering why it doesn't work the way it used to.
Maybe it is in my outlook calendar settings... Iíll check that next and report back results...
You said you're running a rooted UCLB3? Is that Gingerbread Stock?
JB and ICS have a setting in the Calendar App that lets you decide the default 'reminder' time. (Which can then be tweaked when you create the actual event.)
Gingerbread or Froyo, though... I honestly can't remember too well (it's been too long ago!), but I don't think that option existed there.
I also checked the Google Calendar website settings, and there isn't a default reminder setting there either. =X

Quote:
To restore my meeting notifications on my phone, I have now setup gmail to provide me with SMS 15 minutes before meeting. Should get the job done, and perhaps even a little more reliable than before because I will still get the SMS even for meetings scheduled at the last minute where my phone may not have had chance to sync to my gmail yet.

So, my problem is solved by setting up a different type of notification (sms from gmail calendar). Iím not sure what changed (open to comment if anyone knows), but doesnít matter other than for general understanding.
Thanks again Ryo for helping me figure out it had nothing to do with system volume.
Sorry that you had to resort to such a round about method... If you can't find the setting for default reminder time, you could either change your Rom, keep with method you are using, or use a different calendar app. (When I was on Gingerbread, I found that I liked an app called Business Calendar. I'm not sure if it'll work for your needs, so you'll have to give it a try.)
The Following User Says Thank You to Ryo Misaki For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes