OnePlus 2 Forums: Discuss Everything About The OP2!

Now that the OnePlus 2 has been officially unveiled and that we have had close-up … more

Intel & Micron Announce “Revolutionary” Storage Tech

Intel & Micron have announced 3D Xpoint technology—”the … more

Google Now Interfaces With Third-Party Messaging Apps

Google has announced that Ok Google voice commands can now be used to send … more

Make Your Lockscreen More Productive With Widgets

Are you running Android Lollipop? Do you miss the ability to add widgets to your lock … more

Tizen OS Source Code Available

603 posts
Thanks Meter: 323
By contactwajeeh, Senior Member on 16th January 2012, 10:52 PM
Post Reply Subscribe to Thread Email Thread
Hey friends,

We have heard about the Tizen OS. It is yet another linux os for the mobiles & smartphones. It seems that they have released their source code over here:


and the SDK as well...

Hope to we can see this on our beloved HD2 soon.
The Following 10 Users Say Thank You to contactwajeeh For This Useful Post: [ View ]
17th January 2012, 06:45 PM |#2  
Senior Member
Flag L'Aquila, Groningen, Madrid, Bruxelles
Thanks Meter: 1,524
Donate to Me
well it's not so new, it's the fusion between, Limo, Moblin, Maemo, Meego (and i think Bada too since Samsung is heading up the project).
I think it will became the main Samsung OS.
Samsung planned 41 billion dollars for R&D this year....
19th January 2012, 02:01 PM |#3  
Junior Member
Thanks Meter: 1
I am following this thread for the past one year and I have yet to see someone post even a partially working build of maemo, meego, Limo, or Tizen as they call it these days. So here is the suggestion to all the devs who can make a build for the HD2, please make a partially working build so that someone else can improve upon it.
thanks in advance.
25th January 2012, 08:13 PM |#4  
Senior Member
Flag Merced
Thanks Meter: 20
@s8isfi I have been following for a looking time also. I gave up a long time ago I don't even know why I'm on the forum.

Sent from my Schubert using XDA Windows Phone 7 App
13th October 2012, 08:29 PM |#5  
Junior Member
Flag Chennai
Thanks Meter: 38
Thumbs up
Hi All,

I have downloaded the Tizen 1.0 ARM image from here and created new initrd.cpio and mounted all required filesystems (EXT4) to make Tizen boot from HD2. Used the kernel from here

Initially i was able to see some dialogs saying default depth should be 24 or 32. Then I configured xorg with framebuffer and with default depth as 16 as mentioned in Htc-Linux. I almost had it . Now i am stuck at black screen with a cursor displayed for long time .

I think I am missing something. This is the first time I am trying to do all this stuff. Need to go much more deep into it. I hope this should not take much time. I will try to come up with a positive status in this...


HTC HD2 - The Immortal
Last edited by diwa_sen; 13th October 2012 at 08:45 PM.
The Following 4 Users Say Thank You to diwa_sen For This Useful Post: [ View ]
14th October 2012, 07:10 PM |#6  
Senior Member
Thanks Meter: 25
You could post the files for it here so others can contribute
15th October 2012, 09:34 PM |#7  
Junior Member
Flag Chennai
Thanks Meter: 38
Sure. I will share those files asap.

Okay let me share some news on my second try on Tizen in HD2. After long struggle Tizen boot was successful till the Tizen startup animation showed up!!!

Now I could see a pop up error message (WOW! I can see a graphical content ) saying that the compositor must need 24 or 32 depth. But HD2 is configured Xorg and working fine only with 16bpp depth. So? Is it not possible to bring Tizen's UI with 16 bit depth?
Last edited by diwa_sen; 15th October 2012 at 09:36 PM.
The Following User Says Thank You to diwa_sen For This Useful Post: [ View ]
16th October 2012, 05:55 PM |#8  
Senior Member
Thanks Meter: 83
What do you mean "it works fine only with 16bpp depth"? What are the consequences of 24 or 32bpp depth?
16th October 2012, 09:04 PM |#9  
Junior Member
Flag Chennai
Thanks Meter: 38
I apologize for not being clear.

When the depth was set as 24, the graphics looked like solarized and still no UI showed up.

Then I set the depth as 16 and connected a mouse through USB Hosting. When I right click, I can see 4 buttons "Volume Up", "Volume Down", "Home" and sorry i forgot one more button's text. When I clicked Volume Up button, I was able to see a dialog with volume slider but this dialog was cropped and displayed beyond the resolution. I presume the resolution has not fixed for 480x800. I will post some pics on this later.

Need some more time for me to know about X Window system / Composite Window Manager. Info#1 Info#2
Last edited by diwa_sen; 16th October 2012 at 09:07 PM.
19th October 2012, 12:33 PM |#10  
Junior Member
Flag Chennai
Thanks Meter: 38
Tried to boot the latest image of Tizen (LINK) but it looks like DEVTMPFS is not enabled in the kernel. Tried with the latest kernel as well but unable to load /dev. Need to modify the kernel and compile it.
The Following 3 Users Say Thank You to diwa_sen For This Useful Post: [ View ]
21st October 2012, 11:44 AM |#11  
Junior Member
Flag Chennai
Thanks Meter: 38
After several tries and reworks still the screen remains black and with mouse pointer. But the mouse pointer is moving when a mouse connected to usb host and with touchscreen events as well. Anyone can suggest. Here is my xorg.config
# ------------------------------------------------------------
#Section "ServerFlags"
# Option "blank time" "0"
# Option "standby time" "0"
# Option "suspend time" "0"
# Option "off time" "0"

Section "ServerLayout"
Identifier "Builtin Default Layout"
Screen "Framebuffer"
InputDevice "htcleo-ts"

Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "true"
Mode "480x800"
DotClock 0
HTimings 480 480 480 480
VTimings 800 800 800 800
Flags "-HSync" "-VSync"

Section "Device"
Identifier "fbdev0"
Driver "fbdev"
Option "ShadowFB" "on"
Option "Rotate" "CW"
Option "RandRRotation" "on"

Section "Screen"
Identifier "Framebuffer"
Device "fbdev0"
Monitor "Monitor0"
DefaultFbBpp 32
SubSection "Display"
Depth 32
Modes "480x800"

Section "InputDevice"
Identifier "htcleo-ts"
Driver "evdev"
Option "Device" "/dev/input/event0"
# Option "InvertX"
Option "SwapAxes" "true"
# Option "Calibration" "972 4 569 15"
The Following 5 Users Say Thank You to diwa_sen For This Useful Post: [ View ]

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes