LG G3 Receives Oversharpening Fix via Modified Kernel

Nothing is perfect, as they say. No matter how alluring or seemingly perfect, … more

APKTool Updated with Android Lollipop Support

One of the beauties of Android is the level of flexibility we have over our devices. Whether … more

Lollipop Leak for Sprint Galaxy S5, TWRP for Micromax Canvas Magnus – XDA TV

Android 5.0 Lollipop has been leaked for the Sprint … more

Velocity is Like OpenTable on Steroids

We all enjoy a night out with friends or our significant other from time to time. However, there is … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Xperia X10i root problem

OP HoLfElDeR

3rd December 2012, 04:20 PM   |  #1  
HoLfElDeR's Avatar
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Dec 2012
Hi, i am newby, and i tried to root mu phone but whenever i click root in Flashtool i get this
03/003/2012 16:03:41 - INFO - <- This level is successfully initialized
03/003/2012 16:03:41 - INFO - Flashtool Version 0.9.9.0 built on 2012-11-13 22:53:30
03/003/2012 16:03:41 - INFO - You can drag and drop ftf files here to start flashing them
03/003/2012 16:03:50 - INFO - Device connected with USB debugging on
03/003/2012 16:03:51 - INFO - Connected device : X10
03/003/2012 16:03:51 - INFO - Installed version of busybox : N/A
03/003/2012 16:03:51 - INFO - Android version : 2.3.3 / kernel version : 2.6.29-00054-g5f01537 / Build number : 3.0.1.G.0.75
03/003/2012 16:03:59 - INFO - Decrypting C:\Flashtool\custom\root\ZergRush\zergrush.tar.uue .enc to C:\Flashtool\custom\root\ZergRush\zergrush.tar.uue
03/004/2012 16:04:01 - INFO - Pushing C:\Flashtool\custom\root\ZergRush\zergrush.tar.uue to /data/local/tmp
03/004/2012 16:04:01 - INFO - Pushing C:\Flashtool\.\devices\X10\busybox\1.20.0\busybox to /data/local/tmp/busybox
03/004/2012 16:04:02 - INFO - Pushing C:\Flashtool\custom\root\subin\Superuser\su to /data/local/tmp/su
03/004/2012 16:04:02 - INFO - Pushing C:\Flashtool\custom\root\subin\Superuser\Superuser .apk to /data/local/tmp/Superuser.apk
03/004/2012 16:04:03 - INFO - Running part1 of Root Exploit, please wait
03/004/2012 16:04:04 - INFO - Waiting for device. After 60secs, stop waiting will be forced
03/005/2012 16:05:06 - INFO - Forced stop waiting.
03/005/2012 16:05:06 - ERROR - The part1 exploit did not work
03/005/2012 16:05:06 - INFO - Cleaning files

and whenever ai tru superoneclick i get this
export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

/system/bin/su: No such file or directory

END:23415export PS1=""



chmod 755 /data/local/tmp/busybox > /data/local/tmp/output 2>&1

export TEMPRANDOM=71628

export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

export TEMPRANDOM=71628

export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

END:71628export PS1=""



/data/local/tmp/busybox whoami > /data/local/tmp/output 2>&1

export TEMPRANDOM=50170

export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

whoami: unknown uid 2000

END:50170export PS1=""



rm /data/local/tmp/boomsh > /data/local/tmp/output 2>&1

export TEMPRANDOM=41351

export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

rm failed for /data/local/tmp/boomsh, No such file or directory

END:41351export PS1=""



rm /data/local/tmp/sh > /data/local/tmp/output 2>&1

export TEMPRANDOM=17806

export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

rm failed for /data/local/tmp/sh, No such file or directory

END:17806export PS1=""



chmod 700 /data/local/tmp/zergRush > /data/local/tmp/output 2>&1

export TEMPRANDOM=63106

export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

Unable to chmod /data/local/tmp/zergRush: No such file or directory

END:63106export PS1=""



cd /data/local/tmp/ > /data/local/tmp/output 2>&1

export TEMPRANDOM=77310

export PS1=END:$TEMPRANDOM;cat /data/local/tmp/output

END:77310export PS1=""





export TEMPRANDOM=22364;export PS1=END:$TEMPRANDOM;./zergRush

./zergRush: not found

END:22364export PS1=""



Can anyone help me
3rd December 2012, 08:01 PM   |  #2  
HoLfElDeR's Avatar
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Dec 2012
bump
3rd December 2012, 09:33 PM   |  #3  
Junior Member
Thanks Meter: 1
 
15 posts
Join Date:Joined: Sep 2010
I had that problem too. I search thru the forums..
here is solution : http://forum.xda-developers.com/show...postcount=1854
3rd December 2012, 10:12 PM   |  #4  
HoLfElDeR's Avatar
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by luwang

I had that problem too. I search thru the forums..
here is solution : http://forum.xda-developers.com/show...postcount=1854

Thanks for help, but i am still geting this:
03/008/2012 22:08:08 - INFO - <- This level is successfully initialized
03/008/2012 22:08:09 - INFO - Flashtool Version 0.9.9.0 built on 2012-11-21 23:15:59
03/008/2012 22:08:09 - INFO - You can drag and drop ftf files here to start flashing them
03/008/2012 22:08:17 - INFO - Device disconnected
03/010/2012 22:10:16 - INFO - Device connected with USB debugging off
03/010/2012 22:10:16 - INFO - For 2011 devices line, be sure you are not in MTP mode
03/010/2012 22:10:17 - INFO - Device connected with USB debugging on
03/010/2012 22:10:19 - INFO - Connected device : X10
03/010/2012 22:10:19 - INFO - Installed version of busybox : N/A
03/010/2012 22:10:19 - INFO - Android version : 2.3.3 / kernel version : 2.6.29-00054-g5f01537 / Build number : 3.0.1.G.0.75
03/010/2012 22:10:28 - INFO - Decrypting C:\Flashtool\custom\root\ZergRush\zergrush.tar.uue .enc to C:\Flashtool\custom\root\ZergRush\zergrush.tar.uue
03/010/2012 22:10:29 - INFO - Pushing C:\Flashtool\custom\root\ZergRush\zergrush.tar.uue to /data/local/tmp
03/010/2012 22:10:29 - INFO - Pushing C:\Flashtool\.\devices\X10\busybox\1.20.2\busybox to /data/local/tmp/busybox
03/010/2012 22:10:30 - INFO - Pushing C:\Flashtool\custom\root\subin\Superuser\su to /data/local/tmp/su
03/010/2012 22:10:30 - INFO - Pushing C:\Flashtool\custom\root\subin\Superuser\Superuser .apk to /data/local/tmp/Superuser.apk
03/010/2012 22:10:31 - INFO - Running part1 of Root Exploit, please wait
03/010/2012 22:10:31 - INFO - Waiting for device. After 60secs, stop waiting will be forced
03/011/2012 22:11:36 - INFO - Forced stop waiting.
03/011/2012 22:11:36 - ERROR - The part1 exploit did not work
03/011/2012 22:11:36 - INFO - Cleaning files
4th December 2012, 09:36 AM   |  #5  
brenty108's Avatar
Senior Member
Flag santa flora
Thanks Meter: 235
 
878 posts
Join Date:Joined: Jan 2011
Donate to Me
MAke sure you have the latest flash tools.

Sent from my Xperia X10 using xda app-developers app
4th December 2012, 10:40 AM   |  #6  
HoLfElDeR's Avatar
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by brenty108

MAke sure you have the latest flash tools.

Sent from my Xperia X10 using xda app-developers app

I have the latest flash tools, but still it won't work, i tried with luwang solution and still doesent work
Last edited by HoLfElDeR; 4th December 2012 at 10:48 AM.
4th December 2012, 11:25 AM   |  #7  
teddymild's Avatar
Senior Member
Thanks Meter: 65
 
472 posts
Join Date:Joined: Nov 2010
Deleted
5th December 2012, 07:59 AM   |  #8  
Junior Member
Thanks Meter: 1
 
15 posts
Join Date:Joined: Sep 2010
Quote:
Originally Posted by HoLfElDeR

I have the latest flash tools, but still it won't work, i tried with luwang solution and still doesent work

Did you download that rar and extract and replace the content in your flashtool?
Try redownloading the flashtool again and extract and replace those contents in that link i sent you.
5th December 2012, 11:07 AM   |  #9  
HoLfElDeR's Avatar
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by luwang

Did you download that rar and extract and replace the content in your flashtool?
Try redownloading the flashtool again and extract and replace those contents in that link i sent you.

Yes i extracted the rar files in flashtools, and i am still getting the error ERROR - The part1 exploit did not work, i tried several times.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes