Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,414 Members 53,478 Now Online
XDA Developers Android and Mobile Development Forum

format 64GB micro SD card to fat32

Tip us?
 
rdefranx
Old
#21  
Member
Thanks Meter 2
Posts: 57
Join Date: Apr 2008
Location: Bronx
Quote:
Originally Posted by isoul View Post
Try to get another recovery like twrp, it let's you use your external sd.

Sent from my SAMSUNG-SGH-T989 using xda premium
Thanks but I installed twrp and same thing, it won't let me to mount the external sd card. I am using Jelly bean and external sd card shows as \storage\extsdcard.
 
wslytoy
Old
#22  
Member
Thanks Meter 2
Posts: 61
Join Date: Jan 2011
Location: Mississippi
Default 64GB SD card errors.

Ok, 1st, I wanna say thanks for posting this info... I was completely lost as to why my SGS3 wouldn't recognize my new SanDisk Ultra 64GB SD card. Now, I have a massive problem. I formatted it to fat32, I loaded about 26GB worth of music, movies, pics, nandroid back ups and a few other things that were on my 16GB Samsung SD card. As soon as I installed it, my phone completely bogged down. It literally took me 4 minutes to type a text message b/c it was so slow. I pulled the 64GB card out, it ran like a top. I put the card back in, it gives me the error message saying it is damaged and needs to be formatted. I pull the card out again, re-insert it, it mounts fine, but it is slow as hell again. Any ideas as to what the problem may be? BTW, I'm running AOKP on my phone. My buddy is running the same build, same SD card, no problems at all. Thanks!
 
yamaha_wins
Old
(Last edited by yamaha_wins; 7th December 2012 at 05:16 AM.)
#23  
yamaha_wins's Avatar
Senior Member
Thanks Meter 7
Posts: 190
Join Date: May 2012
crazy.. same here, But im using a verizon s3, the new kern that came with the rom update dosent support exfat.. so I decided to format the card to the fat32, placed it in the phone, says card is damaged must format. so here I am still the same issue.

But this is about the best info ive found. that worked for myself.

http://www.simonjstuart.com/2012/07/...using-your-pc/
 
BACARDILIMON
Old
#24  
BACARDILIMON's Avatar
Senior Member
Thanks Meter 662
Posts: 2,312
Join Date: Jun 2010
Location: MASTIC BEACH NY
I have the same class 10 64gb and it worked perfectly. I had to do nothing. I think it depends on rom
NOTE 3 TWEAKED
 
Percy Dolarhyde
Old
#25  
Junior Member
Thanks Meter 2
Posts: 5
Join Date: Dec 2011
Location: Khon Kaen
Default SDXC vs. SDHC

Quote:
Originally Posted by dladz View Post
I have followed the tutorial and have formatted it, but windows still reports a size of 27.4GB which would mean 32GB.

I have a class 10 64GB card, i can format it in exfat no problem, just not fat32.

Any ideas?
Yes. This is a problem with the Card Reader you're using. 64GB cards are SDXC. Cards that are sized up to 32GB are generally SDHC Using an SDHC card reader with a 64GB (SDXC) card will show the incorrect 27.4GB capacity.

Look carefully for a card reader that has the SDXC logo and it should recognize it properly.

-the voice of experience.-
The Following User Says Thank You to Percy Dolarhyde For This Useful Post: [ Click to Expand ]
 
jesusprice
Old
#26  
Member
Thanks Meter 0
Posts: 50
Join Date: Nov 2009
Well I have the 64gb card and formatting to Fat32 worked like a charm

Sent from my SGH-T989 using xda premium
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes