FORUMS

Top Forum Discussions

Porting boot2gecko to AT&T GS3

528 posts
Thanks Meter: 608
 
Post Reply Subscribe to Thread Email Thread
Im trying to port boot2gecko to the at&t gs3.
Im using the cm9 kernel, and it gives me the bootloader, the screen goes black for about 10 seconds, then it starts bootlooping.
Here is my boot.img:
http://d-h.st/OyG

anyone have any ideas?
ill upload my system.img if anyone needs it
 
 
4th January 2013, 08:29 PM |#2  
Quote:
Originally Posted by cpu999

Im trying to port boot2gecko to the at&t gs3.
Im using the cm9 kernel, and it gives me the bootloader, the screen goes black for about 10 seconds, then it starts bootlooping.
Here is my boot.img:
http://d-h.st/OyG

anyone have any ideas?
ill upload my system.img if anyone needs it

are you building this from source?
i spent a bunch of time messing with this at one point, gave up after a bit
was hoping they'd rebase on 4.1 but it didn't seem to be in their agenda
4th January 2013, 11:51 PM |#3  
OP Senior Member
Thanks Meter: 608
 
Donate to Me
More
Quote:
Originally Posted by invisiblek

are you building this from source?
i spent a bunch of time messing with this at one point, gave up after a bit
was hoping they'd rebase on 4.1 but it didn't seem to be in their agenda

Yup its built from source.
I think there's something wrong with the ramdisk cuz im using the cm ICS one

Sent from my SGH-I747 using Tapatalk 2
7th January 2013, 01:07 PM |#4  
Quote:
Originally Posted by cpu999

Yup its built from source.
I think there's something wrong with the ramdisk cuz im using the cm ICS one

Sent from my SGH-I747 using Tapatalk 2

Yea, that probably isn't going to work. You'd need to hack up a working ramdisk (assuming b2g doesn't create one for you) from like the gnex or something.
8th January 2013, 11:32 PM |#5  
luismanson's Avatar
Senior Member
Flag Rosario
Thanks Meter: 20
 
Donate to Me
More
sorry if this is a noob post here, but did you try to boot it with the siyah kernel first? its what they are using on the S2 dual boot setup
9th January 2013, 03:27 AM |#6  
OP Senior Member
Thanks Meter: 608
 
Donate to Me
More
Quote:
Originally Posted by luismanson

sorry if this is a noob post here, but did you try to boot it with the siyah kernel first? its what they are using on the S2 dual boot setup

Im using a us gs3...
No siyah for me
And it wont work anyway

Sent from my SGH-I747 using Tapatalk 2
4th February 2013, 03:38 AM |#8  
T-Macgnolia's Avatar
Senior Member
Flag Shannon, Ms.
Thanks Meter: 1,917
 
Donate to Me
More
Ok I messed around with this for my last device the HTC Sensation. I noticed that the OP cpu999 said he thought it was something in the ramdisk. I know you may be following these instructions already. But have you rebuilt the boot.img per the instructions here. Also I this is my first Samsung device so I have a lot to learn about working with them so if I made any errors in this post please over look them.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes