Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD

OP Entropy512

redherring79
12th February 2013, 01:32 PM   |  #2961  
Guest
Thanks Meter: 0
 
n/a posts
Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD
Quote:
Originally Posted by DefTaker

Dunno about alarms since I don't use my phone for that but I did notice that Android Beam isn't working. Not only is it not working (tried to send my wife a pic from my gallery and it acted like it went through but she ended up receiving a notification saying that Android Beam was not received) but it's also turning on my bluetooth instead!

This is from the latest nightly, 2/11.

Pretty sure Beam has always turned on Bluetooth for image transfers. I think that's how it works.

Sent from my SGH-I777 using Tapatalk 2
Last edited by redherring79; 12th February 2013 at 01:34 PM.
12th February 2013, 02:52 PM   |  #2962  
Senior Member
Thanks Meter: 39
 
324 posts
Join Date:Joined: Jun 2009
More
Quote:
Originally Posted by redherring79

Pretty sure Beam has always turned on Bluetooth for image transfers. I think that's how it works.

Sent from my SGH-I777 using Tapatalk 2

No, beam doesn't use BT (it't never turned on my BT before either). It's NFC. One of the few NFC features that actually works on this phone since NFC is heavily crippled on our hardware (DAMN u Samsung!).

Oh well, will flash the latest nightly to see if it's been fixed. I know that 2/11's had an update so I'm wondering if that may have accidentally created the bug. Will test today's latest nightly build and will report back. If that doesn't work I'll have to try a full wipe and reflash.
12th February 2013, 02:56 PM   |  #2963  
Senior Member
Flag Atlanta, GA
Thanks Meter: 86
 
333 posts
Join Date:Joined: Feb 2012
More
Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD
Quote:
Originally Posted by DefTaker

No, beam doesn't use BT (it't never turned on my BT before either). It's NFC. One of the few NFC features that actually works on this phone since NFC is heavily crippled on our hardware (DAMN u Samsung!).

Oh well, will flash the latest nightly to see if it's been fixed. I know that 2/11's had an update so I'm wondering if that may have accidentally created the bug. Will test today's latest nightly build and will report back. If that doesn't work I'll have to try a full wipe and reflash.

It first uses NFC to get a connection then uses BT to actually make the transfer. It has ALWAYS done that for me. Just transfered a pic to my wife's s2 and my n10, both ended up using BT, like always

Sent from my SGH-i777 using xda app-developers app
12th February 2013, 03:05 PM   |  #2964  
Senior Member
Thanks Meter: 39
 
324 posts
Join Date:Joined: Jun 2009
More
Quote:
Originally Posted by jrod091

It first uses NFC to get a connection then uses BT to actually make the transfer. It has ALWAYS done that for me. Just transfered a pic to my wife's s2 and my n10, both ended up using BT, like always

Sent from my SGH-i777 using xda app-developers app

Really? Didn't know that. But it's never left my BT on, if that's the case. I have always BT OFF and last night was the first time when using Beam, that the file did NOT transfer and it left BT ON on my phone.

I didn't upgrade my wife's i777 and hers was working fine (she's on build 2/08) and does not trigger BT to stay ON.
12th February 2013, 03:17 PM   |  #2965  
Senior Member
Flag Atlanta, GA
Thanks Meter: 86
 
333 posts
Join Date:Joined: Feb 2012
More
Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD
Quote:
Originally Posted by DefTaker

Really? Didn't know that. But it's never left my BT on, if that's the case. I have always BT OFF and last night was the first time when using Beam, that the file did NOT transfer and it left BT ON on my phone.

I didn't upgrade my wife's i777 and hers was working fine (she's on build 2/08) and does not trigger BT to stay ON.

Oh, I see what you're saying now, no, it shouldn't leave it on, it should just trigger it on fur the target then turn back off when the transfer is compete, I believe

Sent from my SGH-i777 using xda app-developers app
13th February 2013, 02:12 AM   |  #2966  
Senior Member
Thanks Meter: 39
 
324 posts
Join Date:Joined: Jun 2009
More
Quote:
Originally Posted by jrod091

Oh, I see what you're saying now, no, it shouldn't leave it on, it should just trigger it on fur the target then turn back off when the transfer is compete, I believe

Sent from my SGH-i777 using xda app-developers app

No worries, flashed today's nightly and 2/12 seems to have fixed it.
13th February 2013, 11:21 PM   |  #2967  
thedude420's Avatar
Senior Member
Flag Nixa, MO
Thanks Meter: 66
 
270 posts
Join Date:Joined: Dec 2010
More
Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD
Leaving my WiFi on zaps the crap out of my battery. This normal behavior at this stage or is it just mine?
14th February 2013, 12:26 AM   |  #2968  
msgfromside3's Avatar
Senior Member
Thanks Meter: 120
 
679 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by thedude420

Leaving my WiFi on zaps the crap out of my battery. This normal behavior at this stage or is it just mine?

That has been normal behavior of almost anything for last couple of years because it is trying to scan for available wifi (guess what happens then?). I am not sure if it is still true, but you are supposed to be able to tweak the rescan interval from build.prop. I haven't done that for ages and I now turn my wifi off as soon as I get in my car.
14th February 2013, 01:33 AM   |  #2969  
Phalanx7621's Avatar
Senior Member
Flag Delaware
Thanks Meter: 2,047
 
4,452 posts
Join Date:Joined: Jul 2011
More
Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD
Yeah you can set your Wi-Fi scan interval to a higher amount to lessen the battery drain, as stated above in your build.prop, or just turn it off when not in use. I normally turn it off.
14th February 2013, 02:23 AM   |  #2970  
thedude420's Avatar
Senior Member
Flag Nixa, MO
Thanks Meter: 66
 
270 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by msgfromside3

That has been normal behavior of almost anything for last couple of years because it is trying to scan for available wifi (guess what happens then?). I am not sure if it is still true, but you are supposed to be able to tweak the rescan interval from build.prop. I haven't done that for ages and I now turn my wifi off as soon as I get in my car.

Quote:
Originally Posted by Phalanx7621

Yeah you can set your Wi-Fi scan interval to a higher amount to lessen the battery drain, as stated above in your build.prop, or just turn it off when not in use. I normally turn it off.

Got ya. Thanks guys

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes