Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,011 Members 47,656 Now Online
XDA Developers Android and Mobile Development Forum

[Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD

Tip us?
redherring79 Old
(Last edited by redherring79; 12th February 2013 at 12:34 PM.)
#2961  
Guest
Thanks Meter 0
Posts: n/a
Default Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD

Quote:
Originally Posted by DefTaker View Post
Dunno about alarms since I don't use my phone for that but I did notice that Android Beam isn't working. Not only is it not working (tried to send my wife a pic from my gallery and it acted like it went through but she ended up receiving a notification saying that Android Beam was not received) but it's also turning on my bluetooth instead!

This is from the latest nightly, 2/11.
Pretty sure Beam has always turned on Bluetooth for image transfers. I think that's how it works.

Sent from my SGH-I777 using Tapatalk 2
 
DefTaker
Old
#2962  
Senior Member
Thanks Meter 39
Posts: 324
Join Date: Jun 2009
Quote:
Originally Posted by redherring79 View Post
Pretty sure Beam has always turned on Bluetooth for image transfers. I think that's how it works.

Sent from my SGH-I777 using Tapatalk 2
No, beam doesn't use BT (it't never turned on my BT before either). It's NFC. One of the few NFC features that actually works on this phone since NFC is heavily crippled on our hardware (DAMN u Samsung!).

Oh well, will flash the latest nightly to see if it's been fixed. I know that 2/11's had an update so I'm wondering if that may have accidentally created the bug. Will test today's latest nightly build and will report back. If that doesn't work I'll have to try a full wipe and reflash.
Phone: Nexus 5
Tablet: Nexus 7 (2013)
 
jrod091
Old
#2963  
Senior Member
Thanks Meter 74
Posts: 320
Join Date: Feb 2012
Location: Atlanta, GA
Default Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD

Quote:
Originally Posted by DefTaker View Post
No, beam doesn't use BT (it't never turned on my BT before either). It's NFC. One of the few NFC features that actually works on this phone since NFC is heavily crippled on our hardware (DAMN u Samsung!).

Oh well, will flash the latest nightly to see if it's been fixed. I know that 2/11's had an update so I'm wondering if that may have accidentally created the bug. Will test today's latest nightly build and will report back. If that doesn't work I'll have to try a full wipe and reflash.
It first uses NFC to get a connection then uses BT to actually make the transfer. It has ALWAYS done that for me. Just transfered a pic to my wife's s2 and my n10, both ended up using BT, like always

Sent from my SGH-i777 using xda app-developers app
Phone:
Samsung Galaxy S4
ROM: Latest AOKP by Task650
Kernel: Latest KT-SGS4 by Ktoonsez

Tablet:
Google Nexus 10
ROM: Latest AOKP by Task650
Kernel:Latest KTManta by Ktoonsez

Barnes and Noble NookColor
ROM: Dual-boot CM9/stock
Kernel: stock
 
DefTaker
Old
#2964  
Senior Member
Thanks Meter 39
Posts: 324
Join Date: Jun 2009
Quote:
Originally Posted by jrod091 View Post
It first uses NFC to get a connection then uses BT to actually make the transfer. It has ALWAYS done that for me. Just transfered a pic to my wife's s2 and my n10, both ended up using BT, like always

Sent from my SGH-i777 using xda app-developers app
Really? Didn't know that. But it's never left my BT on, if that's the case. I have always BT OFF and last night was the first time when using Beam, that the file did NOT transfer and it left BT ON on my phone.

I didn't upgrade my wife's i777 and hers was working fine (she's on build 2/08) and does not trigger BT to stay ON.
Phone: Nexus 5
Tablet: Nexus 7 (2013)
 
jrod091
Old
#2965  
Senior Member
Thanks Meter 74
Posts: 320
Join Date: Feb 2012
Location: Atlanta, GA
Default Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD

Quote:
Originally Posted by DefTaker View Post
Really? Didn't know that. But it's never left my BT on, if that's the case. I have always BT OFF and last night was the first time when using Beam, that the file did NOT transfer and it left BT ON on my phone.

I didn't upgrade my wife's i777 and hers was working fine (she's on build 2/08) and does not trigger BT to stay ON.
Oh, I see what you're saying now, no, it shouldn't leave it on, it should just trigger it on fur the target then turn back off when the transfer is compete, I believe

Sent from my SGH-i777 using xda app-developers app
Phone:
Samsung Galaxy S4
ROM: Latest AOKP by Task650
Kernel: Latest KT-SGS4 by Ktoonsez

Tablet:
Google Nexus 10
ROM: Latest AOKP by Task650
Kernel:Latest KTManta by Ktoonsez

Barnes and Noble NookColor
ROM: Dual-boot CM9/stock
Kernel: stock
 
DefTaker
Old
#2966  
Senior Member
Thanks Meter 39
Posts: 324
Join Date: Jun 2009
Quote:
Originally Posted by jrod091 View Post
Oh, I see what you're saying now, no, it shouldn't leave it on, it should just trigger it on fur the target then turn back off when the transfer is compete, I believe

Sent from my SGH-i777 using xda app-developers app
No worries, flashed today's nightly and 2/12 seems to have fixed it.
Phone: Nexus 5
Tablet: Nexus 7 (2013)
 
thedude420
Old
#2967  
thedude420's Avatar
Senior Member
Thanks Meter 64
Posts: 261
Join Date: Dec 2010
Location: Springfield, MO
Default Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD

Leaving my WiFi on zaps the crap out of my battery. This normal behavior at this stage or is it just mine?
 
msgfromside3
Old
#2968  
msgfromside3's Avatar
Senior Member
Thanks Meter 115
Posts: 645
Join Date: Nov 2010
Quote:
Originally Posted by thedude420 View Post
Leaving my WiFi on zaps the crap out of my battery. This normal behavior at this stage or is it just mine?
That has been normal behavior of almost anything for last couple of years because it is trying to scan for available wifi (guess what happens then?). I am not sure if it is still true, but you are supposed to be able to tweak the rescan interval from build.prop. I haven't done that for ages and I now turn my wifi off as soon as I get in my car.


RTFM Before Asking and Whining
Disable Location Reporting to minimize NlpWakeLock and NlpLocationLocator wakelocks.
Nexus 5 [TMO]: Stock + Root + Franco Kernel
Samsung Galaxy S2 [ATT]: CM10.2
Samsung Galaxy Tab [TMO]: CM9

 
Phalanx7621
Old
#2969  
Phalanx7621's Avatar
Senior Member
Thanks Meter 2,047
Posts: 4,452
Join Date: Jul 2011
Location: Delaware
Default Re: [Firmware][SGH-I777][JB][4.1.1] CyanogenMod 10 preview | USER THREAD

Yeah you can set your Wi-Fi scan interval to a higher amount to lessen the battery drain, as stated above in your build.prop, or just turn it off when not in use. I normally turn it off.

Phones: Samsung Galaxy S II, Motorola Atrix[retired]
 
thedude420
Old
#2970  
thedude420's Avatar
Senior Member
Thanks Meter 64
Posts: 261
Join Date: Dec 2010
Location: Springfield, MO
Quote:
Originally Posted by msgfromside3 View Post
That has been normal behavior of almost anything for last couple of years because it is trying to scan for available wifi (guess what happens then?). I am not sure if it is still true, but you are supposed to be able to tweak the rescan interval from build.prop. I haven't done that for ages and I now turn my wifi off as soon as I get in my car.
Quote:
Originally Posted by Phalanx7621 View Post
Yeah you can set your Wi-Fi scan interval to a higher amount to lessen the battery drain, as stated above in your build.prop, or just turn it off when not in use. I normally turn it off.
Got ya. Thanks guys

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes