Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Port AOSP 4.1 Camera to 4.2 Rom

OP brotherandyslb

15th February 2013, 06:14 AM   |  #1  
OP Member
Thanks Meter: 2
 
38 posts
Join Date:Joined: Nov 2009
As the title states, how would one go about porting an 4.1 camera to 4.2? I really need a stable camera I can rely on and none of the current 4.2 Roms fit the bill. However, I really don't want to go back to 4.1.

Any help would be wonderful!
Last edited by brotherandyslb; 15th February 2013 at 06:16 AM. Reason: spell check broken
15th February 2013, 08:14 AM   |  #2  
x714x's Avatar
Senior Member
Flag Phoenix
Thanks Meter: 277
 
963 posts
Join Date:Joined: Sep 2012
More
You mean run the touchwiz camera on a AOSP rom? Or run the AOSP 4.1 camera on a 4.2 rom? If you are talking the touchwiz camera then the answer is no. Touchwiz stuff needs touchwiz framework to work properly which obviously AOSP does not. There are a lot of camera apps in the playstore with similar functions as the touchwiz camera that you can run. I personally like Procapture.
16th February 2013, 01:50 AM   |  #3  
OP Member
Thanks Meter: 2
 
38 posts
Join Date:Joined: Nov 2009
Quote:
Originally Posted by x714x

You mean run the touchwiz camera on a AOSP rom? Or run the AOSP 4.1 camera on a 4.2 rom? If you are talking the touchwiz camera then the answer is no. Touchwiz stuff needs touchwiz framework to work properly which obviously AOSP does not. There are a lot of camera apps in the playstore with similar functions as the touchwiz camera that you can run. I personally like Procapture.

As stated, I'm talking about the AOSP 4.1 camera on 4.2. Not talking about touchwiz.

The 4.2 camera is extremely buggy at least for me. The 4.1 camera was rock solid.
16th February 2013, 06:56 AM   |  #4  
OP Member
Thanks Meter: 2
 
38 posts
Join Date:Joined: Nov 2009
Anyone? Or does anyone know what all files the camera needs to operate so I can copy one over myself?
17th February 2013, 04:13 AM   |  #5  
OP Member
Thanks Meter: 2
 
38 posts
Join Date:Joined: Nov 2009
After several tries, all I have managed to do is soft brick the phone, alot. Does anyone else want to solve this problem?
17th February 2013, 04:45 AM   |  #6  
PsiPhiDan's Avatar
Senior Member
Flag Plainfield
Thanks Meter: 635
 
2,120 posts
Join Date:Joined: Oct 2011
More
Re: [Q] Port AOSP 4.1 Camera to 4.2 Rom
I don't think anyone else is having camera issues on 4.2, so you're probably not going to get a lot of support here. What issues are you having? Is never had one yet on 4.2, and I use the camera often, as I have an infant.

Sent from my SCH-I535 using xda app-developers app
17th February 2013, 05:04 AM   |  #7  
OP Member
Thanks Meter: 2
 
38 posts
Join Date:Joined: Nov 2009
Frequent FCs, sometimes rebooting will fix, other times I have to re-flash the rom. I too have an infant (2 wks old tomorrow) and a 2yr old. I also use the camera quite often for work. I know I am not the only one having the FC issues, I just don't know why it doesn't happen to others as well. When I flash a new rom I always Factory Reset, Wipe Cache/Dalvik, and Wipe System. Then flash, boot to system, wait a few minutes, reboot to recovery, flash gapps, then restore with titanium. The only camera that worked great (aside from TW of course) was the AOSP 4.1 Camera. All 4.2 cameras have failed.
mentose457
17th February 2013, 07:23 AM   |  #8  
Guest
Thanks Meter: 0
 
n/a posts
Quote:
Originally Posted by brotherandyslb

Frequent FCs, sometimes rebooting will fix, other times I have to re-flash the rom. I too have an infant (2 wks old tomorrow) and a 2yr old. I also use the camera quite often for work. I know I am not the only one having the FC issues, I just don't know why it doesn't happen to others as well. When I flash a new rom I always Factory Reset, Wipe Cache/Dalvik, and Wipe System. Then flash, boot to system, wait a few minutes, reboot to recovery, flash gapps, then restore with titanium. The only camera that worked great (aside from TW of course) was the AOSP 4.1 Camera. All 4.2 cameras have failed.

I assume you have tried pulling the gallery app from a 4.1 rom and pushed it to /system/app/ on your phone. If not give that a try. Im not fully confident it will work but you might get lucky.
17th February 2013, 08:09 AM   |  #9  
OP Member
Thanks Meter: 2
 
38 posts
Join Date:Joined: Nov 2009
Quote:
Originally Posted by mentose457

I assume you have tried pulling the gallery app from a 4.1 rom and pushed it to /system/app/ on your phone. If not give that a try. Im not fully confident it will work but you might get lucky.


Yes, I have tried just the APK. Doing that results in the camera becoming non functional. Then I expanded removed gmscore.apk and 2 lib files then added gallery.apk from 4.1 along with several files merged in to all folders set permissions, reboot ... soft brick. I'm not 100% sure what files the camera relies on and what files the system relies on. What I'd like to do is pinpoint down every file the camera relies on in both 4.1 and 4.2 then make the proper changes. I'm just not sure of how to do that. I've downloaded several different flashable cameras and it seems that each one has different files.

Post Reply Subscribe to Thread

Tags
4.1, 4.2, aosp, camera, port
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes