Make Your Network Smart – XDA Xposed Tuesday

We rave about the features and abilities of our smartphones. However, in order for … more

Dr.Ketan Brings The S6 Theme Store To The Note 4

Dr.Ketan has submitted a video to the forums showing a functional port of the Galaxy S6 … more

Do You Have Insurance on Your Smartphone?

While affordable smartphones are becoming more available, the majority of high-end flagships … more

Apple Music Will Increase iTunes Match to 100,000 Songs

The battle for music streaming subscription dominance is starting to really heat … more

[HOW-TO] Downgrade from JB to ICS with locked bootloader

270 posts
Thanks Meter: 464
By cedesmith, Retired Recognized Developer on 7th October 2012, 03:41 PM
Post Reply Subscribe to Thread Email Thread
17th February 2013, 08:18 PM |#91  
Thanks Meter: 3
I am actually not using a microSD I am using the internal sd card memory, I don't know if that changes anything. And by the way I don't get the system update notification. Anyone could help us fellow members?!
21st February 2013, 11:01 PM |#92  
cowhow's Avatar
Flag Fort Worth, Texas
Thanks Meter: 17

Posted by johnlgalt -

This was already posted elsewhere b/c it is how I rooted my JB 4 days ago. I think it was Praetorian or jrotsky who posted it.

I tried the same method with trying to revert to but that is a no go - only will revert to

So, for those of us who are on how do we revert to a NVflashable version? I'm unlocked but otherwise stock. But, in the event it isn't possible to revert to ICS what's the real world risk? I mean, I've flashed phones and other tablets countless times without bricking. I know that's always a possibility, but you have to almost try to brick a phone. I would think installing TWRP or CWM would present just as great, or greater, of a risk. Educate me, but don't flame me. Are there risks in flashing the TF700 I'm not aware of?
23rd February 2013, 01:04 AM |#93  
buhohitr's Avatar
Senior Member
Thanks Meter: 1,649
Re: [HOW-TO] Downgrade from JB to ICS with locked bootloader
It's not possible to flash back to NVflash version. Asus had sealed the hole when they released .30 ICS bootloader version.

Sent from my ASUS Transformer Pad TF700T using xda premium
23rd February 2013, 12:43 PM |#94  
Thanks Meter: 3
Hi guys just to let you know that I downgraded and rooted my device using the method mentioned here. What I did was downloaded the .30 ICS firmware unzipped (one time) and renamed as the OP mentioned, then I had one copy of this .zip file to my internal memory root and one to an external microSD root. I inserted the microSD on the slot and turned off the tab. Pressed the Vol down and Power button and entered RCK (stock BTW). It then displayed the working driod (no message displayed) and after the reboot I was on ICS (took some while though)!!!! I then downloaded the latest firmware, rooted using the guide on the all-in-one guide for TF700, installed OTA Rootkeeper, temporally unroot with rootkeeper installed the latest firmware, recovered root with Rootkeeper. And now I have a properly JB rooted device. Thanks xda members and all devs!
Last edited by nanias; 23rd February 2013 at 12:45 PM.
28th February 2013, 10:17 AM |#95  
rocer's Avatar
Thanks Meter: 5
Cold Boot
I too was getting the exclamation mark and the dead droid. I read somewhere that doing a cold boot cleans useless clutter and makes the tablet run faster. Just for the heck of it I tried doing this downgrade after a cold boot and it worked for me.

To do a Cold Boot:
- Turn off Tablet
- Hold down Power and Volume Down button
- When you get to the menu DON'T select anything. In small font in the top left corner it says "OS will Cold Boot in 10 seconds if nothing is selected" or something like that So just wait longer than 10 seconds and let your device Cold Boot.
- After Cold Boot, turn off tablet and follow the OP.

Good luck.
28th February 2013, 06:13 PM |#96  
Thanks Meter: 4
Full of hope tried a cold boot and a downgrade. Useless for me, still the red triangle / dead droid
28th February 2013, 10:07 PM |#97  
Flag Trowbridge, Wiltshire
Thanks Meter: 3
Is there another link for the firmware to downgrade to ICS. I have clicked the link in the OP but when I get directed to the Asus support page and select my OS it doesn't give me any OS's to select, just sticks at select OS


Found the firmware here
Last edited by davetwin; 28th February 2013 at 11:19 PM.
28th February 2013, 11:10 PM |#98  
Flag Trowbridge, Wiltshire
Thanks Meter: 3
Originally Posted by Falkenhorst

I tried to downgrade with the steps from first post but wasn't successfull with the latest firmware version .23
There is a simple way to downgrade anyway.

1. copy the firmware to the root folder of your internal memory
2. don't rename it, just leave the original name (for example "")
3. reboot your device
4. you find a message for downgrading your firmware in the notification drawer

This is what worked for me, all other methods described in this thread resulted in the android with red exclamation mark.
1st March 2013, 11:58 AM |#99  
TheReino's Avatar
Thanks Meter: 5
No root
Hello guys,

I just don't get it right. The Downgrade works but for me it is not possible to keep root after upgrading to jb.

I took the " " and put it on my microSD. Renamed it to "" and went into recovery. The downgrade process started und I was able to root the TF700 with the "RootDebugfs.bat" method.

After that I installed the SuperSU app, started it and made the recommended update. I even marked the checkbox ota survival in the superuser app. Aftewards I loaded and installed the Voodoo OTA root keeper and said "protect root".

All checkboxes were marked and I hit the button temp unroot.

Now I tried to start an OTA Update but it always said that there are no updates available. I cleared DMclient and CMclient data + force close but no change.

So I took the "" Update and updated it to jb again with renaming to "".
Recovery started. The update goes well but the OTA rootkeeper app is not able to restore root. -> No backup of su-binary available...

What am I doing wrong?!

Unlocking doesn't work either. Problem with internet connection, please try again later. Whats wrong with this tab?!
1st March 2013, 04:47 PM |#100  
Thanks Meter: 4
Originally Posted by davetwin

This is what worked for me, all other methods described in this thread resulted in the android with red exclamation mark.

Same here
Removed the MicroSD, placed the original .30 (not renamed) on the root of the TF700 and the downgrade got detected right away.
I accepted the downgrade and it succeeded (maybe because of the cold reset earlier).

Anyway I'm root again and now downloading the upgrade using the normal OTA.

Edit: upgraded to JB .25 and succesfully restored root.
Last edited by DarkFire1985; 1st March 2013 at 05:14 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes