Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,847 Members 53,505 Now Online
XDA Developers Android and Mobile Development Forum

[ROM] CM 10.1 (Android 4.2) for RazrHD XT925/XT926

Tip us?
 
madmonkey57
Old
(Last edited by madmonkey57; 18th February 2013 at 02:42 PM.)
#251  
madmonkey57's Avatar
Senior Member
Thanks Meter 245
Posts: 523
Join Date: Oct 2012
Quote:
Originally Posted by epinter View Post
on 4.2.2, the same bootloops previously caused by the sensors, but this time the sensors are working.
Camera? EDIT: I mean, if you are investigating the camera, it could very well be related... Just a hunch...
Motorola RAZR HD (XT925) running CyanogenMod 11.0 (3.0 kernel version aka JB BL / 3.4 kernel version aka KK BL)
 
epinter
Old
#252  
epinter's Avatar
Recognized Developer - OP
Thanks Meter 7,320
Posts: 896
Join Date: Feb 2011
Location: Sao Paulo

 
DONATE TO ME
Quote:
Originally Posted by madmonkey57 View Post
Camera? EDIT: I mean, if you are investigating the camera, it could very well be related... Just a hunch...
Even after remove the camera hal I get bootloops.
Support my work, donate to me using my website or forum post donation buttons.
 
epinter
Old
(Last edited by epinter; 18th February 2013 at 03:03 PM.)
#253  
epinter's Avatar
Recognized Developer - OP
Thanks Meter 7,320
Posts: 896
Join Date: Feb 2011
Location: Sao Paulo

 
DONATE TO ME
you can test:
http://goo.im/devs/epinter/cm-10.1-2...nter-xt925.zip
Remember, this is a preview of 4.2.2, the first bug I noticed was the random bootloop. may have more bugs.
Support my work, donate to me using my website or forum post donation buttons.
 
madmonkey57
Old
#254  
madmonkey57's Avatar
Senior Member
Thanks Meter 245
Posts: 523
Join Date: Oct 2012
Quote:
Originally Posted by epinter View Post
you can test:
http://goo.im/devs/epinter/cm-10.1-2...nter-xt925.zip
Remember, this is a preview of 4.2.2, the first bug I noticed was the random bootloop. may have more bugs.
I will give this a try.
Motorola RAZR HD (XT925) running CyanogenMod 11.0 (3.0 kernel version aka JB BL / 3.4 kernel version aka KK BL)
 
manuski
Old
#255  
manuski's Avatar
Senior Member
Thanks Meter 9
Posts: 132
Join Date: Sep 2010
Default Re: [ROM] CM 10.1 (Android 4.2) for RazrHD XT925

Quote:
Originally Posted by epinter View Post
you can test:
http://goo.im/devs/epinter/cm-10.1-2...nter-xt925.zip
Remember, this is a preview of 4.2.2, the first bug I noticed was the random bootloop. may have more bugs.
Is it possible if you can port one over for the 926? I saw you had one but it boot loops. I can help if you need by giving logs if you'd like. Thanks

Sent from my DROID RAZR HD using Tapatalk 2
 
uropb
Old
#256  
Junior Member
Thanks Meter 18
Posts: 22
Join Date: Jan 2013
Location: moscow
Quote:
Originally Posted by epinter View Post
you can test:
http://goo.im/devs/epinter/cm-10.1-2...nter-xt925.zip
Remember, this is a preview of 4.2.2, the first bug I noticed was the random bootloop. may have more bugs.
can it be applied without wiping data and cashe? i'm on 10.1 from 01.26.13
 
epinter
Old
#257  
epinter's Avatar
Recognized Developer - OP
Thanks Meter 7,320
Posts: 896
Join Date: Feb 2011
Location: Sao Paulo

 
DONATE TO ME
Quote:
Originally Posted by uropb View Post
can it be applied without wiping data and cashe? i'm on 10.1 from 01.26.13
Yes, without wipe. Always keep your backup updated!
Support my work, donate to me using my website or forum post donation buttons.
The Following 2 Users Say Thank You to epinter For This Useful Post: [ Click to Expand ]
 
madmonkey57
Old
#258  
madmonkey57's Avatar
Senior Member
Thanks Meter 245
Posts: 523
Join Date: Oct 2012
Quote:
Originally Posted by madmonkey57 View Post
I will give this a try.
Well I tried like 15 reboots with no success... Each time I cleared /cache, the system rebuilt it, and then got stuck at "Starting apps...". Otherwise, endless CM cycling logo... After that, I tried to "Fix permissions" within CWM, the system froze... It felt like the filesystem couldn't get mounted... Further reboots would end up turning the screen black once passed the boot logo with no apparent sign of booting... Seems like I' back to square one...
Motorola RAZR HD (XT925) running CyanogenMod 11.0 (3.0 kernel version aka JB BL / 3.4 kernel version aka KK BL)
 
hadonf
Old
(Last edited by hadonf; 18th February 2013 at 07:49 PM.)
#259  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Aug 2008
Hello, working here for me from the previous version without wipe. But the play store crashes evertime I click on the install button, and the GPS doesn't fix..
And by the way, keep the great work on this, the rom is fantastic apart the known bugs!

Edit: the market is working now with the camera.msm8960.so removed...
 
madmonkey57
Old
(Last edited by madmonkey57; 19th February 2013 at 08:57 AM.)
#260  
madmonkey57's Avatar
Senior Member
Thanks Meter 245
Posts: 523
Join Date: Oct 2012
Quote:
Originally Posted by madmonkey57 View Post
Well I tried like 15 reboots with no success... Each time I cleared /cache, the system rebuilt it, and then got stuck at "Starting apps...". Otherwise, endless CM cycling logo... After that, I tried to "Fix permissions" within CWM, the system froze... It felt like the filesystem couldn't get mounted... Further reboots would end up turning the screen black once passed the boot logo with no apparent sign of booting... Seems like I' back to square one...
Restored my CM10.1 backup, booted OK. Then restarted all over again. It only took a couple of reboots and it worked at last... Didn't do anything different though...

EDIT: Yes, one thing different, I did an extra step. Right after installing the ROM, I installed gapps as well.
EDIT2: Play Store works out of the box. Elixir reports that all sensors are working fine.
EDIT3: Logcat excerpts:

Plenty of
Code:
09:14:12.476 <5875>[dalvikvm]: could not disable core file generation for pid 5875: Operation not permitted
... and
Code:
09:14:12.526 <5875>[Trace]: error opening trace file: Permission denied (13)
About sensors
Code:
09:14:49.546 <689>[MotoSensors]: CT406 set ALS poll interval: 1000
09:25:24.446 <689>[MotoSensors]: CT406 set ALS poll interval: 200
09:25:24.446 <689>[qcom_sensors_hal]: _hal_sensors_set_delay: max_freq = 0. unsupported sensor? handle:22
09:25:24.446 <689>[MotoSensors]: CT406 set ALS poll interval: 1000
09:25:24.446 <689>[qcom_sensors_hal]: _hal_sensors_set_delay: max_freq = 0. unsupported sensor? handle:22
09:25:25.727 <689>[qcom_sensors_hal]: hal_wait_for_response: pthread_cond_timedwait() rc=110
09:25:25.727 <689>[qcom_sensors_hal]: hal_get_raw_data_mode: Unable to receive raw data mode value
Audio input
Code:
09:25:54.975 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.105 <270>[ALSADevice]: cannot set hw params
09:25:55.105 <270>[ALSADevice]: Set HW/SW params failed: Closing the pcm stream
09:25:55.165 <270>[AudioHardwareALSA]: Error opening pcm input device
09:25:55.165 <6431>[AudioRecord]: Could not get audio input for record source 1
09:25:55.165 <6431>[AudioRecord-JNI]: Error creating AudioRecord instance: initialization check failed.
09:25:55.165 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] Error code -20 when initializing native AudioRecord object.
09:25:55.165 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.175 <270>[ALSADevice]: cannot set hw params
09:25:55.175 <270>[ALSADevice]: Set HW/SW params failed: Closing the pcm stream
09:25:55.215 <270>[AudioHardwareALSA]: Error opening pcm input device
09:25:55.215 <6431>[AudioRecord]: Could not get audio input for record source 1
09:25:55.215 <6431>[AudioRecord-JNI]: Error creating AudioRecord instance: initialization check failed.
09:25:55.215 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] Error code -20 when initializing native AudioRecord object.
09:25:55.215 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
09:25:55.215 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
09:25:55.225 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.235 <270>[ALSADevice]: cannot set hw params
09:25:55.235 <270>[ALSADevice]: Set HW/SW params failed: Closing the pcm stream
09:25:55.265 <270>[AudioHardwareALSA]: Error opening pcm input device
09:25:55.265 <6431>[AudioRecord]: Could not get audio input for record source 1
09:25:55.265 <6431>[AudioRecord-JNI]: Error creating AudioRecord instance: initialization check failed.
09:25:55.265 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] Error code -20 when initializing native AudioRecord object.
09:25:55.265 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.285 <270>[ALSADevice]: cannot set hw params
09:25:55.285 <270>[ALSADevice]: Set HW/SW params failed: Closing the pcm stream
09:25:55.315 <270>[AudioHardwareALSA]: Error opening pcm input device
09:25:55.315 <6431>[AudioRecord]: Could not get audio input for record source 1
09:25:55.315 <6431>[AudioRecord-JNI]: Error creating AudioRecord instance: initialization check failed.
09:25:55.315 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] Error code -20 when initializing native AudioRecord object.
09:25:55.315 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
09:25:55.315 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
09:25:55.315 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.335 <270>[ALSADevice]: cannot set hw params
09:25:55.335 <270>[ALSADevice]: Set HW/SW params failed: Closing the pcm stream
09:25:55.395 <270>[AudioHardwareALSA]: Error opening pcm input device
09:25:55.395 <6431>[AudioRecord]: Could not get audio input for record source 1
09:25:55.395 <6431>[AudioRecord-JNI]: Error creating AudioRecord instance: initialization check failed.
09:25:55.395 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] Error code -20 when initializing native AudioRecord object.
09:25:55.395 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.415 <270>[ALSADevice]: cannot set hw params
09:25:55.415 <270>[ALSADevice]: Set HW/SW params failed: Closing the pcm stream
09:25:55.455 <270>[AudioHardwareALSA]: Error opening pcm input device
09:25:55.455 <6431>[AudioRecord]: Could not get audio input for record source 1
09:25:55.455 <6431>[AudioRecord-JNI]: Error creating AudioRecord instance: initialization check failed.
09:25:55.455 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] Error code -20 when initializing native AudioRecord object.
09:25:55.455 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
09:25:55.455 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
09:25:55.465 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.515 <270>[ALSADevice]: dlsym:Error:(null) Loading acdb_loader_get_ecrx_device
09:25:55.535 <270>[ALSADevice]: cannot set hw params
09:25:55.535 <270>[ALSADevice]: Set HW/SW params failed: Closing the pcm stream
09:25:55.575 <270>[AudioHardwareALSA]: Error opening pcm input device
09:25:55.575 <6431>[AudioRecord]: Could not get audio input for record source 1
09:25:55.575 <6431>[AudioRecord-JNI]: Error creating AudioRecord instance: initialization check failed.
09:25:55.575 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] Error code -20 when initializing native AudioRecord object.
09:25:55.575 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
09:25:55.575 <6431>[AudioRecord-Java]: [ android.media.AudioRecord ] getMinBufferSize(): Invalid audio format.
Motorola RAZR HD (XT925) running CyanogenMod 11.0 (3.0 kernel version aka JB BL / 3.4 kernel version aka KK BL)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes