Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,594 Members 54,075 Now Online
XDA Developers Android and Mobile Development Forum

[Q] WiFi Does Not Connect >5.7GHz

Tip us?
 
klau1
Old
#1  
Senior Member - OP
Thanks Meter 353
Posts: 1,612
Join Date: Jan 2008
Question [Q] WiFi Does Not Connect >5.7GHz

Quote:
I ran into the same issue with an E2500 and returned it but subsequently discovered the issue is with the Galaxy Tab 10.1. When you specify automatic channel assignement the router may choose a channel in the higher part of the band around 5.7GHz. This does not work with the Samsung... you must assign a chennel in the low part of the band in the 5.4GHz segment. Then it will work fine. This would seem to be a bug with the Galaxy 10.1.
-source: http://homecommunity.cisco.com/t5/Wi.../457089/page/2

I found out this is also a problem with my Note 10.1.

If I set the 5GHz band to be in the 5.4GHz channels, the Note 10.1 can see the 5GHz WiFi, but if I set it to channels above 5.7GHz or Auto, it will not see the 5GHz WiFi.

Anyone have some experience with this?

Please Thanks if it helped!






Tablet:
OS:
Kernel Version:
Build number:
Modifications:
 
mel897
Old
#2  
Junior Member
Thanks Meter 3
Posts: 5
Join Date: May 2012
Default Galaxy 5GHz HiBand (>5.7GHz) not working

I found out this is also a problem with my Note 10.1.

If I set the 5GHz band to be in the 5.4GHz channels, the Note 10.1 can see the 5GHz WiFi, but if I set it to channels above 5.7GHz or Auto, it will not see the 5GHz WiFi.

Anyone have some experience with this?[/QUOTE]

The issue is with a configuration file... here is the fix for the Tab 10.1... it should be similar for the Note.

Galaxy Tab 10.1 5GHz HiBand Wifi Fix

There is an issue with the Galaxy Tab 10.1 (and apparently many other Galaxies) only working on the lower 5GHz channels because it is configured for the UK

You need to update the Country Code (ccode) in nvram_net.txt
You need root to do this.

In /system/etc/wifi there are two files:
nvram_net.txt and nvram_net.txt.us

The installed one is for Great Britain, and the other one (.us) is for the United States.

Rename nvram_net.txt to nvram_net.txt.gb and rename nvram_net.txt.us to nvram_net.txt
Or make the following changes to the current configuration file:
Change "ccode=GB" to "ccode=US" and add immediately after "regrev=5".

The files might be slightly different, but look for the ccode=GB line and change it to =US or =ALL

I haven't fixed my new Note yest, but if I run into any difficulties I will repost
The Following User Says Thank You to mel897 For This Useful Post: [ Click to Expand ]
 
mel897
Old
#3  
Junior Member
Thanks Meter 3
Posts: 5
Join Date: May 2012
It is slightly different for the Note 10.1

The file you need to modify in /etc/wifi is nvram_net.txt_murata
The Following 2 Users Say Thank You to mel897 For This Useful Post: [ Click to Expand ]
Tags
5ghz, wifi
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes