Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,126 Members 42,638 Now Online
XDA Developers Android and Mobile Development Forum

Touch Screen working but backlight is really dim! HELP!:(

Tip us?
 
HussnainTariq
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Feb 2011
Location: Brampton
Unhappy Touch Screen working but backlight is really dim! HELP!:(

So, a few days ago i received my xperia arc s housing in the mail from ebay, So the next thing i do is replace the housing and put it back together, Its all working but i notice the back button not working, open the phone up again and mess around a bit while the battery was still in the phone, but then the screen stopped working, and i just put it back together cause i couldn't do anything about it. The touch screen works but it doesn't not display anything, i can start up the phone and unlock the screen and feel the vibrations but the display is really dim, like if i take a flashlight and put it over the screen, i can see everything but when i take the flashlight away i cant see anything, The LEDs near in the home buttons are not working either. What some one did suggest is that the chip that controls the LED's are at fault and damaged. Any other suggestions would be highly appreciated.

Thank You
 
showlyshah
Old
#2  
showlyshah's Avatar
Senior Member
Thanks Meter 523
Posts: 792
Join Date: Mar 2011
Location: kerala
Default Re: Touch Screen working but backlight is really dim! HELP!:(

U must check the flex cable to the display, ( make sure u do disconnect and reconnect it with out battery) ,reinsert batt and then check.
U must check if u have damaged any flex cable or left any scratch marks on any circuit boards etc which may cause any damage to the signal/supply lines.( use a magnifying glass)
U must check for some damaged components like smd resistor,capacitor etc..
If nothing helps, gave it to authorized service center.

Sent from my NexusHD2 using xda premium
N3410>N1100>N1110>SE K800I>SE W850I>SE W715I>SE W995I>SE C905I>SATIO> HTC WILDFIRE> HTC HD7>HTC HD2> XPERIA Z> XPERIA Z1

PLEASE READ THIS B4 U ASK QUESTIONShttp://forum.xda-developers.com/showpost.php?p=18289016&postcount=1
 
Jtlaraia
Old
#3  
Junior Member
Thanks Meter 0
Posts: 16
Join Date: Aug 2011
Quote:
Originally Posted by showlyshah View Post
U must check the flex cable to the display, ( make sure u do disconnect and reconnect it with out battery) ,reinsert batt and then check.
U must check if u have damaged any flex cable or left any scratch marks on any circuit boards etc which may cause any damage to the signal/supply lines.( use a magnifying glass)
U must check for some damaged components like smd resistor,capacitor etc..
If nothing helps, gave it to authorized service center.

Sent from my NexusHD2 using xda premium
^^ Its probably the cable, check all your connections, and buy a test light or little multimeter for a few bucks to make sure everything is getting power.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes