How Open Source Can Help Your Project w/ Ethan Yonker – BABBQ2014

People have finally recovered from this years Big Android BBQ … more

Add Frequency Bands to Your Qualcomm Device

Those of you who travel quite a bit undoubtedly own more than one device due to frequency band … more

More Android 5.0 Details Revealed, Microsoft Band Fitness Tracker – XDA TV

Google talks more about Android 5.0 Lollipop! That and much … more

Google Allows Search Queries To Interact With Apps

Android 5.0 Lollipop brings lots of new features that are quite useful for end users and … more
Post Reply

[Q] Charging over USB through PC

OP Grop

23rd February 2013, 10:50 AM   |  #1  
OP Member
Thanks Meter: 7
 
52 posts
Join Date:Joined: Feb 2013
Hello,

I am new here and have found some answers but no solution for this problem, so I try again by a new thread (sorry if I missed an answer)

I want to charge my tab through the usb connection to my pc or in my car and not only through the AC-adapter.

In the development discussion is this theme going on (page 101):
Quote:
Originally Posted by jaswinky
With the console apk in the device directly:

1|u0_a40@android:/ $ adb shell echo 1 > /sys/class/power_supply/battery/force_usb_charging
/system/bin/sh: can't create /sys/class/power_supply/battery/force_usb_charging: Permission denied
1|u0

I don't kmow why this error, I am root, but anyway, I changed this value directly using root explorer and a text editor and it works for me, now I have enabled usb and non-samsung-charger charging.

Thanks a lot!
Enviado desde mi GT-P7510 usando Tapatalk 2

You are using Terminal Emulator ? If yes then no need to write adb shell, just su first then echo 1 > /sys/class/power_supply/battery/force_usb_charging
I followed this instruction by Using the Terminal Emulator. Changing to "1" works fine until I restart my tab, than its back to "0" and I do have to change it again.

How can I keep the wanted setting to "1" ?

Thanks for help in advance

Peter

Samsung Galaxy Tab 10.1 P7500 3G + Wifi
Latest nightly CM10.1 JB 4.2.2
TWRP 2.4.1.0
Last edited by Grop; 23rd February 2013 at 11:02 AM. Reason: adding info
23rd February 2013, 01:54 PM   |  #2  
John Kester's Avatar
Senior Member
Flag Port Harcourt
Thanks Meter: 106
 
277 posts
Join Date:Joined: Dec 2012
Re: [Q] Charging over USB through PC
CM10 and 10.1 Jellybean come with USB charging already enabled. Wonder why yours doesn't work. Anyway you may need to change your kernel first before activating the feature. I heard A1 kernel works great, I use Pershoot kernels in both JB 4.1.2 and 4.2.1 which I interchange depending on what I need to do. Both have the feature. I also use stock ICS but I never bothered with the feature there.

Sent from my GT-P7500 using xda app-developers app
The Following User Says Thank You to John Kester For This Useful Post: [ View ]
23rd February 2013, 03:07 PM   |  #3  
OP Member
Thanks Meter: 7
 
52 posts
Join Date:Joined: Feb 2013
Thumbs up
John,

Thanks for your help.

Changed the kernel to the A1 1.8.4. P4 G3 and its working again.

I had the Kernel 3.1.10 from CM from somewhere in Januari on it and somewhere it went wrong with that one.

The A1 is doing what I needed.

Thanks

Peter
28th February 2013, 07:02 PM   |  #4  
OP Member
Thanks Meter: 7
 
52 posts
Join Date:Joined: Feb 2013
Storage problem not solved
Today I updatet to the nightly 28-02 and noticed that charging over usb connection is not working. The kernel is back to 3.1.10-cyanogenmod+root@pershoot-ubuntu#4 Wed jan 16 05:31:00EST 2013 and guess what:

Charging through a usb connection to PC is disabled.

So I have to change the Kernel back to the A1 again.
28th February 2013, 07:08 PM   |  #5  
OP Member
Thanks Meter: 7
 
52 posts
Join Date:Joined: Feb 2013
Storage kernel changed
Changed the Kernel to A1 version: 3.1.10_A1_V1.8.4. Daniel@Daniel3 #283 Sun Dec 23 16.02.03 EST 2012.

USB charging is working!

So I presume that in the Pershoots Nightly the Kernel is disabling usb charging. Or is there another way to activate the usb-charging?

Peter
5th March 2013, 12:27 PM   |  #6  
OP Member
Thanks Meter: 7
 
52 posts
Join Date:Joined: Feb 2013
Did a full wipe and installed the cm10.1 - 20130301 Nightly. Same issue. Had to install the A1 kernel again.
5th March 2013, 12:38 PM   |  #7  
OP Member
Thanks Meter: 7
 
52 posts
Join Date:Joined: Feb 2013
Updated to todays version 05/03/2013. Noticed that the Kernel has been updated to: 3.1.10-cyanogenmod+root@pershoot-ubuntu#4 SunMar 3 19:35:46 EST 2013.

No charging over usb connection.

Changed to A1 and charging is working.
5th March 2013, 08:08 PM   |  #8  
Recognized Developer
Thanks Meter: 3,857
 
7,728 posts
Join Date:Joined: Dec 2008
Quote:
Originally Posted by Grop

Updated to todays version 05/03/2013. Noticed that the Kernel has been updated to: 3.1.10-cyanogenmod+root@pershoot-ubuntu#4 SunMar 3 19:35:46 EST 2013.

No charging over usb connection.

Changed to A1 and charging is working.

you have to activate it.

the instructions are right above you. must be root.

i had it enabled automatically (for a short time), but this cauised issues with certain tabs in the suite (the touchscreen would go bonkers) when plugged in and booting, so i removed it. its also safer not to have it on by default, because not all pcs can supply a consistent voltage output. if the power going to the battery is waivering, it could potentially cause issue.

samsung did not have this enabled at all (probably for that very reason).
Last edited by pershoot; 5th March 2013 at 08:23 PM.
The Following User Says Thank You to pershoot For This Useful Post: [ View ]
5th March 2013, 10:35 PM   |  #9  
OP Member
Thanks Meter: 7
 
52 posts
Join Date:Joined: Feb 2013
Thanks
Pershoot,

Thank you for your reply. The solution of activating as I copied above is only working until the next reboot.

I now understand why you did not activate this, and I will take good notice of your advice. Nevertheless it is rather strange that I do not experience any problem using the A1 kernel.

Greatings,

Peter
5th March 2013, 10:56 PM   |  #10  
Recognized Developer
Thanks Meter: 3,857
 
7,728 posts
Join Date:Joined: Dec 2008
Quote:
Originally Posted by Grop

Pershoot,

Thank you for your reply. The solution of activating as I copied above is only working until the next reboot.

I now understand why you did not activate this, and I will take good notice of your advice. Nevertheless it is rather strange that I do not experience any problem using the A1 kernel.

Greatings,

Peter

dont forget, thousands of people and their tabs have to be attenuated for with any changes done. it may work for you and your tab, but that doesn't mean it will work out for anyone else and their tabs.

there's a lot of variance there.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes